summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/php/php_5.5.21.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/php/php_5.5.21.bbappend')
-rw-r--r--recipes-devtools/php/php_5.5.21.bbappend12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-devtools/php/php_5.5.21.bbappend b/recipes-devtools/php/php_5.5.21.bbappend
index b556e19..8d94a83 100644
--- a/recipes-devtools/php/php_5.5.21.bbappend
+++ b/recipes-devtools/php/php_5.5.21.bbappend
@@ -13,6 +13,18 @@ EXTRA_OECONF += " --without-pear"
#for its installation to succeed
RDEPENDS_${PN}-cli_remove = "${PN}"
+#The SDK image seeks *-dev packages and if we do not provide one for
+#php-cli then it will revert to trying to install php-dev, which in turn
+#depends on package php that is empty due to pear being disabled. As a
+#workaround we provide a dev package for php-cli that contains all that is
+#in php-dev (since php-cli contains the php binary anyway)
+PACKAGES += "${PN}-cli-dev"
+FILES_${PN}-cli-dev = "${includedir}/php ${PHP_LIBDIR}/build ${bindir}/phpize \
+ ${bindir}/php-config ${PHP_LIBDIR}/php/.depdb \
+ ${PHP_LIBDIR}/php/.depdblock ${PHP_LIBDIR}/php/.filemap \
+ ${PHP_LIBDIR}/php/.lock ${PHP_LIBDIR}/php/test"
+FILES_${PN}-dev = ""
+
# the do_install_append and do_install_prepend tasks are cumulative so we
# cannot overwrite the do_install_append_ph-php() task that is already in
# the main recipe (meta-openembedded/meta-oe/recipes-devtools/php/php.inc).