summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/iotools/iotools_1.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/iotools/iotools_1.5.bb')
-rw-r--r--recipes-devtools/iotools/iotools_1.5.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/recipes-devtools/iotools/iotools_1.5.bb b/recipes-devtools/iotools/iotools_1.5.bb
index c49bf8a..bc980fa 100644
--- a/recipes-devtools/iotools/iotools_1.5.bb
+++ b/recipes-devtools/iotools/iotools_1.5.bb
@@ -5,6 +5,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
SRC_URI = "https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/iotools/iotools-1.5.tar.gz"
+SRC_URI += "file://Makefile.patch"
SRC_URI[md5sum] = "64c27488a70866577cf99044aa01e28d"
SRC_URI[sha256sum] = "3186ba296072f644dda881b78d77e3774b79e8cef3e828fffc947d558b08830d"
@@ -17,9 +18,13 @@ do_compile () {
do_install () {
install -d ${D}${sbindir}
- oe_runmake SBINDIR=${D}${sbindir} install
- #The Makefile installs files with "cp -a" which preserves ownership
- #of user running bitbake resulting in QA Issue "host-user-contaminated"
- #Fixup permissions
- chown -R root:root ${D}${sbindir}
+ install -m 0755 ${B}/iotools ${D}${sbindir}/iotools
+}
+
+pkg_postinst_${PN} () {
+if [ -n "$D" ]; then
+ exit 1
+fi
+
+${sbindir}/iotools --make-links
}