summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/cpuid/cpuid_20180519.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/cpuid/cpuid_20180519.bb')
-rw-r--r--recipes-devtools/cpuid/cpuid_20180519.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-devtools/cpuid/cpuid_20180519.bb b/recipes-devtools/cpuid/cpuid_20180519.bb
new file mode 100644
index 0000000..b97a47d
--- /dev/null
+++ b/recipes-devtools/cpuid/cpuid_20180519.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Linux tool to dump x86 CPUID information about the CPU(s)"
+DESCRIPTION = "cpuid dumps detailed information about the CPU(s) gathered \
+from the CPUID instruction, and also determines the exact model of CPU(s). \
+It supports Intel, AMD, and VIA CPUs, as well as older Transmeta, Cyrix, \
+UMC, NexGen, Rise, and SiS CPUs"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz"
+SRC_URI[md5sum] = "b3b4e44ef49575043a91def0207dcc76"
+SRC_URI[sha256sum] = "967823be36f23cbc972eb0aa882d069c1d155a5978990ac3bcf425e6a2e7ff9a"
+
+# The install rule from the Makefile has hardcoded paths, so we duplicate
+# the actions to accommodate different paths.
+do_install () {
+ install -d -m755 ${D}/${bindir}
+ install -m755 ${B}/cpuid ${D}/${bindir}/cpuid
+ install -d -m755 ${D}/${mandir}
+ install -m444 ${B}/cpuid.man.gz ${D}/${mandir}
+}