summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/cpuid/cpuid_20160814.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/cpuid/cpuid_20160814.bb')
-rw-r--r--recipes-devtools/cpuid/cpuid_20160814.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-devtools/cpuid/cpuid_20160814.bb b/recipes-devtools/cpuid/cpuid_20160814.bb
new file mode 100644
index 0000000..45ae137
--- /dev/null
+++ b/recipes-devtools/cpuid/cpuid_20160814.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Linux tool to dump x86 CPUID information about the CPU(s)"
+DESCRIPTION = "cpuid dumps detailed information about the CPU(s) gathered \
+from the CPUID instruction, and also determines the exact model of CPU(s). \
+It supports Intel, AMD, and VIA CPUs, as well as older Transmeta, Cyrix, \
+UMC, NexGen, Rise, and SiS CPUs"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "http://www.etallen.com/cpuid/cpuid-20160814.src.tar.gz"
+SRC_URI[md5sum] = "b9d32005bedbb19f9b409dbb530f5510"
+SRC_URI[sha256sum] = "fd4e2b2d88f417ae32f47a92d29351de395a36578fde8aedc228e2e131f38ecd"
+
+# The install rule from the Makefile has hardcoded paths, so we duplicate
+# the actions to accommodate different paths.
+do_install () {
+ install -d -m755 ${D}/${bindir}
+ install -m755 ${B}/cpuid ${D}/${bindir}/cpuid
+ install -d -m755 ${D}/${mandir}
+ install -m444 ${B}/cpuid.man.gz ${D}/${mandir}
+}