summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/releaseinfo.bbclass7
-rw-r--r--conf/distro/systemdev.conf115
-rw-r--r--conf/layer.conf10
-rw-r--r--recipes-benchmarks/hdperf/hdperf_1.5.bb22
-rw-r--r--recipes-devtools/suspendresume/suspendresume_git.bb20
-rw-r--r--recipes-fixup/fb-test/fb-test_git.bbappend9
-rw-r--r--recipes-graphics/drm/libdrm_git.bbappend6
-rw-r--r--recipes-graphics/mesa/mesa_git.bbappend13
-rw-r--r--recipes-systemdev/images/systemdev-image-sdk.bb5
-rw-r--r--recipes-systemdev/images/systemdev-image-xfce-sdk.bb5
-rw-r--r--recipes-systemdev/images/systemdev-image-xfce.bb30
-rw-r--r--recipes-systemdev/images/systemdev-image.bb41
-rw-r--r--recipes-systemdev/images/systemdev-sdk.inc8
13 files changed, 291 insertions, 0 deletions
diff --git a/classes/releaseinfo.bbclass b/classes/releaseinfo.bbclass
new file mode 100644
index 0000000..961cc5a
--- /dev/null
+++ b/classes/releaseinfo.bbclass
@@ -0,0 +1,7 @@
+add_releaseinfo () {
+ echo "image: ${PN}" > ${IMAGE_ROOTFS}/${sysconfdir}/release
+ echo "machine: ${MACHINE}" >> ${IMAGE_ROOTFS}/${sysconfdir}/release
+ echo "version: ${DATETIME}" >> ${IMAGE_ROOTFS}/${sysconfdir}/release
+}
+
+ROOTFS_POSTPROCESS_COMMAND += " add_releaseinfo ; "
diff --git a/conf/distro/systemdev.conf b/conf/distro/systemdev.conf
new file mode 100644
index 0000000..99c483d
--- /dev/null
+++ b/conf/distro/systemdev.conf
@@ -0,0 +1,115 @@
+DISTRO = "systemdev"
+DISTRO_NAME = "Systemdev"
+DISTRO_VERSION = "0.1+snapshot-${DATE}"
+DISTRO_CODENAME = "systemdev"
+SDK_VENDOR = "-systemdevsdk"
+SDK_VERSION := "${@'${DISTRO_VERSION}'.replace('snapshot-${DATE}','snapshot')}"
+
+MAINTAINER = "Darren Hart <dvhart@linux.intel.com>"
+
+TARGET_VENDOR = "-systemdev"
+
+LOCALCONF_VERSION = "1"
+LAYER_CONF_VERSION ?= "6"
+
+# Override these in Systemdev based distros
+SYSTEMDEV_DEFAULT_DISTRO_FEATURES = "largefile x11 opengl ptest multiarch"
+SYSTEMDEV_DEFAULT_EXTRA_RDEPENDS = "packagegroup-core-boot"
+SYSTEMDEV_DEFAULT_EXTRA_RRECOMMENDS = "kernel-module-af-packet"
+
+DISTRO_FEATURES_append = " systemd"
+VIRTUAL-RUNTIME_init_manager = "systemd"
+DISTRO_FEATURES_BACKFILL_CONSIDERED = "sysvinit"
+VIRTUAL-RUNTIME_initscripts = ""
+
+DISTRO_FEATURES ?= "${DISTRO_FEATURES_DEFAULT} ${DISTRO_FEATURES_LIBC} ${SYSTEMDEV_DEFAULT_DISTRO_FEATURES}"
+
+# Prefer systemdev but accept poky overrides. This gets us the meta-yocto yocto
+# project psplash, for example.
+DISTROOVERRIDES = "systemdev:poky"
+
+EFI_PROVIDER = "gummiboot"
+
+SDK_NAME = "${DISTRO}-${TCLIBC}-${SDK_ARCH}-${IMAGE_BASENAME}-${TUNE_PKGARCH}"
+SDKPATH = "/opt/${DISTRO}/${SDK_VERSION}"
+
+# TODO: What is this and do we care for systemdev?
+EXTRAOPKGCONFIG = "poky-feed-config-opkg"
+
+DISTRO_EXTRA_RDEPENDS += " ${SYSTEMDEV_DEFAULT_EXTRA_RDEPENDS}"
+DISTRO_EXTRA_RRECOMMENDS += " ${SYSTEMDEV_DEFAULT_EXTRA_RRECOMMENDS}"
+
+SYSTEMDEVQEMUDEPS = "${@base_contains("INCOMPATIBLE_LICENSE", "GPLv3", "", "qemu-config",d)}"
+DISTRO_EXTRA_RDEPENDS_append_qemux86 = " ${SYSTEMDEVQEMUDEPS}"
+DISTRO_EXTRA_RDEPENDS_append_qemux86-64 = " ${SYSTEMDEVQEMUDEPS}"
+
+TCLIBCAPPEND = ""
+
+QEMU_TARGETS ?= "i386 x86_64"
+
+PREMIRRORS ??= "\
+bzr://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
+cvs://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
+git://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
+hg://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
+osc://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
+p4://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
+svk://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
+svn://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n"
+
+MIRRORS =+ "\
+ftp://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
+http://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
+https://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n"
+
+# The CONNECTIVITY_CHECK_URI's are used to test whether we can succesfully
+# fetch from the network (and warn you if not). To disable the test set
+# the variable to be empty.
+# Git example url: git://git.yoctoproject.org/yocto-firewall-test;protocol=git;rev=HEAD
+
+CONNECTIVITY_CHECK_URIS ?= " \
+ https://eula-downloads.yoctoproject.org/index.php \
+ http://bugzilla.yoctoproject.org/report.cgi"
+
+SANITY_TESTED_DISTROS ?= " \
+ Poky-1.4 \n \
+ Poky-1.5 \n \
+ Ubuntu-12.04 \n \
+ Ubuntu-12.10 \n \
+ Ubuntu-13.04 \n \
+ Ubuntu-13.10 \n \
+ Fedora-18 \n \
+ Fedora-19 \n \
+ Fedora-20 \n \
+ CentOS-6.4 \n \
+ CentOS-6.5 \n \
+ Debian-7.0 \n \
+ Debian-7.1 \n \
+ Debian-7.2 \n \
+ Debian-7.3 \n \
+ Debian-7.4 \n \
+ SUSE-LINUX-12.2 \n \
+ openSUSE-project-12.3 \n \
+ "
+
+# Default hash policy for distro
+BB_SIGNATURE_HANDLER ?= 'OEBasicHash'
+#
+# OELAYOUT_ABI allows us to notify users when the format of TMPDIR changes in
+# an incompatible way. Such changes should usually be detailed in the commit
+# that breaks the format and have been previously discussed on the mailing list
+# with general agreement from the core team.
+#
+OELAYOUT_ABI = "8"
+
+# add poky sanity bbclass from meta-yocto
+INHERIT += "poky-sanity"
+
+# QA check settings - a little stricter than the OE-Core defaults
+WARN_QA = "textrel files-invalid incompatible-license xorg-driver-abi libdir \
+ unknown-configure-option"
+ERROR_QA = "dev-so debug-deps dev-deps debug-files arch pkgconfig la perms \
+ useless-rpaths rpaths staticdev ldflags pkgvarcheck already-stripped \
+ compile-host-path dep-cmp installed-vs-shipped install-host-path \
+ packages-list perm-config perm-line perm-link pkgv-undefined \
+ pn-overrides split-strip var-undefined version-going-backwards"
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..0506783
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "systemdev"
+BBFILE_PATTERN_systemdev = "^${LAYERDIR}/"
+BBFILE_PRIORITY_systemdev = "6"
diff --git a/recipes-benchmarks/hdperf/hdperf_1.5.bb b/recipes-benchmarks/hdperf/hdperf_1.5.bb
new file mode 100644
index 0000000..53968dd
--- /dev/null
+++ b/recipes-benchmarks/hdperf/hdperf_1.5.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Hard Drive Performance Benchmark"
+HOMEPAGE = "http://hdperf.sourceforge.net/"
+SECTION = "benchmarks"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://hdperf.c;beginline=0;endline=21;md5=a4486bc71611cfb35c024ac5b88b7038"
+DEPENDS = "virtual/libc"
+
+SRC_URI = "http://sourceforge.net/projects/hdperf/files/hdperf/${PV}/hdperf-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "b42930b968e124d9b2c909681f863c82"
+
+S = "${WORKDIR}/hdperf"
+
+# The tarball ships a binary.... sigh.
+do_configure() {
+ rm ${S}/hdperf
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 hdperf ${D}${bindir}
+}
diff --git a/recipes-devtools/suspendresume/suspendresume_git.bb b/recipes-devtools/suspendresume/suspendresume_git.bb
new file mode 100644
index 0000000..d9eae46
--- /dev/null
+++ b/recipes-devtools/suspendresume/suspendresume_git.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Suspend/Resume performance tool"
+DESCRIPTION = "Linux tool to measure kernel activity between suspend and resume"
+HOMEPAGE = "http://01.org/suspendresume/"
+DEPENDS = "python"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
+SECTION = "tests"
+
+SRC_URI = "git://github.com/01org/suspendresume.git"
+SRCREV = "2a6919fc0da5e15837c8428c987c2e1aa20c5fc1"
+S = "${WORKDIR}/git"
+
+do_compile() {
+ :
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 analyze_suspend.py ${D}${bindir}
+}
diff --git a/recipes-fixup/fb-test/fb-test_git.bbappend b/recipes-fixup/fb-test/fb-test_git.bbappend
new file mode 100644
index 0000000..2bd0c9a
--- /dev/null
+++ b/recipes-fixup/fb-test/fb-test_git.bbappend
@@ -0,0 +1,9 @@
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 fb-test ${D}${bindir}
+ # avoid collisions with perf (perf) and mesa-demos (offset)
+ for prog in perf rect offset ; do
+ install -m 0755 $prog ${D}${bindir}/fb-$prog
+ done
+}
+
diff --git a/recipes-graphics/drm/libdrm_git.bbappend b/recipes-graphics/drm/libdrm_git.bbappend
new file mode 100644
index 0000000..ff68c7f
--- /dev/null
+++ b/recipes-graphics/drm/libdrm_git.bbappend
@@ -0,0 +1,6 @@
+SRC_URI += "file://installtests.patch"
+
+SRCREV = "7068d987f4dc1260a948f2b4782c66d3d80e9978"
+PV = "2.4.58+git${SRCPV}"
+PR = "${INC_PR}.0"
+
diff --git a/recipes-graphics/mesa/mesa_git.bbappend b/recipes-graphics/mesa/mesa_git.bbappend
new file mode 100644
index 0000000..2da3e47
--- /dev/null
+++ b/recipes-graphics/mesa/mesa_git.bbappend
@@ -0,0 +1,13 @@
+# Although not typically set anymore it seems, set PR to work around a
+# bug in mesa_git.bb where it uses INC_PR. A fix has been submitted upstream
+# for mesa_git.bb, but eventually we won't use mesa_git.bb anyway.
+PR = "r0"
+
+LIC_FILES_CHKSUM = "file://docs/license.html;md5=6a23445982a7a972ac198e93cc1cb3de"
+
+SRCREV = "088d3501786a2ff0833de45951b63acbe6560a0f"
+PV = "10.3.1+git${SRCPV}"
+
+# Set the SRC_URI because we don't want the patches that have been applied
+# upstream and the branch is needed.
+SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa;branch=10.3"
diff --git a/recipes-systemdev/images/systemdev-image-sdk.bb b/recipes-systemdev/images/systemdev-image-sdk.bb
new file mode 100644
index 0000000..ab14fec
--- /dev/null
+++ b/recipes-systemdev/images/systemdev-image-sdk.bb
@@ -0,0 +1,5 @@
+DESCRIPTION = "System development image with SDK"
+LICENSE = "MIT"
+
+require systemdev-image.bb
+require systemdev-sdk.inc
diff --git a/recipes-systemdev/images/systemdev-image-xfce-sdk.bb b/recipes-systemdev/images/systemdev-image-xfce-sdk.bb
new file mode 100644
index 0000000..b830f25
--- /dev/null
+++ b/recipes-systemdev/images/systemdev-image-xfce-sdk.bb
@@ -0,0 +1,5 @@
+DESCRIPTION = "System development image with XFCE and the SDK"
+LICENSE = "MIT"
+
+require systemdev-image-xfce.bb
+require systemdev-sdk.inc
diff --git a/recipes-systemdev/images/systemdev-image-xfce.bb b/recipes-systemdev/images/systemdev-image-xfce.bb
new file mode 100644
index 0000000..413b0d5
--- /dev/null
+++ b/recipes-systemdev/images/systemdev-image-xfce.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "System development image with XFCE"
+LICENSE = "MIT"
+
+require systemdev-image.bb
+
+IMAGE_FEATURES += "splash"
+
+IMAGE_INSTALL += "packagegroup-xfce-base \
+ packagegroup-core-x11-xserver \
+ packagegroup-core-x11-utils \
+ dbus \
+ pointercal \
+ liberation-fonts \
+ kernelshark \
+ midori \
+ gstreamer1.0 \
+ gstreamer1.0-meta-base \
+ gstreamer1.0-plugins-base-meta \
+ gstreamer1.0-plugins-good-meta \
+ gstreamer1.0-plugins-bad-meta \
+ gstreamer1.0-plugins-ugly-meta \
+ gstreamer1.0-libav \
+ gstreamer-vaapi-1.0 \
+ gst-va-intel \
+ libva-intel-driver \
+ "
+
+SYSTEMD_DEFAULT_TARGET = "graphical.target"
+
+REQUIRED_DISTRO_FEATURES = "x11"
diff --git a/recipes-systemdev/images/systemdev-image.bb b/recipes-systemdev/images/systemdev-image.bb
new file mode 100644
index 0000000..4a08b54
--- /dev/null
+++ b/recipes-systemdev/images/systemdev-image.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "System development image"
+LICENSE = "MIT"
+
+inherit core-image distro_features_check releaseinfo
+
+IMAGE_FEATURES += "package-management \
+ debug-tweaks \
+ tools-testapps \
+ tools-debug \
+ ssh-server-openssh \
+ "
+
+IMAGE_INSTALL += "pciutils usbutils dmidecode \
+ acpica acpitests \
+ alsa-utils \
+ kernel-modules \
+ ethtool \
+ powertop \
+ suspendresume \
+ rt-tests \
+ i2c-tools \
+ fb-test \
+ evtest \
+ screen minicom \
+ hdperf \
+ iperf \
+ vim \
+ python-pyserial \
+ tmux \
+ lmbench \
+ bonnie++ \
+ ltp \
+ bootchart \
+ netperf \
+ git \
+ python-sqlalchemy \
+ mysql-python \
+ connman \
+ mesa \
+ libdrm \
+ "
diff --git a/recipes-systemdev/images/systemdev-sdk.inc b/recipes-systemdev/images/systemdev-sdk.inc
new file mode 100644
index 0000000..02c0bdd
--- /dev/null
+++ b/recipes-systemdev/images/systemdev-sdk.inc
@@ -0,0 +1,8 @@
+IMAGE_FEATURES += "tools-sdk \
+ dev-pkgs \
+ "
+
+IMAGE_INSTALL += "bc \
+ python-pip \
+ "
+