summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/ndctl/ndctl_51.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-kernel/ndctl/ndctl_51.bb b/recipes-kernel/ndctl/ndctl_51.bb
new file mode 100644
index 0000000..5f57292
--- /dev/null
+++ b/recipes-kernel/ndctl/ndctl_51.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Utility library for managing the libnvdimm"
+DESCRIPTION = "Utility library for managing the libnvdimm \
+(non-volatile memory device) sub-system in the Linux kernel."
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e66651809cac5da60c8b80e9e4e79e08"
+
+inherit pkgconfig autotools
+
+DEPENDS += "kmod udev json-c util-linux"
+
+SRC_URI = "https://github.com/pmem/ndctl/archive/v51.tar.gz"
+SRC_URI[md5sum] = "28d3d0e082a151faaab6dfe5b8fa4bb5"
+SRC_URI[sha256sum] = "af113605584217e504dd60b97d04ecc80b2e4aaff2f6e515192c23111dcf3b76"
+
+EXTRA_OECONF += "--enable-logging --enable-debug --enable-local"
+
+B = "${S}"
+
+do_configure_prepend() {
+ cd ${S}
+ ./autogen.sh
+}