summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/turbostat/turbostat.bb13
1 files changed, 4 insertions, 9 deletions
diff --git a/recipes-kernel/turbostat/turbostat.bb b/recipes-kernel/turbostat/turbostat.bb
index 6c927c5..e55ec72 100644
--- a/recipes-kernel/turbostat/turbostat.bb
+++ b/recipes-kernel/turbostat/turbostat.bb
@@ -7,16 +7,11 @@ or statistics are printed periodically."
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
-DEPENDS = "virtual/kernel"
+inherit kernelsrc
PROVIDES = "virtual/turbostat"
-inherit linux-kernel-base
-
-do_populate_lic[depends] += "virtual/kernel:do_populate_sysroot"
-
-S = "${STAGING_KERNEL_DIR}"
-# The source should be ready after the do_unpack
-do_unpack[depends] += "virtual/kernel:do_populate_sysroot"
+do_populate_lic[depends] += "virtual/kernel:do_patch"
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
B = "${WORKDIR}/${BPN}-${PV}"
@@ -52,5 +47,5 @@ do_install() {
}
python do_package_prepend() {
- bb.data.setVar('PKGV', get_kernelversion('${S}').split("-")[0], d)
+ d.setVar('PKGV', d.getVar("KERNEL_VERSION", True).split("-")[0])
}