aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/swupd-server/swupd-server_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/swupd-server/swupd-server_git.bb')
-rw-r--r--recipes-core/swupd-server/swupd-server_git.bb24
1 files changed, 20 insertions, 4 deletions
diff --git a/recipes-core/swupd-server/swupd-server_git.bb b/recipes-core/swupd-server/swupd-server_git.bb
index 5f93034..dbe7b19 100644
--- a/recipes-core/swupd-server/swupd-server_git.bb
+++ b/recipes-core/swupd-server/swupd-server_git.bb
@@ -8,7 +8,19 @@ DEPENDS = "file glib-2.0 rsync openssl libarchive bsdiff bzip2"
# are assumed to be provided and would not get built.
DEPENDS_append_class-native = " file-replacement-native bzip2-replacement-native"
-PV = "3.2.5+git${SRCPV}"
+# This matches the SWUPD_TOOLS_FORMAT in swupd-image.bbclass.
+# When updating to a new release which changes the format of
+# the output, copy the recipe first to ensure that the old
+# release is still available if needed by swupd-image.bbclass,
+# then bump this number.
+#
+# The rest of the recipe ensures that different swupd-server
+# versions can be build and installed in parallel (format
+# number embedded in PN and the resulting files).
+SWUPD_SERVER_FORMAT = "4"
+PN = "swupd-server-format${SWUPD_SERVER_FORMAT}"
+FILESEXTRAPATHS_prepend = "${THISDIR}/swupd-server:"
+PV = "3.3.0+git${SRCPV}"
SRC_URI = "git://github.com/clearlinux/swupd-server.git;protocol=https \
file://0025-swupd_make_pack-fix-extracting-files-with-bsdtar.patch \
file://0026-fullfiles.c-fix-invalid-LOG-call.patch \
@@ -17,15 +29,13 @@ SRC_URI = "git://github.com/clearlinux/swupd-server.git;protocol=https \
file://0029-fullfiles-use-libarchive-directly.patch \
file://0001-swupd-create-update-alternative-input-layout.patch \
file://0002-add-logging-to-stdout.patch \
- file://swupd_create_fullfiles-avoid-segfault-when-nothing-c.patch \
- file://0001-delta.c-fix-xattr-test-after-patching.patch \
file://0002-pack.c-do-not-clean-packstage.patch \
file://0003-swupd_create_pack-download-original-files-on-demand-.patch \
file://0001-create_pack-rely-less-on-previous-builds.patch \
file://0002-create_pack-download-fullfile-on-demand-for-packs.patch \
file://0003-create_pack-abort-delta-handling-early-when-impossib.patch \
"
-SRCREV = "ddca171dad32229ceeff8b8527a179610b88ce55"
+SRCREV = "9148ea8a8ecd73720d450d30acc4bceec310ab3b"
S = "${WORKDIR}/git"
@@ -40,3 +50,9 @@ RDEPENDS_${PN} = "rsync"
RDEPENDS_${PN}_class-target = " bsdtar"
BBCLASSEXTEND = "native"
+
+do_install_append () {
+ for i in ${D}${bindir}/swupd_*; do
+ mv $i ${i}_${SWUPD_SERVER_FORMAT}
+ done
+}