aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/swupd-client/swupd-client_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/swupd-client/swupd-client_git.bb')
-rw-r--r--recipes-core/swupd-client/swupd-client_git.bb31
1 files changed, 14 insertions, 17 deletions
diff --git a/recipes-core/swupd-client/swupd-client_git.bb b/recipes-core/swupd-client/swupd-client_git.bb
index fd73223..d603cb0 100644
--- a/recipes-core/swupd-client/swupd-client_git.bb
+++ b/recipes-core/swupd-client/swupd-client_git.bb
@@ -5,17 +5,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=f8d90fb802930e30e49c39c8126a959e"
DEPENDS = "glib-2.0 curl openssl libarchive bsdiff"
-PV = "3.6.0+git${SRCPV}"
-SRC_URI = "\
- git://github.com/clearlinux/swupd-client.git;protocol=https \
- file://Change-systemctl-path-to-OE-systemctl-path.patch \
- file://0001-Add-configure-option-to-re-enable-updating-of-config.patch \
- file://Make-pinned-pubkey-configurable.patch \
- file://ignore-xattrs-when-verifying-Manifest-files.patch \
- file://0001-downloads-minimize-syscalls-to-improve-performance.patch \
- file://0002-downloads-open-FILE-in-advance-and-use-default-write.patch \
-"
-SRCREV = "f4000c5b22be47ec1af2f8748fd71a36148b5dc4"
+PV = "3.7.2+git${SRCPV}"
+SRC_URI = "git://github.com/clearlinux/swupd-client.git;protocol=https \
+ file://Change-systemctl-path-to-OE-systemctl-path.patch \
+ file://0001-Add-configure-option-to-re-enable-updating-of-config.patch \
+ file://ignore-xattrs-when-verifying-Manifest-files.patch \
+ file://0001-fix-enable-xattr.patch \
+ "
+SRCREV = "b43ad9748ea690f69f924b6cae9a83c3886514b6"
S = "${WORKDIR}/git"
@@ -30,18 +27,18 @@ RRECOMMENDS_${PN}_class-target = "os-release"
# and bump the number by one for each update of the recipe where we
# switch to a source that has a format change.
#
-# To switch to a client with a new format also update SWUPD_FORMAT in
+# To switch to a client with a new format also update SWUPD_TOOLS_FORMAT in
# swupd-image.bbclass.
-RPROVIDES_${PN} = "swupd-client-format3"
+SWUPD_CLIENT_FORMAT = "4"
+RPROVIDES_${PN} = "swupd-client-format${SWUPD_CLIENT_FORMAT}"
-# TODO: we inherit autotools-brokensep because the Makefile calls a perl script
-# in ${S} during one of its steps.
-inherit pkgconfig autotools-brokensep systemd
+inherit pkgconfig autotools systemd
EXTRA_OECONF = "\
--with-systemdsystemunitdir=${systemd_system_unitdir} \
--enable-bsdtar \
--disable-tests \
+ --enable-xattr \
"
PACKAGECONFIG ??= "stateless"
@@ -53,7 +50,7 @@ FILES_${PN} += "\
/var/lib/swupd \
"
-SYSTEMD_SERVICE_${PN} = "check-update.timer check-update.service"
+SYSTEMD_SERVICE_${PN} = "check-update.timer check-update.service swupd-update.timer swupd-update.service"
SYSTEMD_AUTO_ENABLE_${PN} = "disable"
BBCLASSEXTEND = "native"