aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/swupd-client/swupd-client/0001-Add-configure-option-to-re-enable-updating-of-config.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/swupd-client/swupd-client/0001-Add-configure-option-to-re-enable-updating-of-config.patch')
-rw-r--r--recipes-core/swupd-client/swupd-client/0001-Add-configure-option-to-re-enable-updating-of-config.patch16
1 files changed, 9 insertions, 7 deletions
diff --git a/recipes-core/swupd-client/swupd-client/0001-Add-configure-option-to-re-enable-updating-of-config.patch b/recipes-core/swupd-client/swupd-client/0001-Add-configure-option-to-re-enable-updating-of-config.patch
index 649f7da..06f138c 100644
--- a/recipes-core/swupd-client/swupd-client/0001-Add-configure-option-to-re-enable-updating-of-config.patch
+++ b/recipes-core/swupd-client/swupd-client/0001-Add-configure-option-to-re-enable-updating-of-config.patch
@@ -1,22 +1,24 @@
-From d648898c8f9823a8d511507f93390079954bc24a Mon Sep 17 00:00:00 2001
+From 72bcbe256a6612954ea24175538660864e65e26d Mon Sep 17 00:00:00 2001
From: Joshua Lock <joshua.g.lock@intel.com>
Date: Mon, 18 Apr 2016 13:30:18 +0100
-Subject: [PATCH] Add configure option to re-enable updating of config files
+Subject: [PATCH 2/4] Add configure option to re-enable updating of config
+ files
Upstream-Status: Pending
Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
+
---
configure.ac | 7 +++++++
src/heuristics.c | 5 +++--
2 files changed, 10 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
-index b1905f0..4a5c029 100644
+index ee05258..5cbc450 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -63,6 +63,13 @@ AS_IF([test "x$enable_bsdtar" = "xyes" ],
- [AC_DEFINE(SWUPD_WITHOUT_BSDTAR, 1, [Use default tar])]
+@@ -153,6 +153,13 @@ AS_IF([test "x$enable_tar_selinux" = "xyes"],
+ [TARSELINUX=no]
)
+AC_ARG_ENABLE(
@@ -30,7 +32,7 @@ index b1905f0..4a5c029 100644
[path to systemd system service dir @<:@default=/usr/lib/systemd/system@:>@]), [unitpath=${withval}],
[unitpath="$($PKG_CONFIG --variable=systemdsystemunitdir systemd)"])
diff --git a/src/heuristics.c b/src/heuristics.c
-index e7c0632..c488e17 100644
+index 1b5d6c9..a2615f3 100644
--- a/src/heuristics.c
+++ b/src/heuristics.c
@@ -27,6 +27,7 @@
@@ -53,5 +55,5 @@ index e7c0632..c488e17 100644
is_state(file->filename) || // ideally we trust the manifest but short term reapply check here
(file->is_boot && file->is_deleted) ||
--
-2.5.5
+2.1.4