aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf1
-rw-r--r--recipes-core/swupd-client/oe-swupd-helpers.bb3
-rw-r--r--recipes-core/swupd-client/swupd-client_2.87.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 2998949..50e7558 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -13,4 +13,5 @@ LAYERVERSION_meta-swupd = "1"
SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += "\
oe-swupd-helpers->bash \
+ oe-swupd-helpers->busybox \
"
diff --git a/recipes-core/swupd-client/oe-swupd-helpers.bb b/recipes-core/swupd-client/oe-swupd-helpers.bb
index 4690f21..9a5a8dd 100644
--- a/recipes-core/swupd-client/oe-swupd-helpers.bb
+++ b/recipes-core/swupd-client/oe-swupd-helpers.bb
@@ -35,5 +35,4 @@ do_install () {
done
}
-RDEPENDS_${PN} += "bash"
-FILES_${PN} += "${systemd_system_unitdir}" \ No newline at end of file
+FILES_${PN} += "${systemd_system_unitdir}"
diff --git a/recipes-core/swupd-client/swupd-client_2.87.bb b/recipes-core/swupd-client/swupd-client_2.87.bb
index 96e7a10..09d09a4 100644
--- a/recipes-core/swupd-client/swupd-client_2.87.bb
+++ b/recipes-core/swupd-client/swupd-client_2.87.bb
@@ -24,7 +24,7 @@ SRC_URI[md5sum] = "5d272c62edb8a9c576005ac5e1182ea3"
SRC_URI[sha256sum] = "45df259a7dc2fed985ee9961e112120fc46670dd75476c3262fc6804b1c66fb8"
DEPENDS = "glib-2.0 curl openssl libarchive"
-RDEPENDS_${PN}_append_class-target = " oe-swupd-helpers bsdtar"
+RDEPENDS_${PN}_append_class-target = " oe-swupd-helpers bash bsdtar"
# We check /etc/os-release for the current OS version number
RRECOMMENDS_${PN}_class-target = "os-release"