aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-security/selinux/policycoreutils/scripts_makefile.patch26
-rw-r--r--recipes-security/selinux/policycoreutils_2.1.13.bb3
2 files changed, 28 insertions, 1 deletions
diff --git a/recipes-security/selinux/policycoreutils/scripts_makefile.patch b/recipes-security/selinux/policycoreutils/scripts_makefile.patch
new file mode 100644
index 0000000..8972474
--- /dev/null
+++ b/recipes-security/selinux/policycoreutils/scripts_makefile.patch
@@ -0,0 +1,26 @@
+policycoreutils: fix genhomedircon generation
+
+The script is put on the target and needs to reference
+the directory in which semodule is installed.
+
+Upstream Status: pending
+
+Signed-off-by: Joe Slater <jslater@windriver.com>
+
+--- a/scripts/Makefile
++++ b/scripts/Makefile
+@@ -8,11 +8,12 @@ LOCALEDIR ?= $(PREFIX)/share/locale
+
+ all: fixfiles genhomedircon chcat
+
++# we want the script to use the user sbin directory on the target
++#
+ genhomedircon:
+ @echo "#!/bin/sh" > genhomedircon
+ @echo >> genhomedircon
+- @if [ ! -e semodule_path ]; then echo -n "$(USRSBINDIR)/" >> genhomedircon; fi
+- @if [ -e semodule_path ]; then echo -n "`cat semodule_path`/" >> genhomedircon; fi
++ @echo -n "$(sbindir)/" >> genhomedircon
+ @echo "semodule -Bn" >> genhomedircon
+
+ install: all
diff --git a/recipes-security/selinux/policycoreutils_2.1.13.bb b/recipes-security/selinux/policycoreutils_2.1.13.bb
index 6696357..687347c 100644
--- a/recipes-security/selinux/policycoreutils_2.1.13.bb
+++ b/recipes-security/selinux/policycoreutils_2.1.13.bb
@@ -1,4 +1,4 @@
-PR = "r2"
+PR = "r3"
include selinux_20120924.inc
include ${BPN}.inc
@@ -11,4 +11,5 @@ SRC_URI[sha256sum] = "34040f06f3111d9ee957576e4095841d35b9ca9141ee8d80aab036cbef
SRC_URI += "\
file://policycoreutils-revert-restorecon-update-type.patch \
file://policycoreutils-revert-run_init-open_init_pty.patch \
+ file://scripts_makefile.patch \
"