aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-tpm/tpm2simulator/tpm2simulator-native_116.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-tpm/tpm2simulator/tpm2simulator-native_116.bb')
-rw-r--r--recipes-tpm/tpm2simulator/tpm2simulator-native_116.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-tpm/tpm2simulator/tpm2simulator-native_116.bb b/recipes-tpm/tpm2simulator/tpm2simulator-native_116.bb
new file mode 100644
index 0000000..a53d4c3
--- /dev/null
+++ b/recipes-tpm/tpm2simulator/tpm2simulator-native_116.bb
@@ -0,0 +1,24 @@
+SUMMARY = "TPM 2.0 Simulator Extraction Script"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1415f7be284540b81d9d28c67c1a6b8b"
+
+DEPENDS += "python"
+
+SRCREV = "93dc4412432013ed7bcabd42007754c68f6e362e"
+SRC_URI = "git://github.com/stwagnr/tpm2simulator.git"
+
+S = "${WORKDIR}/git"
+OECMAKE_SOURCEPATH = "${S}/cmake"
+
+PV = "116+git${SRCPV}"
+
+inherit native lib_package cmake
+
+EXTRA_OECMAKE = " \
+ -DCMAKE_BUILD_TYPE=Debug \
+ -DSPEC_VERSION=116 \
+"
+
+do_configure_prepend () {
+ sed -i 's/^SET = False/SET = True/' ${S}/scripts/settings.py
+}