aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-security/checksec/checksec_2.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/checksec/checksec_2.1.0.bb')
-rw-r--r--recipes-security/checksec/checksec_2.1.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-security/checksec/checksec_2.1.0.bb b/recipes-security/checksec/checksec_2.1.0.bb
new file mode 100644
index 0000000..5c6528e
--- /dev/null
+++ b/recipes-security/checksec/checksec_2.1.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Linux system security checks"
+DESCRIPTION = "The checksec script is designed to test what standard Linux OS and PaX security features are being used."
+SECTION = "security"
+LICENSE = "BSD"
+HOMEPAGE="https://github.com/slimm609/checksec.sh"
+
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=93fddcca19f6c897871f9b5f9a035f4a"
+
+SRCREV = "04582bad41589ad479ca8b1f0170ed317475b5a5"
+SRC_URI = "git://github.com/slimm609/checksec.sh"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/checksec ${D}${bindir}
+}
+
+RDEPENDS_${PN} = "bash openssl-bin"