aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-security/checksec/checksec_1.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/checksec/checksec_1.11.1.bb')
-rw-r--r--recipes-security/checksec/checksec_1.11.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-security/checksec/checksec_1.11.1.bb b/recipes-security/checksec/checksec_1.11.1.bb
new file mode 100644
index 0000000..835dffc
--- /dev/null
+++ b/recipes-security/checksec/checksec_1.11.1.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Linux system security checks"
+DESCRIPTION = "The checksec script is designed to test what standard Linux OS and PaX security features are being used."
+SECTION = "security"
+LICENSE = "BSD"
+HOMEPAGE="https://github.com/slimm609/checksec.sh"
+
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=93fddcca19f6c897871f9b5f9a035f4a"
+
+SRCREV = "3c15cb89641c700096fdec0c1904a0cf9b83c5e2"
+SRC_URI = "git://github.com/slimm609/checksec.sh"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/checksec ${D}${bindir}
+}
+
+RDEPENDS_${PN} = "bash openssl-bin"