aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-perl/perl
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-perl/perl')
-rw-r--r--recipes-perl/perl/files/libwhisker2.patch73
-rw-r--r--recipes-perl/perl/lib-perl_0.63.bb28
-rw-r--r--recipes-perl/perl/libnetaddr-ip-perl_4.069.bb26
-rw-r--r--recipes-perl/perl/libwhisker2-perl_2.5.bb24
4 files changed, 151 insertions, 0 deletions
diff --git a/recipes-perl/perl/files/libwhisker2.patch b/recipes-perl/perl/files/libwhisker2.patch
new file mode 100644
index 0000000..c066366
--- /dev/null
+++ b/recipes-perl/perl/files/libwhisker2.patch
@@ -0,0 +1,73 @@
+From 34698c7f561fb575293a1c991a71e1b4ddc5ae73 Mon Sep 17 00:00:00 2001
+From: Andrei Dinu <andrei.adrianx.dinu@intel.com>
+Date: Fri, 5 Jul 2013 11:56:58 +0300
+Subject: [PATCH] Mandir and perl install dir were overwritten with faulty
+ information in the Makefile. Now the Mandir and perl
+ install dir are sent via paramters from the recipe.
+
+Signed-off-by: Andrei Dinu <andrei.adrianx.dinu@intel.com>
+---
+ Makefile.pl | 12 +++++++-----
+ 1 file changed, 7 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile.pl b/Makefile.pl
+index 9ca5602..8776e18 100644
+--- a/Makefile.pl
++++ b/Makefile.pl
+@@ -131,6 +131,8 @@ foreach (keys %MODULES){
+
+ # adjust DESTDIR, if needed
+ $DESTDIR = $ENV{DESTDIR} if(defined $ENV{DESTDIR});
++$MANDIR = $ENV{MANDIR} if(defined $ENV{MANDIR});
++$INSTALLDIR = $ENV{INSTALLDIR} if(defined $ENV{INSTALLDIR});
+
+ # parse command line build options
+ while($COMMAND = shift @ARGV){
+@@ -171,7 +173,7 @@ sub command_install_pod {
+ command_build() if(!-e $TARGET);
+ die("Can not install without Config.pm") if($MODULES{Config}==0);
+ $CWD=&cwd if($MODULES{Cwd}>0);
+- my $where=$DESTDIR . $Config{'man3direxp'};
++ my $where=$DESTDIR . $MANDIR;
+ my $t = $TARGET;
+ if($LIBRARY){
+ $t="$PACKAGE.3pm";
+@@ -219,7 +221,7 @@ sub command_install_pod {
+ sub command_uninstall_pod {
+ die("Can not uninstall without Config.pm") if($MODULES{Config}==0);
+ $CWD=&cwd if($MODULES{Cwd}>0);
+- my $where=$DESTDIR . $Config{'man3direxp'};
++ my $where=$DESTDIR . $MANDIR;
+ my $t = $TARGET;
+ if($LIBRARY){
+ $t="$PACKAGE.3pm";
+@@ -243,7 +245,7 @@ sub command_install_library {
+ command_build() if(!-e $TARGET);
+ die("Can not install without Config.pm") if($MODULES{Config}==0);
+ $CWD=&cwd if($MODULES{Cwd}>0);
+- my $where=$DESTDIR . $Config{'installsitelib'};
++ my $where=$DESTDIR . $INSTALLDIR;
+ if(!-e $where){
+ print STDOUT "WARNING!\n\n",
+ "The local perl site directory does not exist:\n",
+@@ -271,7 +273,7 @@ sub command_install_library {
+ sub command_uninstall_library {
+ die("Can not uninstall without Config.pm") if($MODULES{Config}==0);
+ $CWD=&cwd if($MODULES{Cwd}>0);
+- my $where=$DESTDIR . $Config{'installsitelib'};
++ my $where=$DESTDIR . $INSTALLDIR;
+ chdir($where);
+ if(-e $TARGET){
+ unlink $TARGET;
+@@ -401,7 +403,7 @@ sub command_socket_diag {
+ sub command_install_compat {
+ die("Can not install without Config.pm") if($MODULES{Config}==0);
+ $CWD=&cwd if($MODULES{Cwd}>0);
+- my $where=$DESTDIR . $Config{'installsitelib'};
++ my $where=$DESTDIR . $INSTALLDIR;
+ if(!-e $where){
+ print STDOUT "WARNING!\n\n",
+ "The local perl site directory does not exist:\n",
+--
+1.7.9.5
+
diff --git a/recipes-perl/perl/lib-perl_0.63.bb b/recipes-perl/perl/lib-perl_0.63.bb
new file mode 100644
index 0000000..7895864
--- /dev/null
+++ b/recipes-perl/perl/lib-perl_0.63.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "This is a small simple module which simplifies the \
+manipulation of @INC at compile time. It is typically used to add extra \
+directories to Perl's search path so that later 'use' or 'require' statements \
+will find modules which are not located in the default search path."
+
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+PR = "r0"
+
+LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=94b119f1a7b8d611efc89b5d562a1a50"
+
+DEPENDS += "perl"
+
+SRC_URI = "http://www.cpan.org/authors/id/S/SM/SMUELLER/lib-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "8607ac4e0d9d43585ec28312f52df67c"
+SRC_URI[sha256sum] = "72f63db9220098e834d7a38231626bd0c9b802c1ec54a628e2df35f3818e5a00"
+
+S = "${WORKDIR}/lib-${PV}"
+
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+
+inherit cpan
+
+do_compile() {
+ export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
+ cpan_do_compile
+}
diff --git a/recipes-perl/perl/libnetaddr-ip-perl_4.069.bb b/recipes-perl/perl/libnetaddr-ip-perl_4.069.bb
new file mode 100644
index 0000000..69c2d83
--- /dev/null
+++ b/recipes-perl/perl/libnetaddr-ip-perl_4.069.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "This package contains the IP.pm module with friends."
+
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+
+LIC_FILES_CHKSUM = "file://Copying;md5=cde580764a0fbc0f02fafde4c65d6227"
+
+DEPENDS += "perl"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MIKER/NetAddr-IP-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "7721135fcea390327f75421a6b701144"
+SRC_URI[sha256sum] = "96739afc484eca1597c4f4b520864b342169c8fdeef486778511e5a1527ba4e7"
+
+S = "${WORKDIR}/NetAddr-IP-${PV}"
+
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+
+inherit cpan
+
+do_compile() {
+ cpan_do_compile
+}
+BBCLASSEXTEND = "native"
+
+PNBLACKLIST[libnetaddr-ip-perl] = "BROKEN: doesn't build | make[2]: *** No rule to make target `config.h', needed by `Util.c'. Stop."
diff --git a/recipes-perl/perl/libwhisker2-perl_2.5.bb b/recipes-perl/perl/libwhisker2-perl_2.5.bb
new file mode 100644
index 0000000..a98bde0
--- /dev/null
+++ b/recipes-perl/perl/libwhisker2-perl_2.5.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Libwhisker is a Perl module geared specificly for HTTP testing."
+
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=254b8e29606fce6d1c1a4c9e32354573"
+
+DEPENDS = "perl"
+
+SRC_URI = "http://sourceforge.net/projects/whisker/files/libwhisker/${PV}/libwhisker2-${PV}.tar.gz \
+ file://libwhisker2.patch"
+
+SRC_URI[md5sum] = "7cc1718dddde8f9a439d5622ae2f37eb"
+SRC_URI[sha256sum] = "f45a1cf2ad2637b29dd1b13d7221ea12e3923ea09d107ced446400f19070a42f"
+
+S = "${WORKDIR}/libwhisker2-2.5"
+
+inherit cpan-base perlnative
+
+do_install() {
+ install -d 755 ${D}${PERLLIBDIRS}/vendor_perl/${PERLVERSION}
+ install -d 755 ${D}${datadir}/perl/${PERLVERSION}
+ oe_runmake install DESTDIR=${D} INSTALLDIR=${PERLLIBDIRS}/vendor_perl/${PERLVERSION} MANDIR=${datadir}/perl/${PERLVERSION}
+}