aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-perl/perl/libwhisker2-perl_2.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-perl/perl/libwhisker2-perl_2.5.bb')
-rw-r--r--recipes-perl/perl/libwhisker2-perl_2.5.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-perl/perl/libwhisker2-perl_2.5.bb b/recipes-perl/perl/libwhisker2-perl_2.5.bb
new file mode 100644
index 0000000..a98bde0
--- /dev/null
+++ b/recipes-perl/perl/libwhisker2-perl_2.5.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Libwhisker is a Perl module geared specificly for HTTP testing."
+
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=254b8e29606fce6d1c1a4c9e32354573"
+
+DEPENDS = "perl"
+
+SRC_URI = "http://sourceforge.net/projects/whisker/files/libwhisker/${PV}/libwhisker2-${PV}.tar.gz \
+ file://libwhisker2.patch"
+
+SRC_URI[md5sum] = "7cc1718dddde8f9a439d5622ae2f37eb"
+SRC_URI[sha256sum] = "f45a1cf2ad2637b29dd1b13d7221ea12e3923ea09d107ced446400f19070a42f"
+
+S = "${WORKDIR}/libwhisker2-2.5"
+
+inherit cpan-base perlnative
+
+do_install() {
+ install -d 755 ${D}${PERLLIBDIRS}/vendor_perl/${PERLVERSION}
+ install -d 755 ${D}${datadir}/perl/${PERLVERSION}
+ oe_runmake install DESTDIR=${D} INSTALLDIR=${PERLLIBDIRS}/vendor_perl/${PERLVERSION} MANDIR=${datadir}/perl/${PERLVERSION}
+}