aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-yocto-4.8/tpm.cfg9
-rw-r--r--recipes-kernel/linux/linux-yocto-4.8/tpm.scc4
-rw-r--r--recipes-kernel/linux/linux-yocto_4.8.bbappend7
3 files changed, 20 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-yocto-4.8/tpm.cfg b/recipes-kernel/linux/linux-yocto-4.8/tpm.cfg
new file mode 100644
index 0000000..fe1bb3f
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto-4.8/tpm.cfg
@@ -0,0 +1,9 @@
+CONFIG_HW_RANDOM_TPM=y
+CONFIG_TCG_TPM=y
+CONFIG_TCG_TIS_CORE=y
+CONFIG_TCG_TIS=y
+CONFIG_TCG_CRB=y
+CONFIG_TCG_VTPM_PROXY=y
+CONFIG_DEVPORT=y
+CONFIG_FUSE_FS=y
+CONFIG_CUSE=y
diff --git a/recipes-kernel/linux/linux-yocto-4.8/tpm.scc b/recipes-kernel/linux/linux-yocto-4.8/tpm.scc
new file mode 100644
index 0000000..7c7ec2d
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto-4.8/tpm.scc
@@ -0,0 +1,4 @@
+define KFEATURE_DESCRIPTION "TPM Kernel Support"
+define KFEATURE_COMPATIBILITY arch
+
+kconf non-hardware tpm.cfg
diff --git a/recipes-kernel/linux/linux-yocto_4.8.bbappend b/recipes-kernel/linux/linux-yocto_4.8.bbappend
new file mode 100644
index 0000000..0e6960e
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto_4.8.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-4.8:"
+
+# TPM kernel support
+SRC_URI += "\
+ ${@bb.utils.contains('DISTRO_FEATURES', 'tpm', ' file://tpm.cfg', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'tpm', ' file://tpm.scc', '', d)} \
+"