aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-security/images/security-test-image.bb4
-rw-r--r--recipes-security/packagegroup/packagegroup-core-security-ptest.bb25
2 files changed, 26 insertions, 3 deletions
diff --git a/recipes-security/images/security-test-image.bb b/recipes-security/images/security-test-image.bb
index d801fdc..f133084 100644
--- a/recipes-security/images/security-test-image.bb
+++ b/recipes-security/images/security-test-image.bb
@@ -4,15 +4,13 @@ IMAGE_FEATURES += "ssh-server-openssh"
TEST_SUITES = "ssh ping ptest apparmor clamav samhain sssd tripwire checksec smack suricata"
-DISTRO_FEATURES_append = " ptest"
INSTALL_CLAMAV_CVD = "1"
IMAGE_INSTALL = "\
packagegroup-base \
packagegroup-core-boot \
- packagegroup-core-security \
+ packagegroup-core-security-ptest \
os-release \
- clamav-cvd \
"
diff --git a/recipes-security/packagegroup/packagegroup-core-security-ptest.bb b/recipes-security/packagegroup/packagegroup-core-security-ptest.bb
new file mode 100644
index 0000000..4934889
--- /dev/null
+++ b/recipes-security/packagegroup/packagegroup-core-security-ptest.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Security ptest packagegroup"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PACKAGES = "\
+ ${PN} \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+SUMMARY_${PN} = "Security packages with ptests"
+RDEPENDS_${PN} = " \
+ ptest-runner \
+ samhain-standalone-ptest \
+ xmlsec1-ptest \
+ keyutils-ptest \
+ libseccomp-ptest \
+ python-scapy-ptest \
+ suricata-ptest \
+ tripwire-ptest \
+ python-fail2ban-ptest \
+ ${@bb.utils.contains("DISTRO_FEATURES", "apparmor", "apparmor-ptest", "",d)} \
+ ${@bb.utils.contains("DISTRO_FEATURES", "smack", "smack-ptest", "",d)} \
+ "