aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-mac/AppArmor/apparmor_2.13.2.bb (renamed from recipes-mac/AppArmor/apparmor_2.12.bb)12
-rw-r--r--recipes-mac/AppArmor/files/tool-paths.patch37
2 files changed, 9 insertions, 40 deletions
diff --git a/recipes-mac/AppArmor/apparmor_2.12.bb b/recipes-mac/AppArmor/apparmor_2.13.2.bb
index efa93e6..62ed611 100644
--- a/recipes-mac/AppArmor/apparmor_2.12.bb
+++ b/recipes-mac/AppArmor/apparmor_2.13.2.bb
@@ -17,7 +17,6 @@ SRC_URI = " \
http://archive.ubuntu.com/ubuntu/pool/main/a/${BPN}/${BPN}_${PV}.orig.tar.gz \
file://disable_perl_h_check.patch \
file://crosscompile_perl_bindings.patch \
- file://tool-paths.patch \
file://apparmor.rc \
file://functions \
file://apparmor \
@@ -25,8 +24,8 @@ SRC_URI = " \
file://run-ptest \
"
-SRC_URI[md5sum] = "49054f58042f8e51ea92cc866575a833"
-SRC_URI[sha256sum] = "8a2b0cd083faa4d0640f579024be3a629faa7db3b99540798a1a050e2eaba056"
+SRC_URI[md5sum] = "2439b35266b5a3a461b0a2dba6e863c3"
+SRC_URI[sha256sum] = "844def9926dfda5c7858428d06e44afc80573f9706458b6e7282edbb40b11a30"
PARALLEL_MAKE = ""
@@ -60,6 +59,13 @@ do_configure() {
}
do_compile () {
+ # Fixes:
+ # | sed -ie 's///g' Makefile.perl
+ # | sed: -e expression #1, char 0: no previous regular expression
+ #| Makefile:478: recipe for target 'Makefile.perl' failed
+ sed -i "s@sed -ie 's///g' Makefile.perl@@" ${S}/libraries/libapparmor/swig/perl/Makefile
+
+
oe_runmake -C ${B}/libraries/libapparmor
oe_runmake -C ${B}/binutils
oe_runmake -C ${B}/utils
diff --git a/recipes-mac/AppArmor/files/tool-paths.patch b/recipes-mac/AppArmor/files/tool-paths.patch
deleted file mode 100644
index aaf08da..0000000
--- a/recipes-mac/AppArmor/files/tool-paths.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Upstream-Status: Backport
-Signed-off-by: Ross Burton <ross.burton@intel.com>
-
-From e7edd937adcbf1b3c8d38a31de5bacb2029b1965 Mon Sep 17 00:00:00 2001
-From: John Johansen <john.johansen@canonical.com>
-Date: Thu, 4 Oct 2018 23:15:28 -0700
-Subject: [PATCH] parser: fix Makefile hardcoded paths to flex and bison
-
-The hardcoded paths for flex and python can break builds on systems
-where those tools are stored in an alternate location. Use which
-to lookup where flex and bison are available.
-
-This fixes issue #4
-
-Signed-off-by: John Johansen <john.johansen@canonical.com>
----
- parser/Makefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/parser/Makefile b/parser/Makefile
-index 4d370c36..015c218d 100644
---- a/parser/Makefile
-+++ b/parser/Makefile
-@@ -27,9 +27,9 @@ INSTALL_CONFDIR=${DESTDIR}${CONFDIR}
- LOCALEDIR=/usr/share/locale
- MANPAGES=apparmor.d.5 apparmor.7 apparmor_parser.8 subdomain.conf.5
-
--YACC := /usr/bin/bison
-+YACC := bison
- YFLAGS := -d
--LEX := /usr/bin/flex
-+LEX := flex
- LEXFLAGS = -B -v
- WARNINGS = -Wall
- EXTRA_WARNINGS = -Wsign-compare -Wmissing-field-initializers -Wformat-security -Wunused-parameter
---
-2.11.0