aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-security/paxctl/paxctl_0.9.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-security/paxctl/paxctl_0.9.bb b/recipes-security/paxctl/paxctl_0.9.bb
index d69219f..fb87f10 100644
--- a/recipes-security/paxctl/paxctl_0.9.bb
+++ b/recipes-security/paxctl/paxctl_0.9.bb
@@ -18,3 +18,18 @@ EXTRA_OEMAKE = "CC='${CC}' DESTDIR='${D}'"
do_install() {
oe_runmake install
}
+
+# The install target in the Makefile will fail for paxctl-native with error:
+# install -D --owner 0 --group 0 --mode a=rx paxctl .../sbin/paxctl
+# install: cannot change ownership of '.../sbin/paxctl': \
+# Operation not permitted
+# Drop '--owner 0 --group 0' to fix the issue.
+do_install_class-native() {
+ local PROG=paxctl
+ install -d ${D}${base_sbindir}
+ install -d ${D}${mandir}/man1
+ install --mode a=rx $PROG ${D}${base_sbindir}/$PROG
+ install --mode a=r $PROG.1 ${D}${mandir}/man1/$PROG.1
+}
+
+BBCLASSEXTEND = "native"