aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-tpm/tpm-tools/tpm-tools-1.3.8/gcc6_missleading_indent_fix.patch24
-rw-r--r--recipes-tpm/tpm-tools/tpm-tools_1.3.8.bb1
2 files changed, 25 insertions, 0 deletions
diff --git a/recipes-tpm/tpm-tools/tpm-tools-1.3.8/gcc6_missleading_indent_fix.patch b/recipes-tpm/tpm-tools/tpm-tools-1.3.8/gcc6_missleading_indent_fix.patch
new file mode 100644
index 0000000..aec5e7a
--- /dev/null
+++ b/recipes-tpm/tpm-tools/tpm-tools-1.3.8/gcc6_missleading_indent_fix.patch
@@ -0,0 +1,24 @@
+Index: tpm-tools-1.3.8/src/tpm_mgmt/tpm_present.c
+===================================================================
+--- tpm-tools-1.3.8.orig/src/tpm_mgmt/tpm_present.c
++++ tpm-tools-1.3.8/src/tpm_mgmt/tpm_present.c
+@@ -349,13 +349,13 @@ int main(int argc, char **argv)
+ }
+ } while (flags[++i].name);
+
+- out_success:
++out_success:
+ logSuccess(argv[0]);
+ iRc = 0;
+- out_close:
++out_close:
+ contextClose(hContext);
+- out:
+- if (szTpmPasswd && !isWellKnown)
+- shredPasswd( szTpmPasswd );
+- return iRc;
++out:
++ if (szTpmPasswd && !isWellKnown)
++ shredPasswd( szTpmPasswd );
++return iRc;
+ }
diff --git a/recipes-tpm/tpm-tools/tpm-tools_1.3.8.bb b/recipes-tpm/tpm-tools/tpm-tools_1.3.8.bb
index 99ea8ee..790894a 100644
--- a/recipes-tpm/tpm-tools/tpm-tools_1.3.8.bb
+++ b/recipes-tpm/tpm-tools/tpm-tools_1.3.8.bb
@@ -15,6 +15,7 @@ SRC_URI += " \
http://downloads.sourceforge.net/project/trousers/${BPN}/${PV}/${BP}.tar.gz \
file://tpm-tools-extendpcr.patch \
file://03-fix-bool-error-parseStringWithValues.patch \
+ file://gcc6_missleading_indent_fix.patch \
"
SRC_URI[md5sum] = "85a978c4e03fefd4b73cbeadde7c4d0b"