aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-tpm/tpm2.0-tss/tpm2.0-tss/0001-tss2_tpm2_types.h-Fix-broken-TRANSIENT_LAST-macro.patch29
-rw-r--r--recipes-tpm/tpm2.0-tss/tpm2.0-tss_git.bb3
2 files changed, 31 insertions, 1 deletions
diff --git a/recipes-tpm/tpm2.0-tss/tpm2.0-tss/0001-tss2_tpm2_types.h-Fix-broken-TRANSIENT_LAST-macro.patch b/recipes-tpm/tpm2.0-tss/tpm2.0-tss/0001-tss2_tpm2_types.h-Fix-broken-TRANSIENT_LAST-macro.patch
new file mode 100644
index 0000000..74f82be
--- /dev/null
+++ b/recipes-tpm/tpm2.0-tss/tpm2.0-tss/0001-tss2_tpm2_types.h-Fix-broken-TRANSIENT_LAST-macro.patch
@@ -0,0 +1,29 @@
+From 92a0830306c2eb3081b5ac3329f7504cd58d670b Mon Sep 17 00:00:00 2001
+From: Philip Tricca <philip.b.tricca@intel.com>
+Date: Thu, 12 Jan 2017 11:55:52 -0800
+Subject: [PATCH] tss2_tpm2_types.h: Fix broken TRANSIENT_LAST macro.
+
+Upstream-Status: Backport
+
+Signed-off-by: Philip Tricca <philip.b.tricca@intel.com>
+Signed-off-by: Jagadeesh Krishnanjanappa <jkrishnanjanappa@mvista.com>
+---
+ include/sapi/tss2_tpm2_types.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/sapi/tss2_tpm2_types.h b/include/sapi/tss2_tpm2_types.h
+index 48cc1dc..aa41c06 100644
+--- a/include/sapi/tss2_tpm2_types.h
++++ b/include/sapi/tss2_tpm2_types.h
+@@ -452,7 +452,7 @@ typedef TPM_HANDLE TPM_HC;
+ #define TRANSIENT_FIRST (HR_TRANSIENT + 0 ) /* first transient object */
+ #define ACTIVE_SESSION_FIRST (POLICY_SESSION_FIRST ) /* used in GetCapability */
+ #define ACTIVE_SESSION_LAST (POLICY_SESSION_LAST ) /* used in GetCapability */
+-#define TRANSIENT_LAST (TRANSIENT_FIRST+MAX_LOADED_OBJECTS1 ) /* last transient object */
++#define TRANSIENT_LAST (TRANSIENT_FIRST + MAX_LOADED_OBJECTS - 1 ) /* last transient object */
+ #define PERSISTENT_FIRST (HR_PERSISTENT + 0 ) /* first persistent object */
+ #define PERSISTENT_LAST (PERSISTENT_FIRST + 0x00FFFFFF ) /* last persistent object */
+ #define PLATFORM_PERSISTENT (PERSISTENT_FIRST + 0x00800000 ) /* first platform persistent object */
+--
+2.6.4
+
diff --git a/recipes-tpm/tpm2.0-tss/tpm2.0-tss_git.bb b/recipes-tpm/tpm2.0-tss/tpm2.0-tss_git.bb
index c4b5c8c..2910741 100644
--- a/recipes-tpm/tpm2.0-tss/tpm2.0-tss_git.bb
+++ b/recipes-tpm/tpm2.0-tss/tpm2.0-tss_git.bb
@@ -7,7 +7,8 @@ SECTION = "tpm"
SRCREV = "8e25d0cbb287d30c93b2b77e99bc761dc67e31a9"
SRC_URI = " \
git://github.com/01org/TPM2.0-TSS.git;protocol=git;branch=master;name=TPM2.0-TSS;destsuffix=TPM2.0-TSS \
- file://ax_pthread.m4"
+ file://ax_pthread.m4 \
+ file://0001-tss2_tpm2_types.h-Fix-broken-TRANSIENT_LAST-macro.patch"
inherit autotools pkgconfig