aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot%.bbappend')
-rw-r--r--recipes-bsp/u-boot/u-boot%.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot%.bbappend b/recipes-bsp/u-boot/u-boot%.bbappend
index 801f710..401d649 100644
--- a/recipes-bsp/u-boot/u-boot%.bbappend
+++ b/recipes-bsp/u-boot/u-boot%.bbappend
@@ -4,3 +4,11 @@ do_compile_append_rock2-square () {
cp ${B}/spl/${SPL_BINARY} ${B}
fi
}
+
+ATF_DEPENDS ??= ""
+
+EXTRA_OEMAKE_append_rk3399 = " BL31=${DEPLOY_DIR_IMAGE}/bl31.elf"
+ATF_DEPENDS_rk3399 = "virtual/atf:do_deploy"
+
+do_compile[depends] += "${ATF_DEPENDS}"
+