aboutsummaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf')
-rw-r--r--conf/layer.conf10
-rw-r--r--conf/machine/firefly-rk3288.conf4
-rw-r--r--conf/machine/include/nanopi-m4.inc11
-rw-r--r--conf/machine/include/px30.inc21
-rw-r--r--conf/machine/include/rk3066.inc8
-rw-r--r--conf/machine/include/rk3188.inc8
-rw-r--r--conf/machine/include/rk3288.inc10
-rw-r--r--conf/machine/include/rk3308.inc18
-rw-r--r--conf/machine/include/rk3328.inc22
-rw-r--r--conf/machine/include/rk3399.inc22
-rw-r--r--conf/machine/include/rk3568.inc19
-rw-r--r--conf/machine/include/rk3588.inc6
-rw-r--r--conf/machine/include/rk3588s.inc17
-rw-r--r--conf/machine/include/rock-pi-4.inc6
-rw-r--r--conf/machine/include/rockchip-defaults.inc12
-rw-r--r--conf/machine/include/rockchip-extlinux.inc24
-rw-r--r--conf/machine/include/rockchip-wic.inc17
-rw-r--r--conf/machine/include/tinker.inc2
-rw-r--r--conf/machine/marsboard-rk3066.conf3
-rw-r--r--conf/machine/nanopi-m4-2gb.conf8
-rw-r--r--conf/machine/nanopi-m4.conf8
-rw-r--r--conf/machine/nanopi-m4b.conf11
-rw-r--r--conf/machine/nanopi-r2s.conf11
-rw-r--r--conf/machine/nanopi-r4s.conf11
-rw-r--r--conf/machine/orangepi-5-plus.conf12
-rw-r--r--conf/machine/radxarock.conf3
-rw-r--r--conf/machine/roc-rk3308-cc.conf12
-rw-r--r--conf/machine/roc-rk3328-cc.conf11
-rw-r--r--conf/machine/rock-3a.conf11
-rw-r--r--conf/machine/rock-4c-plus.conf10
-rw-r--r--conf/machine/rock-5a.conf11
-rw-r--r--conf/machine/rock-5b.conf11
-rw-r--r--conf/machine/rock-pi-4a.conf11
-rw-r--r--conf/machine/rock-pi-4b.conf11
-rw-r--r--conf/machine/rock-pi-4c.conf11
-rw-r--r--conf/machine/rock-pi-e.conf11
-rw-r--r--conf/machine/rock-pi-s.conf11
-rw-r--r--conf/machine/rock2-square.conf9
-rw-r--r--conf/machine/rock64.conf15
-rw-r--r--conf/machine/tinker-board-s.conf11
-rw-r--r--conf/machine/tinker-board.conf (renamed from conf/machine/tinker-rk3288.conf)5
-rw-r--r--conf/machine/veyron-speedy.conf20
-rw-r--r--conf/machine/vyasa-rk3288.conf3
43 files changed, 440 insertions, 48 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index f2cf469..68205dd 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -14,6 +14,10 @@ BBFILE_PRIORITY_rockchip = "1"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_rockchip = "1"
-LAYERSERIES_COMPAT_rockchip = "zeus"
-LAYERDEPENDS_rockchip = "core"
-LICENSE_PATH += "${LAYERDIR}/licenses"
+LAYERSERIES_COMPAT_rockchip = "scarthgap"
+LAYERDEPENDS_rockchip = "core meta-arm"
+
+BBFILES_DYNAMIC += " \
+ qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bb \
+ qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bbappend \
+"
diff --git a/conf/machine/firefly-rk3288.conf b/conf/machine/firefly-rk3288.conf
index 0900440..6ff1be8 100644
--- a/conf/machine/firefly-rk3288.conf
+++ b/conf/machine/firefly-rk3288.conf
@@ -7,7 +7,7 @@
#http://www.t-firefly.com/en/
require conf/machine/include/rk3288.inc
+require conf/machine/include/rockchip-wic.inc
-KERNEL_DEVICETREE = "rk3288-firefly.dtb"
+KERNEL_DEVICETREE = "rockchip/rk3288-firefly.dtb"
UBOOT_MACHINE = "firefly-rk3288_defconfig"
-GPTIMG_APPEND = "console=tty1 console=ttyS2,115200n8 rw root=/dev/mmcblk0p7 rootfstype=ext4 init=/sbin/init"
diff --git a/conf/machine/include/nanopi-m4.inc b/conf/machine/include/nanopi-m4.inc
new file mode 100644
index 0000000..aaf07a3
--- /dev/null
+++ b/conf/machine/include/nanopi-m4.inc
@@ -0,0 +1,11 @@
+# Copyright (C) 2021 Blade SAS
+# Common definitions for all NanoPi M4 RK3399 board variants
+
+# add a common override for all nanopi-m4
+MACHINEOVERRIDES =. "nanopi-m4:"
+
+require conf/machine/include/rk3399.inc
+
+MACHINE_FEATURES += "usbhost serial"
+
+KERNEL_DEVICETREE = "rockchip/rk3399-nanopi-m4.dtb"
diff --git a/conf/machine/include/px30.inc b/conf/machine/include/px30.inc
new file mode 100644
index 0000000..badcbcd
--- /dev/null
+++ b/conf/machine/include/px30.inc
@@ -0,0 +1,21 @@
+# Copyright (C) 2022 Theobroma Systems Design und Consulting
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SOC_FAMILY = "px30"
+
+DEFAULTTUNE ?= "cortexa35-crypto"
+
+require conf/machine/include/soc-family.inc
+require conf/machine/include/arm/armv8a/tune-cortexa35.inc
+require conf/machine/include/rockchip-defaults.inc
+require conf/machine/include/rockchip-wic.inc
+
+KBUILD_DEFCONFIG ?= "defconfig"
+KERNEL_CLASSES = "kernel-fitimage"
+KERNEL_IMAGETYPE ?= "fitImage"
+
+TFA_PLATFORM = "px30"
+TFA_BUILD_TARGET = "bl31"
+
+UBOOT_SUFFIX ?= "itb"
+UBOOT_ENTRYPOINT ?= "0x06000000"
diff --git a/conf/machine/include/rk3066.inc b/conf/machine/include/rk3066.inc
index 91fbbaa..3510df2 100644
--- a/conf/machine/include/rk3066.inc
+++ b/conf/machine/include/rk3066.inc
@@ -3,6 +3,12 @@
SOC_FAMILY = "rk3066"
-require conf/machine/include/tune-cortexa9.inc
+require conf/machine/include/arm/armv7a/tune-cortexa9.inc
require conf/machine/include/soc-family.inc
require conf/machine/include/rockchip-defaults.inc
+
+SERIAL_CONSOLES = "115200;ttyS2"
+
+KBUILD_DEFCONFIG = "multi_v7_defconfig"
+KERNEL_FEATURES:append:rk3066 = " bsp/rockchip/remove-non-rockchip-arch-arm.scc"
+KERNEL_IMAGETYPE ?= "zImage"
diff --git a/conf/machine/include/rk3188.inc b/conf/machine/include/rk3188.inc
index bd36837..830f908 100644
--- a/conf/machine/include/rk3188.inc
+++ b/conf/machine/include/rk3188.inc
@@ -3,6 +3,12 @@
SOC_FAMILY = "rk3188"
-require conf/machine/include/tune-cortexa9.inc
+require conf/machine/include/arm/armv7a/tune-cortexa9.inc
require conf/machine/include/soc-family.inc
require conf/machine/include/rockchip-defaults.inc
+
+SERIAL_CONSOLES = "115200;ttyFIQ0"
+
+KBUILD_DEFCONFIG = "multi_v7_defconfig"
+KERNEL_FEATURES:append:rk3188 = " bsp/rockchip/remove-non-rockchip-arch-arm.scc"
+KERNEL_IMAGETYPE ?= "zImage"
diff --git a/conf/machine/include/rk3288.inc b/conf/machine/include/rk3288.inc
index 0528e8a..e682c0b 100644
--- a/conf/machine/include/rk3288.inc
+++ b/conf/machine/include/rk3288.inc
@@ -3,14 +3,14 @@
SOC_FAMILY = "rk3288"
-require conf/machine/include/tune-cortexa17.inc
+require conf/machine/include/arm/armv7a/tune-cortexa17.inc
require conf/machine/include/soc-family.inc
require conf/machine/include/rockchip-defaults.inc
SERIAL_CONSOLES = "115200;ttyS2"
-PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot"
-SPL_BINARY ?= "u-boot-spl-dtb.bin"
+KBUILD_DEFCONFIG ?= "multi_v7_defconfig"
+KERNEL_FEATURES:append:rk3288 = " bsp/rockchip/remove-non-rockchip-arch-arm.scc"
+KERNEL_IMAGETYPE ?= "zImage"
-IMAGE_FSTYPES = "rockchip-gpt-img"
-IMAGE_CLASSES += "rockchip-gpt-img"
+UBOOT_SUFFIX ?= "bin"
diff --git a/conf/machine/include/rk3308.inc b/conf/machine/include/rk3308.inc
new file mode 100644
index 0000000..5a5dafd
--- /dev/null
+++ b/conf/machine/include/rk3308.inc
@@ -0,0 +1,18 @@
+SOC_FAMILY = "rk3308"
+
+DEFAULTTUNE ?= "cortexa35-crypto"
+
+require conf/machine/include/soc-family.inc
+require conf/machine/include/arm/armv8a/tune-cortexa35.inc
+require conf/machine/include/rockchip-defaults.inc
+require conf/machine/include/rockchip-wic.inc
+
+SERIAL_CONSOLES = "1500000;ttyS0"
+
+KBUILD_DEFCONFIG ?= "defconfig"
+KERNEL_FEATURES:append:rk3308 = " bsp/rockchip/remove-non-rockchip-arch-arm64.scc"
+KERNEL_CLASSES = "kernel-fitimage"
+KERNEL_IMAGETYPE ?= "fitImage"
+
+UBOOT_SUFFIX ?= "itb"
+UBOOT_ENTRYPOINT ?= "0x06000000"
diff --git a/conf/machine/include/rk3328.inc b/conf/machine/include/rk3328.inc
new file mode 100644
index 0000000..6be777c
--- /dev/null
+++ b/conf/machine/include/rk3328.inc
@@ -0,0 +1,22 @@
+# Copyright (C) 2021 Blade SAS
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SOC_FAMILY = "rk3328"
+
+DEFAULTTUNE ?= "cortexa53-crypto"
+
+require conf/machine/include/soc-family.inc
+require conf/machine/include/arm/armv8a/tune-cortexa53.inc
+require conf/machine/include/rockchip-defaults.inc
+require conf/machine/include/rockchip-wic.inc
+
+KBUILD_DEFCONFIG ?= "defconfig"
+KERNEL_FEATURES:append:rk3328 = " bsp/rockchip/remove-non-rockchip-arch-arm64.scc"
+KERNEL_CLASSES = "kernel-fitimage"
+KERNEL_IMAGETYPE ?= "fitImage"
+
+TFA_PLATFORM = "rk3328"
+TFA_BUILD_TARGET = "bl31"
+
+UBOOT_SUFFIX ?= "itb"
+UBOOT_ENTRYPOINT ?= "0x06000000"
diff --git a/conf/machine/include/rk3399.inc b/conf/machine/include/rk3399.inc
new file mode 100644
index 0000000..5a3f439
--- /dev/null
+++ b/conf/machine/include/rk3399.inc
@@ -0,0 +1,22 @@
+# Copyright (C) 2020 Garmin Ltd. or its subsidaries
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SOC_FAMILY = "rk3399"
+
+DEFAULTTUNE ?= "cortexa72-cortexa53-crypto"
+
+require conf/machine/include/soc-family.inc
+require conf/machine/include/arm/armv8a/tune-cortexa72-cortexa53.inc
+require conf/machine/include/rockchip-defaults.inc
+require conf/machine/include/rockchip-wic.inc
+
+KBUILD_DEFCONFIG ?= "defconfig"
+KERNEL_FEATURES:append:rk3399 = " bsp/rockchip/remove-non-rockchip-arch-arm64.scc"
+KERNEL_CLASSES = "kernel-fitimage"
+KERNEL_IMAGETYPE ?= "fitImage"
+
+TFA_PLATFORM = "rk3399"
+TFA_BUILD_TARGET = "bl31"
+
+UBOOT_SUFFIX ?= "itb"
+UBOOT_ENTRYPOINT ?= "0x06000000"
diff --git a/conf/machine/include/rk3568.inc b/conf/machine/include/rk3568.inc
new file mode 100644
index 0000000..3c227dc
--- /dev/null
+++ b/conf/machine/include/rk3568.inc
@@ -0,0 +1,19 @@
+SOC_FAMILY = "rk3568"
+
+DEFAULTTUNE ?= "cortexa55"
+
+require conf/machine/include/soc-family.inc
+require conf/machine/include/arm/armv8-2a/tune-cortexa55.inc
+require conf/machine/include/rockchip-defaults.inc
+require conf/machine/include/rockchip-wic.inc
+
+KBUILD_DEFCONFIG ?= "defconfig"
+KERNEL_FEATURES:append:rk3568 = " bsp/rockchip/remove-non-rockchip-arch-arm64.scc"
+KERNEL_CLASSES = "kernel-fitimage"
+KERNEL_IMAGETYPE ?= "fitImage"
+
+PREFERRED_PROVIDER_trusted-firmware-a = "rockchip-rkbin"
+PREFERRED_PROVIDER_optee-os = "rockchip-rkbin"
+
+UBOOT_SUFFIX ?= "itb"
+UBOOT_ENTRYPOINT ?= "0x06000000"
diff --git a/conf/machine/include/rk3588.inc b/conf/machine/include/rk3588.inc
new file mode 100644
index 0000000..34f0627
--- /dev/null
+++ b/conf/machine/include/rk3588.inc
@@ -0,0 +1,6 @@
+MACHINEOVERRIDES =. "rk3588:"
+
+# the rk3588s is a "stripped-down" version of the rk3588
+# in the kernel's device-tree the rk3588 builds on top of the rk3588s
+# so anything that is valid for the rk3588s is valid for the rk3588
+require conf/machine/include/rk3588s.inc
diff --git a/conf/machine/include/rk3588s.inc b/conf/machine/include/rk3588s.inc
new file mode 100644
index 0000000..878f7a8
--- /dev/null
+++ b/conf/machine/include/rk3588s.inc
@@ -0,0 +1,17 @@
+MACHINEOVERRIDES =. "rk3588s:"
+DEFAULTTUNE ?= "cortexa76-cortexa55-crypto"
+
+require conf/machine/include/arm/armv8-2a/tune-cortexa76-cortexa55.inc
+require conf/machine/include/rockchip-defaults.inc
+require conf/machine/include/rockchip-wic.inc
+
+KBUILD_DEFCONFIG ?= "defconfig"
+KERNEL_FEATURES:append:rk3588s = " bsp/rockchip/remove-non-rockchip-arch-arm64.scc"
+KERNEL_CLASSES = "kernel-fitimage"
+KERNEL_IMAGETYPE ?= "fitImage"
+
+PREFERRED_PROVIDER_trusted-firmware-a = "rockchip-rkbin"
+PREFERRED_PROVIDER_optee-os = "rockchip-rkbin"
+
+UBOOT_SUFFIX ?= "itb"
+UBOOT_ENTRYPOINT ?= "0x06000000"
diff --git a/conf/machine/include/rock-pi-4.inc b/conf/machine/include/rock-pi-4.inc
new file mode 100644
index 0000000..0a86846
--- /dev/null
+++ b/conf/machine/include/rock-pi-4.inc
@@ -0,0 +1,6 @@
+# Add a common override for all Rock Pi 4 machines
+MACHINEOVERRIDES =. "rock-pi-4:"
+
+require conf/machine/include/rk3399.inc
+
+MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
diff --git a/conf/machine/include/rockchip-defaults.inc b/conf/machine/include/rockchip-defaults.inc
index ed180f9..2387eb9 100644
--- a/conf/machine/include/rockchip-defaults.inc
+++ b/conf/machine/include/rockchip-defaults.inc
@@ -1,13 +1,10 @@
# meta-rockchip default settings
# kernel
-PREFERRED_PROVIDER_virtual/kernel ?= "linux-stable"
-LINUX_VERSION_EXTENSION ?= "-rockchip"
-KBUILD_DEFCONFIG = "multi_v7_defconfig"
-KERNEL_IMAGETYPE = "zImage"
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
+KCONFIG_MODE ?= "alldefconfig"
# xserver
-PREFERRED_PROVIDER_virtual/xserver = "xserver-xorg"
XSERVER = " \
xserver-xorg \
xserver-xorg-utils \
@@ -18,8 +15,9 @@ XSERVER = " \
xf86-video-modesetting \
xf86-input-evdev \
xf86-input-mouse \
- xf86-input-keyboard \
"
# misc
-IMAGE_FSTYPES += "ext4"
+SERIAL_CONSOLES ?= "1500000;ttyS2"
+RK_CONSOLE_BAUD ?= "${@d.getVar('SERIAL_CONSOLES').split(';')[0]}"
+RK_CONSOLE_DEVICE ?= "${@d.getVar('SERIAL_CONSOLES').split(';')[1].split()[0]}"
diff --git a/conf/machine/include/rockchip-extlinux.inc b/conf/machine/include/rockchip-extlinux.inc
new file mode 100644
index 0000000..ca33f4c
--- /dev/null
+++ b/conf/machine/include/rockchip-extlinux.inc
@@ -0,0 +1,24 @@
+# KERNEL_DEVICETREE follows the pattern of
+# 'rockchip/${SOC_FAMILY}-${BOARD}.dtb' which is required when compiling
+# the kernel so the kernel's Makefile can find the device tree
+#
+# when using extlinux with a fitImage the device tree is contained in the
+# fitImage
+#
+# however for non-fitImages it is not found at
+# $UBOOT_EXTLINUX_FDTDIR/rockchip/$KERNEL_DEVICETREE but rather at
+# $UBOOT_EXTLINUX_FDTDIR/$KERNEL_DEVICETREE therefore we need to strip off
+# the 'rockchip/' part for extlinux non-fitImage builds
+NONFITDT ?= "${@d.getVar('KERNEL_DEVICETREE').split('/')[1]}"
+
+UBOOT_EXTLINUX ?= "1"
+UBOOT_EXTLINUX_ROOT ?= "root=PARTLABEL=root"
+UBOOT_EXTLINUX_FDTDIR ?= "${@bb.utils.contains('KERNEL_IMAGETYPE', 'fitImage', '', '/boot', d)}"
+UBOOT_EXTLINUX_FDT ?= "${@bb.utils.contains('KERNEL_IMAGETYPE', 'fitImage', '', '${NONFITDT}', d)}"
+UBOOT_EXTLINUX_CONSOLE ?= "earlycon console=tty1 console=${RK_CONSOLE_DEVICE},${RK_CONSOLE_BAUD}n8"
+UBOOT_EXTLINUX_KERNEL_ARGS ?= "rootwait rw rootfstype=ext4"
+UBOOT_EXTLINUX_KERNEL_IMAGE ?= "/boot/${KERNEL_IMAGETYPE}"
+UBOOT_EXTLINUX_LABELS ?= "default"
+UBOOT_EXTLINUX_MENU_DESCRIPTION:default ?= "${MACHINE}"
+
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "u-boot-extlinux"
diff --git a/conf/machine/include/rockchip-wic.inc b/conf/machine/include/rockchip-wic.inc
new file mode 100644
index 0000000..147a366
--- /dev/null
+++ b/conf/machine/include/rockchip-wic.inc
@@ -0,0 +1,17 @@
+# common meta-rockchip wic/wks items
+
+require conf/machine/include/rockchip-extlinux.inc
+
+SPL_BINARY ?= "idbloader.img"
+
+IMAGE_FSTYPES += "wic wic.bmap"
+WKS_FILE ?= "rockchip.wks"
+WKS_FILE_DEPENDS ?= " \
+ e2fsprogs-native \
+ virtual/bootloader \
+ "
+
+WICVARS:append = " \
+ SPL_BINARY \
+ UBOOT_SUFFIX \
+ "
diff --git a/conf/machine/include/tinker.inc b/conf/machine/include/tinker.inc
new file mode 100644
index 0000000..2d05bef
--- /dev/null
+++ b/conf/machine/include/tinker.inc
@@ -0,0 +1,2 @@
+require conf/machine/include/rk3288.inc
+require conf/machine/include/rockchip-wic.inc
diff --git a/conf/machine/marsboard-rk3066.conf b/conf/machine/marsboard-rk3066.conf
index 09414bc..36945e8 100644
--- a/conf/machine/marsboard-rk3066.conf
+++ b/conf/machine/marsboard-rk3066.conf
@@ -8,5 +8,4 @@
require conf/machine/include/rk3066.inc
-SERIAL_CONSOLES = "115200;ttyS2"
-KERNEL_DEVICETREE = "rk3066a-marsboard.dtb"
+KERNEL_DEVICETREE = "rockchip/rk3066a-marsboard.dtb"
diff --git a/conf/machine/nanopi-m4-2gb.conf b/conf/machine/nanopi-m4-2gb.conf
new file mode 100644
index 0000000..9fd7279
--- /dev/null
+++ b/conf/machine/nanopi-m4-2gb.conf
@@ -0,0 +1,8 @@
+# Copyright (C) 2021 Blade SAS
+
+#@TYPE: Machine
+#@NAME: NanoPi M4
+#@DESCRIPTION: NanoPi M4 RK3399 board from FriendlyElec, 2GB variant
+
+require include/nanopi-m4.inc
+UBOOT_MACHINE = "nanopi-m4-2gb-rk3399_defconfig"
diff --git a/conf/machine/nanopi-m4.conf b/conf/machine/nanopi-m4.conf
new file mode 100644
index 0000000..648fc75
--- /dev/null
+++ b/conf/machine/nanopi-m4.conf
@@ -0,0 +1,8 @@
+# Copyright (C) 2021 Blade SAS
+
+#@TYPE: Machine
+#@NAME: NanoPi M4
+#@DESCRIPTION: NanoPi M4 RK3399 board from FriendlyElec, 4GB variant
+
+require include/nanopi-m4.inc
+UBOOT_MACHINE = "nanopi-m4-rk3399_defconfig"
diff --git a/conf/machine/nanopi-m4b.conf b/conf/machine/nanopi-m4b.conf
new file mode 100644
index 0000000..35cd8f6
--- /dev/null
+++ b/conf/machine/nanopi-m4b.conf
@@ -0,0 +1,11 @@
+#@TYPE: Machine
+#@NAME: NanoPi M4B
+#@DESCRIPTION: NanoPi M4B RK3399-based board which has the same form factor as the RPi B3+.
+#https://www.friendlyelec.com/index.php?route=product/product&product_id=275
+
+require conf/machine/include/rk3399.inc
+
+MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
+
+KERNEL_DEVICETREE = "rockchip/rk3399-nanopi-m4b.dtb"
+UBOOT_MACHINE = "nanopi-m4b-rk3399_defconfig"
diff --git a/conf/machine/nanopi-r2s.conf b/conf/machine/nanopi-r2s.conf
new file mode 100644
index 0000000..4472c21
--- /dev/null
+++ b/conf/machine/nanopi-r2s.conf
@@ -0,0 +1,11 @@
+#@TYPE: Machine
+#@NAME: NanoPi R2S
+#@DESCRIPTION: The NanoPi R2S is a mini router with edge computing and dual GbE ports by FriendlyElec
+#https://www.friendlyelec.com/index.php?route=product/product&product_id=282
+
+require conf/machine/include/rk3328.inc
+
+KERNEL_DEVICETREE = "rockchip/rk3328-nanopi-r2s.dtb"
+MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
+
+UBOOT_MACHINE = "nanopi-r2s-rk3328_defconfig"
diff --git a/conf/machine/nanopi-r4s.conf b/conf/machine/nanopi-r4s.conf
new file mode 100644
index 0000000..21be440
--- /dev/null
+++ b/conf/machine/nanopi-r4s.conf
@@ -0,0 +1,11 @@
+#@TYPE: Machine
+#@NAME: NanoPi R4S
+#@DESCRIPTION: NanoPi R4S is a high-end FriendlyElec mini-router based on the RK3399 SoC
+#https://www.friendlyelec.com/index.php?route=product/product&product_id=284
+
+require conf/machine/include/rk3399.inc
+
+MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
+
+KERNEL_DEVICETREE = "rockchip/rk3399-nanopi-r4s.dtb"
+UBOOT_MACHINE = "nanopi-r4s-rk3399_defconfig"
diff --git a/conf/machine/orangepi-5-plus.conf b/conf/machine/orangepi-5-plus.conf
new file mode 100644
index 0000000..2731ff4
--- /dev/null
+++ b/conf/machine/orangepi-5-plus.conf
@@ -0,0 +1,12 @@
+#@TYPE: Machine
+#@NAME: Orange Pi 5 Plus
+#@DESCRIPTION: 5th generation SBC designed by Kunlong Co.,Limited.
+#http://www.orangepi.org/html/hardWare/computerAndMicrocontrollers/details/Orange-Pi-5-plus-32GB.html
+
+require conf/machine/include/rk3588.inc
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-dev"
+KERNEL_DEVICETREE = "rockchip/rk3588-orangepi-5-plus.dtb"
+MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
+
+UBOOT_MACHINE = "orangepi-5-plus-rk3588_defconfig"
diff --git a/conf/machine/radxarock.conf b/conf/machine/radxarock.conf
index 2036f6a..6ad8474 100644
--- a/conf/machine/radxarock.conf
+++ b/conf/machine/radxarock.conf
@@ -9,5 +9,4 @@
require conf/machine/include/rk3188.inc
-SERIAL_CONSOLES = "115200;ttyFIQ0"
-KERNEL_DEVICETREE = "rk3188-radxarock.dtb"
+KERNEL_DEVICETREE = "rockchip/rk3188-radxarock.dtb"
diff --git a/conf/machine/roc-rk3308-cc.conf b/conf/machine/roc-rk3308-cc.conf
new file mode 100644
index 0000000..839e73c
--- /dev/null
+++ b/conf/machine/roc-rk3308-cc.conf
@@ -0,0 +1,12 @@
+# Copyright (C) 2024 Trevor Woerner
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+#@TYPE: Machine
+#@NAME: roc-rk3308-cc
+#@DESCRIPTION: T-Firefly ROC-RK3308-CC SBC
+#https://en.t-firefly.com/product/rocrk3308cc
+
+require include/rk3308.inc
+
+UBOOT_MACHINE = "roc-cc-rk3308_defconfig"
+KERNEL_DEVICETREE = "rockchip/rk3308-roc-cc.dtb"
diff --git a/conf/machine/roc-rk3328-cc.conf b/conf/machine/roc-rk3328-cc.conf
new file mode 100644
index 0000000..05216ec
--- /dev/null
+++ b/conf/machine/roc-rk3328-cc.conf
@@ -0,0 +1,11 @@
+# Copyright (C) 2021 Trevor Woerner
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+#@TYPE: Machine
+#@NAME: roc-rk3328-cc (aka "renegade")
+#@DESCRIPTION: Libre Computer Board ROC-RK3328-CC (Renegade) Mini Computer with Gigabit Ethernet and USB 3.0
+
+require include/rk3328.inc
+
+UBOOT_MACHINE = "roc-cc-rk3328_defconfig"
+KERNEL_DEVICETREE = "rockchip/rk3328-roc-cc.dtb"
diff --git a/conf/machine/rock-3a.conf b/conf/machine/rock-3a.conf
new file mode 100644
index 0000000..ec3d914
--- /dev/null
+++ b/conf/machine/rock-3a.conf
@@ -0,0 +1,11 @@
+#@TYPE: Machine
+#@NAME: Radxa Rock 3a
+#@DESCRIPTION: ROCK3 is a series of Rockchip RK3566/RK3568 based SBC(Single Board Computer) and Compute Module by Radxa.
+#https://wiki.radxa.com/Rock3/3a
+
+require conf/machine/include/rk3568.inc
+
+KERNEL_DEVICETREE = "rockchip/rk3568-rock-3a.dtb"
+MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
+
+UBOOT_MACHINE = "rock-3a-rk3568_defconfig"
diff --git a/conf/machine/rock-4c-plus.conf b/conf/machine/rock-4c-plus.conf
new file mode 100644
index 0000000..fec4167
--- /dev/null
+++ b/conf/machine/rock-4c-plus.conf
@@ -0,0 +1,10 @@
+#@TYPE: Machine
+#@NAME: ROCK 4C Plus
+#@DESCRIPTION: ROCK 4C Plus based on Rockchip RK3399-T Processor is designed by Radxa.
+#https://wiki.radxa.com/Rock4/4cplus
+#https://docs.radxa.com/en/rock4/rock4c+
+
+require conf/machine/include/rock-pi-4.inc
+
+KERNEL_DEVICETREE = "rockchip/rk3399-rock-4c-plus.dtb"
+UBOOT_MACHINE = "rock-4c-plus-rk3399_defconfig"
diff --git a/conf/machine/rock-5a.conf b/conf/machine/rock-5a.conf
new file mode 100644
index 0000000..1a6aa36
--- /dev/null
+++ b/conf/machine/rock-5a.conf
@@ -0,0 +1,11 @@
+#@TYPE: Machine
+#@NAME: Radxa Rock 5A
+#@DESCRIPTION: ROCK5 is the 5th generation of SBC designed by Radxa.
+#https://docs.radxa.com/en/rock5/rock5a
+
+require conf/machine/include/rk3588s.inc
+
+KERNEL_DEVICETREE = "rockchip/rk3588s-rock-5a.dtb"
+MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
+
+UBOOT_MACHINE = "rock5a-rk3588s_defconfig"
diff --git a/conf/machine/rock-5b.conf b/conf/machine/rock-5b.conf
new file mode 100644
index 0000000..c3a9b0a
--- /dev/null
+++ b/conf/machine/rock-5b.conf
@@ -0,0 +1,11 @@
+#@TYPE: Machine
+#@NAME: Radxa Rock 5B
+#@DESCRIPTION: ROCK5 is the 5th generation of SBC designed by Radxa.
+#https://wiki.radxa.com/Rock5/5b
+
+require conf/machine/include/rk3588.inc
+
+KERNEL_DEVICETREE = "rockchip/rk3588-rock-5b.dtb"
+MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
+
+UBOOT_MACHINE = "rock5b-rk3588_defconfig"
diff --git a/conf/machine/rock-pi-4a.conf b/conf/machine/rock-pi-4a.conf
new file mode 100644
index 0000000..abe2336
--- /dev/null
+++ b/conf/machine/rock-pi-4a.conf
@@ -0,0 +1,11 @@
+#@TYPE: Machine
+#@NAME: Rock Pi 4A RK3399
+#@DESCRIPTION: Rock Pi 4 is a Raspberry Pi 4 Alternative based on Rockchip RK3399 Processor.
+#
+# NOTE: This machine is for Kernel 5.10 and later. If you are using an older
+# kernel, see rock-pi-4.conf
+
+require conf/machine/include/rock-pi-4.inc
+
+KERNEL_DEVICETREE = "rockchip/rk3399-rock-pi-4a.dtb"
+UBOOT_MACHINE = "rock-pi-4-rk3399_defconfig"
diff --git a/conf/machine/rock-pi-4b.conf b/conf/machine/rock-pi-4b.conf
new file mode 100644
index 0000000..587fb32
--- /dev/null
+++ b/conf/machine/rock-pi-4b.conf
@@ -0,0 +1,11 @@
+#@TYPE: Machine
+#@NAME: Rock Pi 4B RK3399
+#@DESCRIPTION: Rock Pi 4 is a Raspberry Pi 4 Alternative based on Rockchip RK3399 Processor.
+#
+# NOTE: This machine is for Kernel 5.10 and later. If you are using an older
+# kernel, see rock-pi-4.conf
+
+require conf/machine/include/rock-pi-4.inc
+
+KERNEL_DEVICETREE = "rockchip/rk3399-rock-pi-4b.dtb"
+UBOOT_MACHINE = "rock-pi-4-rk3399_defconfig"
diff --git a/conf/machine/rock-pi-4c.conf b/conf/machine/rock-pi-4c.conf
new file mode 100644
index 0000000..3af26ff
--- /dev/null
+++ b/conf/machine/rock-pi-4c.conf
@@ -0,0 +1,11 @@
+#@TYPE: Machine
+#@NAME: Rock Pi 4C RK3399
+#@DESCRIPTION: Rock Pi 4 is a Raspberry Pi 4 Alternative based on Rockchip RK3399 Processor.
+#
+# NOTE: This machine is for Kernel 5.10 and later. If you are using an older
+# kernel, see rock-pi-4.conf
+
+require conf/machine/include/rock-pi-4.inc
+
+KERNEL_DEVICETREE = "rockchip/rk3399-rock-pi-4c.dtb"
+UBOOT_MACHINE = "rock-pi-4c-rk3399_defconfig"
diff --git a/conf/machine/rock-pi-e.conf b/conf/machine/rock-pi-e.conf
new file mode 100644
index 0000000..517956c
--- /dev/null
+++ b/conf/machine/rock-pi-e.conf
@@ -0,0 +1,11 @@
+#@TYPE: Machine
+#@NAME: ROCK Pi E rk3328
+#@DESCRIPTION: ROCK Pi E is a Rockchip RK3328-based SBC by Radxa. E is for Ethernets.
+#https://wiki.radxa.com/RockpiE
+
+require conf/machine/include/rk3328.inc
+
+KERNEL_DEVICETREE = "rockchip/rk3328-rock-pi-e.dtb"
+MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
+
+UBOOT_MACHINE = "rock-pi-e-rk3328_defconfig"
diff --git a/conf/machine/rock-pi-s.conf b/conf/machine/rock-pi-s.conf
new file mode 100644
index 0000000..79ea73c
--- /dev/null
+++ b/conf/machine/rock-pi-s.conf
@@ -0,0 +1,11 @@
+#@TYPE: Machine
+#@NAME: Radxa Rock Pi S
+#@DESCRIPTION: ROCK Pi S is a Rockchip RK3308 based SBC by Radxa. "S" stands for "small square"
+#https://wiki.radxa.com/RockpiS
+
+require conf/machine/include/rk3308.inc
+
+KERNEL_DEVICETREE = "rockchip/rk3308-rock-pi-s.dtb"
+MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
+
+UBOOT_MACHINE = "rock-pi-s-rk3308_defconfig"
diff --git a/conf/machine/rock2-square.conf b/conf/machine/rock2-square.conf
index 1f4e938..9468b9a 100644
--- a/conf/machine/rock2-square.conf
+++ b/conf/machine/rock2-square.conf
@@ -8,5 +8,12 @@
require conf/machine/include/rk3288.inc
-KERNEL_DEVICETREE = "rk3288-rock2-square.dtb"
+SPL_BINARY = "u-boot-spl-dtb.bin"
+KERNEL_DEVICETREE = "rockchip/rk3288-rock2-square.dtb"
UBOOT_MACHINE = "rock2_defconfig"
+
+# This board doesn't support the combined idbloader, so resort to the older
+# image class
+IMAGE_FSTYPES += "rockchip-gpt-img"
+IMAGE_CLASSES += "rockchip-gpt-img"
+
diff --git a/conf/machine/rock64.conf b/conf/machine/rock64.conf
new file mode 100644
index 0000000..fa75a51
--- /dev/null
+++ b/conf/machine/rock64.conf
@@ -0,0 +1,15 @@
+# Copyright (C) 2021 Blade SAS
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+#@TYPE: Machine
+#@NAME: Rock64
+#@DESCRIPTION: Rock64 RK3328 board from Pine64
+
+require include/rk3328.inc
+
+MACHINE_FEATURES += "usbhost serial"
+
+UBOOT_MACHINE = "rock64-rk3328_defconfig"
+KERNEL_DEVICETREE = "rockchip/rk3328-rock64.dtb"
+
+KBUILD_DEFCONFIG = "defconfig"
diff --git a/conf/machine/tinker-board-s.conf b/conf/machine/tinker-board-s.conf
new file mode 100644
index 0000000..3a65613
--- /dev/null
+++ b/conf/machine/tinker-board-s.conf
@@ -0,0 +1,11 @@
+# Copyright (C) 2020 Sergey Bostandzhyan
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+#@TYPE: Machine
+#@NAME: Tinker-S RK3288
+#@DESCRIPTION: ASUS Tinker Board is a Raspberry Pi 3 Alternative based on Rockchip RK3288 Processor.
+
+require conf/machine/include/tinker.inc
+
+KERNEL_DEVICETREE = "rockchip/rk3288-tinker-s.dtb"
+UBOOT_MACHINE = "tinker-s-rk3288_defconfig"
diff --git a/conf/machine/tinker-rk3288.conf b/conf/machine/tinker-board.conf
index 9e23f8d..ef1a1c1 100644
--- a/conf/machine/tinker-rk3288.conf
+++ b/conf/machine/tinker-board.conf
@@ -5,8 +5,7 @@
#@NAME: Tinker RK3288
#@DESCRIPTION: ASUS Tinker Board is a Raspberry Pi 3 Alternative based on Rockchip RK3288 Processor.
-require conf/machine/include/rk3288.inc
+require conf/machine/include/tinker.inc
-KERNEL_DEVICETREE = "rk3288-tinker.dtb"
+KERNEL_DEVICETREE = "rockchip/rk3288-tinker.dtb"
UBOOT_MACHINE = "tinker-rk3288_defconfig"
-GPTIMG_APPEND = "console=tty1 console=ttyS2,115200n8 rw root=/dev/mmcblk0p7 rootfstype=ext4 init=/sbin/init"
diff --git a/conf/machine/veyron-speedy.conf b/conf/machine/veyron-speedy.conf
deleted file mode 100644
index 3d857a0..0000000
--- a/conf/machine/veyron-speedy.conf
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright (C) 2015 Romain Perier
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-#@TYPE: Machine
-#@NAME: RK3288 Speedy
-#@DESCRIPTION: Google Veyron Speedy Rev 1+ board (formally known as Chromebook Asus C201)
-#https://www.google.com/chromebook/find/#?device=asus-chromebook-c201
-
-require conf/machine/include/rk3288.inc
-
-KERNEL_DEVICETREE = "rk3288-speedy.dtb"
-MACHINE_EXTRA_RDEPENDS = "linux-firmware-bcm4354 linux-firmware-bcm-veyron kernel-module-brcmfmac kernel-module-cros-ec-accel kernel-module-btbcm kernel-module-hci-uart"
-PREFERRED_PROVIDER_virtual/kernel = "linux-veyron"
-
-XSERVER = " xserver-xorg \
- xf86-input-evdev \
- xf86-input-synaptics \
- xf86-input-keyboard"
-
-UBOOT_MACHINE = "chromebook_minnie_defconfig"
diff --git a/conf/machine/vyasa-rk3288.conf b/conf/machine/vyasa-rk3288.conf
index bfbd09b..52b4401 100644
--- a/conf/machine/vyasa-rk3288.conf
+++ b/conf/machine/vyasa-rk3288.conf
@@ -6,9 +6,10 @@
#@DESCRIPTION: Amarula Vyasa is Rockchip RK3288 SOC based Single board computer with fully supported opensource software.
require conf/machine/include/rk3288.inc
+require conf/machine/include/rockchip-wic.inc
KERNEL_IMAGETYPE = "uImage"
-KERNEL_DEVICETREE = "rk3288-vyasa.dtb"
+KERNEL_DEVICETREE = "rockchip/rk3288-vyasa.dtb"
KERNEL_EXTRA_ARGS += "LOADADDR=0x02000000"
UBOOT_MACHINE = "vyasa-rk3288_defconfig"