aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/include/rk3066.inc2
-rw-r--r--conf/machine/include/rk3188.inc2
-rw-r--r--conf/machine/radxarock.conf2
-rw-r--r--recipes-devtools/prebuilt-gcc-linaro/prebuilt-gcc-linaro_4.9-2016.02.bb27
-rw-r--r--recipes-kernel/linux/linux-rockchip/0001-arm-mach-rk3188-Fix-relative-path-for-dependencies.patch61
-rw-r--r--recipes-kernel/linux/linux-rockchip/0002-Some-other-fixes.patch41
-rw-r--r--recipes-kernel/linux/linux-rockchip_3.0.bb44
7 files changed, 1 insertions, 178 deletions
diff --git a/conf/machine/include/rk3066.inc b/conf/machine/include/rk3066.inc
index d4c29e5..4039034 100644
--- a/conf/machine/include/rk3066.inc
+++ b/conf/machine/include/rk3066.inc
@@ -14,8 +14,6 @@ XSERVER = "xserver-xorg \
xf86-input-mouse \
xf86-input-keyboard"
-PREFERRED_PROVIDER_virtual/kernel = "linux-rockchip-3.0"
-
KERNEL_IMAGETYPE = "zImage"
IMAGE_FSTYPES += "ext4"
diff --git a/conf/machine/include/rk3188.inc b/conf/machine/include/rk3188.inc
index 510dbec..73f9dbd 100644
--- a/conf/machine/include/rk3188.inc
+++ b/conf/machine/include/rk3188.inc
@@ -13,8 +13,6 @@ XSERVER = "xserver-xorg \
xf86-input-mouse \
xf86-input-keyboard"
-PREFERRED_PROVIDER_virtual/kernel = "linux-rockchip-3.0"
-
KERNEL_IMAGETYPE = "zImage"
IMAGE_FSTYPES += "ext4"
diff --git a/conf/machine/radxarock.conf b/conf/machine/radxarock.conf
index 2f812c6..c89b7c3 100644
--- a/conf/machine/radxarock.conf
+++ b/conf/machine/radxarock.conf
@@ -9,7 +9,7 @@
require conf/machine/include/rk3188.inc
-PREFERRED_PROVIDER_virtual/kernel ?= "linux-rockchip"
+PREFERRED_PROVIDER_virtual/kernel = "linux"
SERIAL_CONSOLES ?= "115200;ttyFIQ0"
KERNEL_DEVICETREE ?= "rk3188-radxarock.dtb"
OLDEST_KERNEL ?= "3.0"
diff --git a/recipes-devtools/prebuilt-gcc-linaro/prebuilt-gcc-linaro_4.9-2016.02.bb b/recipes-devtools/prebuilt-gcc-linaro/prebuilt-gcc-linaro_4.9-2016.02.bb
deleted file mode 100644
index a6af321..0000000
--- a/recipes-devtools/prebuilt-gcc-linaro/prebuilt-gcc-linaro_4.9-2016.02.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright (C) 2016 Romain Perier
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-inherit base native
-
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM="file://include/gmp.h;beginline=1;endline=29;md5=6e0172559b628f995afd902f4920f78b"
-ARM_ABI = "arm-linux-gnueabi"
-VER = "${PV}-x86_64_${ARM_ABI}"
-SRC_URI = "https://releases.linaro.org/components/toolchain/binaries/${PV}/${ARM_ABI}/gcc-linaro-${VER}.tar.xz"
-SRC_URI[sha256sum] = "fdef102e754b2aa9e7d0b2ad465216a41b421694e1ce0cc972621214f8ac4bd5"
-
-S = "${WORKDIR}/gcc-linaro-${VER}"
-
-python do_fetch() {
- build_arch = d.getVar("BUILD_ARCH", True)
- if build_arch != "x86_64":
- bb.fatal("Build architecture '%s' is not supported by this package\n" % build_arch)
- bb.build.exec_func("base_do_fetch", d)
-}
-
-do_install() {
- DIRS="arm-linux-gnueabi bin lib libexec"
- for subdir in $DIRS; do
- cp -rPp ${S}/${subdir} ${STAGING_DIR_NATIVE}${prefix_native}
- done
-}
diff --git a/recipes-kernel/linux/linux-rockchip/0001-arm-mach-rk3188-Fix-relative-path-for-dependencies.patch b/recipes-kernel/linux/linux-rockchip/0001-arm-mach-rk3188-Fix-relative-path-for-dependencies.patch
deleted file mode 100644
index b60985e..0000000
--- a/recipes-kernel/linux/linux-rockchip/0001-arm-mach-rk3188-Fix-relative-path-for-dependencies.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 72adac076e0d98fc2c3e846de72edf6169707cec Mon Sep 17 00:00:00 2001
-From: Romain Perier <romain.perier@gmail.com>
-Date: Thu, 1 Dec 2016 16:32:13 +0100
-Subject: [PATCH] arm: mach-rk3188: Fix relative path for dependencies
-
-Don't include relative path for dependencies modules, it breaks
-out of source builds.
-
-Signed-off-by: Romain Perier <romain.perier@gmail.com>
----
- arch/arm/mach-rk3188/Makefile | 24 ++++++++++++------------
- 1 file changed, 12 insertions(+), 12 deletions(-)
-
-diff --git a/arch/arm/mach-rk3188/Makefile b/arch/arm/mach-rk3188/Makefile
-index b80abdc..2fb39fb 100644
---- a/arch/arm/mach-rk3188/Makefile
-+++ b/arch/arm/mach-rk3188/Makefile
-@@ -1,28 +1,28 @@
- EXTRA_CFLAGS += -Os
- ifneq ($(CONFIG_RK_FPGA),y)
--obj-y += ../plat-rk/clock.o
-+obj-y += clock.o
- obj-y += clock_data.o
--obj-y += ../mach-rk30/ddr.o
--obj-y += ../mach-rk30/pmu.o
--obj-y += ../mach-rk30/reset.o
--obj-$(CONFIG_PM) += ../mach-rk30/pm.o
-+obj-y += ddr.o
-+obj-y += pmu.o
-+obj-y += reset.o
-+obj-$(CONFIG_PM) += pm.o
- endif
--obj-y += ../mach-rk30/common.o
-+obj-y += common.o
- CFLAGS_common.o += -DTEXT_OFFSET=$(TEXT_OFFSET)
--obj-y += ../mach-rk30/devices.o
-+obj-y += devices.o
- obj-y += io.o
- obj-y += rk_timer.o
--obj-$(CONFIG_SMP) += ../mach-rk30/platsmp.o ../mach-rk30/headsmp.o
--obj-$(CONFIG_HOTPLUG_CPU) += ../mach-rk30/hotplug.o
--obj-$(CONFIG_CPU_IDLE) += ../mach-rk30/cpuidle.o
-+obj-$(CONFIG_SMP) += platsmp.o headsmp.o
-+obj-$(CONFIG_HOTPLUG_CPU) += hotplug.o
-+obj-$(CONFIG_CPU_IDLE) += cpuidle.o
- obj-$(CONFIG_CPU_FREQ) += cpufreq.o
- obj-$(CONFIG_DVFS) += dvfs.o
- obj-y += board.o
-
- board-$(CONFIG_MACH_RK3188_FPGA) += board-rk3188-fpga.o
--board-$(CONFIG_MACH_RK3188_TB) += ../mach-rk30/board-rk3168-tb.o
-+board-$(CONFIG_MACH_RK3188_TB) += board-rk3168-tb.o
- board-$(CONFIG_MACH_RK3188_SDK) += board-rk3188-sdk.o
--board-$(CONFIG_MACH_RK3188_LR097) += ../mach-rk30/board-rk3168-LR097.o
-+board-$(CONFIG_MACH_RK3188_LR097) += board-rk3168-LR097.o
- board-$(CONFIG_MACH_RK3188_DS1006H) += board-rk3188-ds1006h.o
- obj-$(CONFIG_SOC_RK3188) += board.o
- board-$(CONFIG_MACH_RK3188_FAC) += board-rk3188-fac.o
---
-2.9.3
-
diff --git a/recipes-kernel/linux/linux-rockchip/0002-Some-other-fixes.patch b/recipes-kernel/linux/linux-rockchip/0002-Some-other-fixes.patch
deleted file mode 100644
index ffb8a20..0000000
--- a/recipes-kernel/linux/linux-rockchip/0002-Some-other-fixes.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From fc28debedc298cdd19e0327ac416c0e51a74fe6d Mon Sep 17 00:00:00 2001
-From: Romain Perier <romain.perier@gmail.com>
-Date: Fri, 2 Dec 2016 18:46:33 +0100
-Subject: [PATCH] Some other fixes
-
-Signed-off-by: Romain Perier <romain.perier@free-electrons.com>
----
- drivers/net/wireless/Makefile | 2 +-
- kernel/timeconst.pl | 3 ---
- 2 files changed, 1 insertion(+), 4 deletions(-)
-
-diff --git a/drivers/net/wireless/Makefile b/drivers/net/wireless/Makefile
-index becd320..a8fbdb7 100755
---- a/drivers/net/wireless/Makefile
-+++ b/drivers/net/wireless/Makefile
-@@ -1,7 +1,7 @@
- #
- # Makefile for the Linux Wireless network device drivers.
- #
--obj-y += wifi_sys/rkwifi_sys_iface.o
-+obj-y += $(realpath wifi_sys/rkwifi_sys_iface.o)
- obj-$(CONFIG_BCM4329) += bcm4329/
- obj-$(CONFIG_MV8686) += mv8686/
- obj-$(CONFIG_BCM4319) += bcm4319/
-diff --git a/kernel/timeconst.pl b/kernel/timeconst.pl
-index eb51d76..82266f5 100644
---- a/kernel/timeconst.pl
-+++ b/kernel/timeconst.pl
-@@ -370,9 +370,6 @@ if ($hz eq '--can') {
- }
-
- @val = @{$canned_values{$hz}};
-- if (!defined(@val)) {
-- @val = compute_values($hz);
-- }
- output($hz, @val);
- }
- exit 0;
---
-2.9.3
-
diff --git a/recipes-kernel/linux/linux-rockchip_3.0.bb b/recipes-kernel/linux/linux-rockchip_3.0.bb
deleted file mode 100644
index 8506f4d..0000000
--- a/recipes-kernel/linux/linux-rockchip_3.0.bb
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright (C) 2016 Romain Perier
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-require recipes-kernel/linux/linux-yocto.inc
-
-SRC_URI = "git://github.com/radxa/linux-rockchip.git;branch=radxa-stable-3.0 \
- file://0001-arm-mach-rk3188-Fix-relative-path-for-dependencies.patch \
- file://0002-Some-other-fixes.patch"
-SRCREV = "${AUTOREV}"
-PV = "3.0.36"
-DEPENDS = "prebuilt-gcc-linaro"
-COMPATIBLE_MACHINE = "(radxarock)"
-KBUILD_DEFCONFIG = "radxa_rock_linux_defconfig"
-# kernel 3.0.x does not have devicetree
-KERNEL_DEVICETREE = ""
-
-# This kernel only builds and works with the gcc-4.x toolchain. As, we only want
-# to use this toolchain for this recipe, we overwrite CROSS_COMPILE, CC, LD and
-# AR.
-export CROSS_COMPILE = "arm-linux-gnueabi-"
-KERNEL_CC = "${CROSS_COMPILE}gcc"
-KERNEL_LD = "${CROSS_COMPILE}ld.bfd"
-KERNEL_AR = "${CROSS_COMPILE}ar"
-
-deltask kernel_configme
-
-# The rockchip kernel for mach-rk3188 does not support out-of-tree build,
-# mainly because the Makefile includes relative path to the parent directory
-# for most of its dependencies (mach-rk30 and plat-rk). By doing so, it breaks
-# the out-of-tree build. Even by patching the Makefile to use "realpath", it is
-# very difficult to have a successful build (we get strange link errors). So we
-# create symlinks, to put dependencies into the same directory.
-do_configure_append() {
- MODULES="ddr.c ddr_reg_resume.inc pmu.c reset.c pm.c common.c devices.c \
- platsmp.c headsmp.S hotplug.c cpuidle.c"
- for m in ${MODULES}; do
- ln -sf ${S}/arch/arm/mach-rk30/${m} ${S}/arch/arm/mach-rk3188/${m}
- done
- ln -sf ${S}/arch/arm/plat-rk/clock.c ${S}/arch/arm/mach-rk3188/clock.c
-}
-
-do_install_prepend() {
- install -d ${D}/lib/firmware
-}