aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/u-boot/0001-configs-tinker-rk3288-disable-CONFIG_SPL_I2C_SUPPORT.patch35
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend4
2 files changed, 39 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot/0001-configs-tinker-rk3288-disable-CONFIG_SPL_I2C_SUPPORT.patch b/recipes-bsp/u-boot/u-boot/0001-configs-tinker-rk3288-disable-CONFIG_SPL_I2C_SUPPORT.patch
new file mode 100644
index 0000000..9b40b5f
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/0001-configs-tinker-rk3288-disable-CONFIG_SPL_I2C_SUPPORT.patch
@@ -0,0 +1,35 @@
+From f58f46f1db638aaf9b6edd14a500759677a6fa00 Mon Sep 17 00:00:00 2001
+From: Heinrich Schuchardt <xypron.glpk@gmx.de>
+Date: Wed, 27 Feb 2019 20:05:43 +0100
+Subject: [PATCH] configs: tinker-rk3288 disable CONFIG_SPL_I2C_SUPPORT
+
+The SPL for the Tinker Board has to fit into 32 KiB. Currently this limit
+is exceeded.
+
+CONFIG_SPL_I2C_SUPPORT is not needed to move to main U-Boot. So let's
+disable it.
+
+Suggested-by: David Wu <david.wu@rock-chips.com>
+Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
+Reviewed-by: David Wu <david.wu@rock-chips.com>
+Reviewed-by: Philipp Tomsich <philipp.tomsich@theobroma-systems.com>
+---
+Upstream-status: Submitted [u-boot]
+- the original developer of this patch sent it to the u-boot mailing list
+- https://patchwork.ozlabs.org/patch/1049112/
+
+ configs/tinker-rk3288_defconfig | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/configs/tinker-rk3288_defconfig b/configs/tinker-rk3288_defconfig
+index 85ef9dabbd..f84189d05c 100644
+--- a/configs/tinker-rk3288_defconfig
++++ b/configs/tinker-rk3288_defconfig
+@@ -18,7 +18,6 @@ CONFIG_DEFAULT_FDT_FILE="rk3288-tinker.dtb"
+ CONFIG_DISPLAY_BOARDINFO_LATE=y
+ CONFIG_SPL_STACK_R=y
+ CONFIG_SPL_STACK_R_MALLOC_SIMPLE_LEN=0x2000
+-CONFIG_SPL_I2C_SUPPORT=y
+ CONFIG_CMD_GPIO=y
+ CONFIG_CMD_GPT=y
+ CONFIG_CMD_I2C=y
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
index fa0a681..2e6a9e7 100644
--- a/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -1,3 +1,7 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI_append_tinker-rk3288 = " file://0001-configs-tinker-rk3288-disable-CONFIG_SPL_I2C_SUPPORT.patch"
+
do_compile_append_rk3288 () {
# copy to default search path
if [ ${SPL_BINARY} ]; then