aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-support/mkbootimg/mkbootimg-native_git.bb24
-rw-r--r--recipes-support/rkflashtool/rkflashtool-native_git.bb28
2 files changed, 0 insertions, 52 deletions
diff --git a/recipes-support/mkbootimg/mkbootimg-native_git.bb b/recipes-support/mkbootimg/mkbootimg-native_git.bb
deleted file mode 100644
index 3d3ea39..0000000
--- a/recipes-support/mkbootimg/mkbootimg-native_git.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright (C) 2014 Romain Perier <romain.perier@gmail.com>
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-DESCRIPTION = "Tools to create firmware / boot images for Rockchip devices"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://mkbootimg.c;beginline=3;endline=15;md5=b18126d1bbc60ae5dbc31ef949a6f1c3"
-
-DEPENDS += "openssl-native"
-SRC_URI="git://github.com/neo-technologies/rockchip-mkbootimg.git"
-SRCREV = "dcfdea23d8a223ec68f09789ebf38fc8b832e5d6"
-PR = "r1"
-PV = "0.1+git${SRCREV}"
-
-inherit base native
-
-S = "${WORKDIR}/git"
-
-do_compile() {
- oe_runmake LDFLAGS="$LDFLAGS -lcrypto"
-}
-
-do_install() {
- oe_runmake PREFIX=${prefix} DESTDIR=${D} install
-}
diff --git a/recipes-support/rkflashtool/rkflashtool-native_git.bb b/recipes-support/rkflashtool/rkflashtool-native_git.bb
deleted file mode 100644
index fc3e68f..0000000
--- a/recipes-support/rkflashtool/rkflashtool-native_git.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright (C) 2014 Romain Perier <romain.perier@gmail.com>
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-DESCRIPTION = "Tools for flashing Rockchip devices"
-LICENSE = "ASIS"
-LIC_FILES_CHKSUM = "file://rkcrc.c;beginline=1;endline=25;md5=5c55527c991502a9b86b768674cdcff5"
-
-DEPENDS += "libusb-native"
-SRC_URI="git://github.com/linux-rockchip/rkflashtool.git"
-SRCREV = "${AUTOREV}"
-PR = "r1"
-PV = "0.1+git${SRCREV}"
-
-inherit native
-
-S = "${WORKDIR}/git"
-
-do_compile() {
- oe_runmake
-}
-
-do_install() {
- install -d ${D}/${prefix}/bin
-
- for tool in rkcrc rkflashtool rkmisc rkpad rkparameters rkunpack rkunsign; do
- install -m 0755 ${S}/${tool} ${D}/${prefix}/bin/${tool}
- done
-}