aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/u-boot-rockchip.inc27
-rw-r--r--recipes-bsp/u-boot/u-boot-rockchip/binutils-2.28-ld-fix.patch13
-rw-r--r--recipes-bsp/u-boot/u-boot-rockchip_20171218.bb13
3 files changed, 0 insertions, 53 deletions
diff --git a/recipes-bsp/u-boot/u-boot-rockchip.inc b/recipes-bsp/u-boot/u-boot-rockchip.inc
deleted file mode 100644
index 5d89cd6..0000000
--- a/recipes-bsp/u-boot/u-boot-rockchip.inc
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright (C) 2017 Fuzhou Rockchip Electronics Co., Ltd
-# Copyright (C) 2017 Trevor Woerner <twoerner@gmail.com>
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-require recipes-bsp/u-boot/u-boot.inc
-
-DESCRIPTION = "Rockchip next-dev U-Boot"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
-COMPATIBLE_MACHINE = "(rk3036|rk3066|rk3188|rk3288|rk3328|rk3399)"
-
-DEPENDS = "dtc-native bc-native swig-native"
-
-# u-boot will build native python module
-inherit pythonnative
-
-do_compile_prepend () {
- export STAGING_INCDIR=${STAGING_INCDIR_NATIVE};
- export STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE};
-}
-
-do_compile_append () {
- # copy to default search path
- if [ ${SPL_BINARY} ]; then
- cp ${B}/spl/${SPL_BINARY} ${B}/
- fi
-}
diff --git a/recipes-bsp/u-boot/u-boot-rockchip/binutils-2.28-ld-fix.patch b/recipes-bsp/u-boot/u-boot-rockchip/binutils-2.28-ld-fix.patch
deleted file mode 100644
index b3f6795..0000000
--- a/recipes-bsp/u-boot/u-boot-rockchip/binutils-2.28-ld-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: git/arch/arm/config.mk
-===================================================================
---- git.orig/arch/arm/config.mk
-+++ git/arch/arm/config.mk
-@@ -89,7 +89,7 @@ PLATFORM_LIBS := arch/arm/lib/eabi_compa
- endif
-
- # needed for relocation
--LDFLAGS_u-boot += -pie
-+LDFLAGS_u-boot += -N -pie
-
- #
- # FIXME: binutils versions < 2.22 have a bug in the assembler where
diff --git a/recipes-bsp/u-boot/u-boot-rockchip_20171218.bb b/recipes-bsp/u-boot/u-boot-rockchip_20171218.bb
deleted file mode 100644
index 4545f13..0000000
--- a/recipes-bsp/u-boot/u-boot-rockchip_20171218.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-# Copyright (C) 2017 Fuzhou Rockchip Electronics Co., Ltd
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-include u-boot-rockchip.inc
-
-TAG = "release-${PV}"
-SRC_URI = " \
- git://github.com/rockchip-linux/u-boot.git;tag=${TAG};nobranch=1; \
- file://binutils-2.28-ld-fix.patch \
-"
-S = "${WORKDIR}/git"