aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/omxplayer/omxplayer/use-native-pkg-config.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/omxplayer/omxplayer/use-native-pkg-config.patch')
-rw-r--r--recipes-multimedia/omxplayer/omxplayer/use-native-pkg-config.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-multimedia/omxplayer/omxplayer/use-native-pkg-config.patch b/recipes-multimedia/omxplayer/omxplayer/use-native-pkg-config.patch
new file mode 100644
index 0000000..ed81999
--- /dev/null
+++ b/recipes-multimedia/omxplayer/omxplayer/use-native-pkg-config.patch
@@ -0,0 +1,19 @@
+Force the pkg-config native tool. Strangely ffmpeg prepends cross_prefix
+to the default value which obviously is wrong.
+
+Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
+
+Index: git/Makefile.ffmpeg
+===================================================================
+--- git.orig/Makefile.ffmpeg
++++ git/Makefile.ffmpeg
+@@ -245,7 +245,8 @@ configure:
+ --disable-decoder=idf \
+ --enable-decoder=opus \
+ --cross-prefix=$(HOST)- \
+- --disable-stripping
++ --disable-stripping \
++ --pkg-config=pkg-config
+
+ .PHONY : clean
+ clean: