aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/bcm2835/bcm2835_1.52.bb42
-rw-r--r--recipes-devtools/bcm2835/bcm2835_1.73.bb49
-rw-r--r--recipes-devtools/pi-blaster/pi-blaster_git.bb10
-rw-r--r--recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.10.bb14
-rw-r--r--recipes-devtools/python/python3-adafruit-platformdetect_3.27.0.bb14
-rw-r--r--recipes-devtools/python/python3-adafruit-pureio_1.1.9.bb19
-rw-r--r--recipes-devtools/python/python3-rtimu/0001-setup.py-Port-to-use-setuptools.patch29
-rw-r--r--recipes-devtools/python/python3-rtimu_7.2.1.bb (renamed from recipes-devtools/python/python3-rtimu_git.bb)6
-rw-r--r--recipes-devtools/python/python3-sense-hat_2.2.0.bb24
-rw-r--r--recipes-devtools/python/rpi-gpio/0001-Remove-nested-functions.patch33
-rw-r--r--recipes-devtools/python/rpi-gpio_0.6.3.bb14
-rw-r--r--recipes-devtools/python/rpi-gpio_0.7.1.bb15
-rw-r--r--recipes-devtools/python/rpio/0001-include-sys-types.h-explicitly-for-getting-caddr_t-d.patch30
-rw-r--r--recipes-devtools/python/rpio_0.10.1.bb (renamed from recipes-devtools/python/rpio_0.10.0.bb)21
-rw-r--r--recipes-devtools/raspi-gpio/raspi-gpio_git.bb2
15 files changed, 162 insertions, 160 deletions
diff --git a/recipes-devtools/bcm2835/bcm2835_1.52.bb b/recipes-devtools/bcm2835/bcm2835_1.52.bb
deleted file mode 100644
index eef6afd..0000000
--- a/recipes-devtools/bcm2835/bcm2835_1.52.bb
+++ /dev/null
@@ -1,42 +0,0 @@
-DESCRIPTION = "Package that provides access to GPIO and other IO\
-functions on the Broadcom BCM 2835 chip, allowing access to the\
-GPIO pins on the 26 pin IDE plug on the RPi board"
-SECTION = "base"
-HOMEPAGE = "http://www.open.com.au/mikem/bcm2835"
-AUTHOR = "Mike McCauley (mikem@open.com.au)"
-
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-
-COMPATIBLE_MACHINE = "^rpi$"
-
-SRC_URI = "http://www.airspayce.com/mikem/bcm2835/bcm2835-${PV}.tar.gz"
-
-SRC_URI[md5sum] = "b5dc426b4ff258bb1397442f98e40236"
-SRC_URI[sha256sum] = "b9fd10f7a80aadaed28a77168709b7c519568a63b6e98d0a50e9c5fe31bea6bb"
-
-inherit autotools
-
-do_compile_append() {
- # Now compiling the examples provided by the package
- mkdir -p ${B}/examples
- for file in `ls ${S}/examples`; do
- ${CC} ${LDFLAGS} ${S}/examples/${file}/${file}.c -o ${B}/examples/${file} -Bstatic -L${B}/src -lbcm2835 -I${S}/src
- done
-}
-
-do_install_append() {
- install -d ${D}/${libdir}/${BPN}
- for file in ${B}/examples/*
- do
- install -m 0755 ${file} ${D}/${libdir}/${BPN}
- done
-}
-
-PACKAGES += "${PN}-tests"
-
-RDEPENDS_${PN}-dev = ""
-
-FILES_${PN} = ""
-FILES_${PN}-tests = "${libdir}/${BPN}"
-FILES_${PN}-dbg += "${libdir}/${BPN}/.debug"
diff --git a/recipes-devtools/bcm2835/bcm2835_1.73.bb b/recipes-devtools/bcm2835/bcm2835_1.73.bb
new file mode 100644
index 0000000..cdf2332
--- /dev/null
+++ b/recipes-devtools/bcm2835/bcm2835_1.73.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "Package that provides access to GPIO and other IO\
+functions on the Broadcom BCM 2835 chip, allowing access to the\
+GPIO pins on the 26 pin IDE plug on the RPi board"
+SECTION = "base"
+HOMEPAGE = "http://www.open.com.au/mikem/bcm2835"
+AUTHOR = "Mike McCauley (mikem@open.com.au)"
+
+LICENSE = "GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e49f4652534af377a713df3d9dec60cb"
+
+COMPATIBLE_MACHINE = "^rpi$"
+
+SRC_URI = "http://www.airspayce.com/mikem/bcm2835/bcm2835-${PV}.tar.gz"
+
+SRC_URI[sha256sum] = "e67a986462618988a5a86752e36e3ebdd7c5cae66940ff7330aea243b2762525"
+
+inherit autotools
+
+do_compile:append() {
+ # Now compiling the examples provided by the package
+ mkdir -p ${B}/examples/spiram
+ for file in `ls ${S}/examples`; do
+ example="$file"
+ if [ "$file" = "spiram" ]; then
+ # This includes a tiny library
+ EXAMPLE_LDFLAGS="-L${B}/examples/spiram -lspiram"
+ example="spiram_test"
+ ${CC} ${CFLAGS} -c ${S}/examples/spiram/spiram.c -o ${B}/examples/spiram/libspiram.o -I${S}/src -I${S}/examples/spiram
+ rm -f ${B}/examples/spiram/libspiram.a && ${BUILD_AR} crD ${B}/examples/spiram/libspiram.a ${B}/examples/spiram/libspiram.o
+ fi
+ ${CC} ${LDFLAGS} ${S}/examples/${file}/${example}.c -o ${B}/examples/${example} -Bstatic -L${B}/src -lbcm2835 ${EXAMPLE_LDFLAGS} -I${S}/src
+ done
+}
+
+do_install:append() {
+ install -d ${D}/${libdir}/${BPN}
+ for example in $(find ${B}/examples -type f -maxdepth 1)
+ do
+ install -m 0755 ${example} ${D}/${libdir}/${BPN}
+ done
+}
+
+PACKAGES += "${PN}-tests"
+
+RDEPENDS:${PN}-dev = ""
+
+FILES:${PN} = ""
+FILES:${PN}-tests = "${libdir}/${BPN}"
+FILES:${PN}-dbg += "${libdir}/${BPN}/.debug"
diff --git a/recipes-devtools/pi-blaster/pi-blaster_git.bb b/recipes-devtools/pi-blaster/pi-blaster_git.bb
index fdaf16c..d02fa92 100644
--- a/recipes-devtools/pi-blaster/pi-blaster_git.bb
+++ b/recipes-devtools/pi-blaster/pi-blaster_git.bb
@@ -2,21 +2,21 @@ DESCRIPTION = "This project enables PWM on the GPIO pins you request of a Raspbe
HOMEPAGE = "https://github.com/sarfata/pi-blaster/"
SECTION = "devel/libs"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://README.md;beginline=268;endline=292;md5=86d10e4bcf4b4014d306dde7c1d2a80d"
+LIC_FILES_CHKSUM = "file://README.md;beginline=295;endline=319;md5=86d10e4bcf4b4014d306dde7c1d2a80d"
-SRC_URI = "git://github.com/sarfata/pi-blaster \
+SRC_URI = "git://github.com/sarfata/pi-blaster;branch=master;protocol=https \
file://remove-initscript-lsb-dependency.patch \
"
S = "${WORKDIR}/git"
-SRCREV = "befd8ef36e5066e4d444ef47fe4020787e541248"
+SRCREV = "fbba9a7dcef0f352a11f8a2a5f6cbc15b62c0829"
inherit update-rc.d autotools
INITSCRIPT_PACKAGES = "${PN}"
-INITSCRIPT_NAME_${PN} = "${PN}.boot.sh"
-INITSCRIPT_PARAMS_${PN} = "defaults 15 85"
+INITSCRIPT_NAME:${PN} = "${PN}.boot.sh"
+INITSCRIPT_PARAMS:${PN} = "defaults 15 85"
COMPATIBLE_MACHINE = "^rpi$"
diff --git a/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.10.bb b/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.10.bb
new file mode 100644
index 0000000..8ff3073
--- /dev/null
+++ b/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.10.bb
@@ -0,0 +1,14 @@
+SUMMARY = "CircuitPython data descriptor classes to represent hardware registers on I2C and SPI devices."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_Register"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6ec69d6e9e6c85adfb7799d7f8cf044e"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_Register.git;branch=main;protocol=https"
+SRCREV = "d1e8ac7ad9dcd65ab83749db3e5c96ffee80ebb7"
+S = "${WORKDIR}/git"
+
+DEPENDS += "python3-setuptools-scm-native"
+
+inherit setuptools3
+
+RDEPENDS:${PN} += "python3-core"
diff --git a/recipes-devtools/python/python3-adafruit-platformdetect_3.27.0.bb b/recipes-devtools/python/python3-adafruit-platformdetect_3.27.0.bb
new file mode 100644
index 0000000..45dc49d
--- /dev/null
+++ b/recipes-devtools/python/python3-adafruit-platformdetect_3.27.0.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Platform detection for use by libraries like Adafruit-Blinka."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_Python_PlatformDetect"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fccd531dce4b989c05173925f0bbb76c"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_Python_PlatformDetect.git;branch=main;protocol=https"
+SRCREV = "e1460098eeca5ea573f92814691bb378e15530d9"
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS:${PN} += "python3-core"
diff --git a/recipes-devtools/python/python3-adafruit-pureio_1.1.9.bb b/recipes-devtools/python/python3-adafruit-pureio_1.1.9.bb
new file mode 100644
index 0000000..cdbe4b4
--- /dev/null
+++ b/recipes-devtools/python/python3-adafruit-pureio_1.1.9.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Pure python (i.e. no native extensions) access to Linux IO including I2C and SPI. Drop in replacement for smbus and spidev modules."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_Python_PureIO"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2a21fcca821a506d4c36f7bbecc0d009"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_Python_PureIO.git;branch=main;protocol=https"
+SRCREV = "383b615ce9ff5bbefdf77652799f380016fda353"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS:${PN} += " \
+ python3-core \
+ python3-ctypes \
+ python3-fcntl \
+"
diff --git a/recipes-devtools/python/python3-rtimu/0001-setup.py-Port-to-use-setuptools.patch b/recipes-devtools/python/python3-rtimu/0001-setup.py-Port-to-use-setuptools.patch
new file mode 100644
index 0000000..77eca99
--- /dev/null
+++ b/recipes-devtools/python/python3-rtimu/0001-setup.py-Port-to-use-setuptools.patch
@@ -0,0 +1,29 @@
+From f5ab30abd37ee884fb3ccaad0a8d21108ca2c812 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 28 Feb 2022 21:37:19 -0800
+Subject: [PATCH] setup.py: Port to use setuptools
+
+Needed to get it going with wheel, distutils is deprecated for long
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Linux/python/setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Linux/python/setup.py b/Linux/python/setup.py
+index e429e6f..da96843 100644
+--- a/Linux/python/setup.py
++++ b/Linux/python/setup.py
+@@ -22,7 +22,7 @@
+ #// OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ #// SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+-from distutils.core import setup, Extension
++from setuptools import setup, Extension
+ import os.path
+
+ RTIMU_sources = [
+--
+2.35.1
+
diff --git a/recipes-devtools/python/python3-rtimu_git.bb b/recipes-devtools/python/python3-rtimu_7.2.1.bb
index c0cb311..1afbb5f 100644
--- a/recipes-devtools/python/python3-rtimu_git.bb
+++ b/recipes-devtools/python/python3-rtimu_7.2.1.bb
@@ -5,11 +5,11 @@ SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://../../LICENSE;md5=96cdecb41125f498958e09b72faf318e"
-SRC_URI = "git://github.com/RPi-Distro/RTIMULib.git;protocol=http;branch=master \
+SRC_URI = "git://github.com/RPi-Distro/RTIMULib.git;protocol=http;branch=master;protocol=https \
file://0001-include-asm-ioctl.h-for-ioctl-define.patch;patchdir=../.. \
+ file://0001-setup.py-Port-to-use-setuptools.patch;patchdir=../.. \
"
SRCREV = "b949681af69b45f0f7f4bb53b6770037b5b02178"
-S = "${WORKDIR}/git/Linux/python/"
-
+S = "${WORKDIR}/git/Linux/python"
inherit setuptools3
diff --git a/recipes-devtools/python/python3-sense-hat_2.2.0.bb b/recipes-devtools/python/python3-sense-hat_2.2.0.bb
deleted file mode 100644
index 5ea0014..0000000
--- a/recipes-devtools/python/python3-sense-hat_2.2.0.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-SUMMARY = "Python module to control the Raspberry Pi Sense HAT used in the Astro Pi mission"
-HOMEPAGE = "https://github.com/RPi-Distro/python-sense-hat"
-SECTION = "devel/python"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=d80fe312e1ff5fbd97369b093bf21cda"
-
-inherit setuptools3 pypi
-
-PYPI_PACKAGE = "sense-hat"
-
-SRC_URI[md5sum] = "69929250cb72349a8a82edf2584b1d83"
-SRC_URI[sha256sum] = "f000998d042d96ed722d459312e1bebd0107f9f3015cd34b3e4fabcab9c800af"
-
-DEPENDS += " \
- jpeg \
- zlib \
- freetype \
- "
-
-RDEPENDS_${PN} += " \
- ${PYTHON_PN}-numpy \
- ${PYTHON_PN}-rtimu \
- ${PYTHON_PN}-imaging \
- "
diff --git a/recipes-devtools/python/rpi-gpio/0001-Remove-nested-functions.patch b/recipes-devtools/python/rpi-gpio/0001-Remove-nested-functions.patch
index bd97179..5c94bc2 100644
--- a/recipes-devtools/python/rpi-gpio/0001-Remove-nested-functions.patch
+++ b/recipes-devtools/python/rpi-gpio/0001-Remove-nested-functions.patch
@@ -30,6 +30,8 @@ silence this warning
uint32_t peri_base;
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+[Pierre-Jean: update for version 0.7.0]
+Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io>
---
Upstream-Status: Submitted
@@ -37,37 +39,6 @@ Upstream-Status: Submitted
source/py_gpio.c | 135 ++++++++++++++++++++++++++++---------------------------
2 files changed, 71 insertions(+), 70 deletions(-)
-diff --git a/source/c_gpio.c b/source/c_gpio.c
-index c96a2b0..b69880f 100644
---- a/source/c_gpio.c
-+++ b/source/c_gpio.c
-@@ -61,7 +61,7 @@ int setup(void)
- {
- int mem_fd;
- uint8_t *gpio_mem;
-- uint32_t peri_base;
-+ uint32_t peri_base = 0;
- uint32_t gpio_base;
- unsigned char buf[4];
- FILE *fp;
-@@ -73,7 +73,7 @@ int setup(void)
- if ((mem_fd = open("/dev/gpiomem", O_RDWR|O_SYNC)) > 0)
- {
- gpio_map = (uint32_t *)mmap(NULL, BLOCK_SIZE, PROT_READ|PROT_WRITE, MAP_SHARED, mem_fd, 0);
-- if ((uint32_t)gpio_map < 0) {
-+ if (gpio_map == MAP_FAILED) {
- return SETUP_MMAP_FAIL;
- } else {
- return SETUP_OK;
-@@ -127,7 +127,7 @@ int setup(void)
-
- gpio_map = (uint32_t *)mmap( (void *)gpio_mem, BLOCK_SIZE, PROT_READ|PROT_WRITE, MAP_SHARED|MAP_FIXED, mem_fd, gpio_base);
-
-- if ((uint32_t)gpio_map < 0)
-+ if (gpio_map == MAP_FAILED)
- return SETUP_MMAP_FAIL;
-
- return SETUP_OK;
diff --git a/source/py_gpio.c b/source/py_gpio.c
index d54cc7f..007bad5 100644
--- a/source/py_gpio.c
diff --git a/recipes-devtools/python/rpi-gpio_0.6.3.bb b/recipes-devtools/python/rpi-gpio_0.6.3.bb
deleted file mode 100644
index d0ff00a..0000000
--- a/recipes-devtools/python/rpi-gpio_0.6.3.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-DESCRIPTION = "A module to control Raspberry Pi GPIO channels"
-HOMEPAGE = "http://code.google.com/p/raspberry-gpio-python/"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=9b95630a648966b142f1a0dcea001cb7"
-
-PYPI_PACKAGE = "RPi.GPIO"
-inherit pypi distutils
-
-SRC_URI += "file://0001-Remove-nested-functions.patch"
-SRC_URI[md5sum] = "e4abe1cfb5eacebe53078032256eb837"
-SRC_URI[sha256sum] = "a5fc0eb5e401963b6c0a03650da6b42c4005f02d962b81241d96c98d0a578516"
-
-COMPATIBLE_MACHINE = "^rpi$"
diff --git a/recipes-devtools/python/rpi-gpio_0.7.1.bb b/recipes-devtools/python/rpi-gpio_0.7.1.bb
new file mode 100644
index 0000000..e7a9950
--- /dev/null
+++ b/recipes-devtools/python/rpi-gpio_0.7.1.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "A module to control Raspberry Pi GPIO channels"
+HOMEPAGE = "https://sourceforge.net/projects/raspberry-gpio-python/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=a2294b0b1daabc30dfb5b3de73b2e00a"
+
+PYPI_PACKAGE = "RPi.GPIO"
+
+inherit pypi setuptools3
+
+SRC_URI += "file://0001-Remove-nested-functions.patch \
+ "
+SRC_URI[sha256sum] = "cd61c4b03c37b62bba4a5acfea9862749c33c618e0295e7e90aa4713fb373b70"
+
+COMPATIBLE_MACHINE = "^rpi$"
diff --git a/recipes-devtools/python/rpio/0001-include-sys-types.h-explicitly-for-getting-caddr_t-d.patch b/recipes-devtools/python/rpio/0001-include-sys-types.h-explicitly-for-getting-caddr_t-d.patch
deleted file mode 100644
index bed9749..0000000
--- a/recipes-devtools/python/rpio/0001-include-sys-types.h-explicitly-for-getting-caddr_t-d.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From c86bfacc98d58244f532626954ed00d84ecfa82d Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sat, 30 Jan 2016 17:12:37 -0800
-Subject: [PATCH] include sys/types.h explicitly for getting caddr_t definition
-
-Helps fixing build on musl where sys/types.h is not included indirectly
-as happening on glibc
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
-Upstream-Status: Submitted
-
- source/c_gpio/c_gpio.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/source/c_gpio/c_gpio.c b/source/c_gpio/c_gpio.c
-index 25a04ca..70df632 100644
---- a/source/c_gpio/c_gpio.c
-+++ b/source/c_gpio/c_gpio.c
-@@ -29,6 +29,7 @@
- #include <stdint.h>
- #include <stdlib.h>
- #include <fcntl.h>
-+#include <sys/types.h>
- #include <sys/mman.h>
- #include "c_gpio.h"
-
---
-2.7.0
-
diff --git a/recipes-devtools/python/rpio_0.10.0.bb b/recipes-devtools/python/rpio_0.10.1.bb
index c3254bc..176646d 100644
--- a/recipes-devtools/python/rpio_0.10.0.bb
+++ b/recipes-devtools/python/rpio_0.10.1.bb
@@ -2,21 +2,22 @@ DESCRIPTION = "Advanced GPIO for the Raspberry Pi. Extends RPi.GPIO with PWM, \
GPIO interrups, TCP socket interrupts, command line tools and more"
HOMEPAGE = "https://github.com/metachris/RPIO"
SECTION = "devel/python"
-LICENSE = "LGPLv3+"
-LIC_FILES_CHKSUM = "file://README.rst;beginline=41;endline=53;md5=d5d95d7486a4d98c999675c23196b25a"
+LICENSE = "LGPL-3.0-or-later"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=bb3ca60759f3202f1ae42e3519cd06bc"
-PYPI_PACKAGE = "RPIO"
-inherit pypi
+SRC_URI = "\
+ git://github.com/metachris/RPIO.git;protocol=https;branch=master \
+ "
+SRCREV = "be1942a69b2592ddacd9dc833d2668a19aafd8d2"
+S = "${WORKDIR}/git"
-SRC_URI += "file://0001-include-sys-types.h-explicitly-for-getting-caddr_t-d.patch"
-
-inherit setuptools
+inherit setuptools3
COMPATIBLE_MACHINE = "^rpi$"
-RDEPENDS_${PN} = "\
- python-logging \
- python-threading \
+RDEPENDS:${PN} = "\
+ python3-logging \
+ python3-threading \
"
SRC_URI[md5sum] = "cefc45422833dcafcd59b78dffc540f4"
diff --git a/recipes-devtools/raspi-gpio/raspi-gpio_git.bb b/recipes-devtools/raspi-gpio/raspi-gpio_git.bb
index c2d7f59..8ea4be1 100644
--- a/recipes-devtools/raspi-gpio/raspi-gpio_git.bb
+++ b/recipes-devtools/raspi-gpio/raspi-gpio_git.bb
@@ -8,7 +8,7 @@ COMPATIBLE_MACHINE = "^rpi$"
inherit autotools
-SRCREV = "2eaa8b8755a550e34d07c898b90b0d9b3d66fd81"
+SRCREV = "22b44e4765b4b78dc5b22394fff484e353d5914d"
SRC_URI = "git://github.com/RPi-Distro/raspi-gpio.git;protocol=https;branch=master \
"