aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-sense-hat_2.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-sense-hat_2.1.0.bb')
-rw-r--r--recipes-devtools/python/python-sense-hat_2.1.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-sense-hat_2.1.0.bb b/recipes-devtools/python/python-sense-hat_2.1.0.bb
new file mode 100644
index 0000000..e990a28
--- /dev/null
+++ b/recipes-devtools/python/python-sense-hat_2.1.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Python module to control the Raspberry Pi Sense HAT used in the Astro Pi mission"
+HOMEPAGE = "https://github.com/RPi-Distro/python-sense-hat"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=d80fe312e1ff5fbd97369b093bf21cda"
+
+SRCNAME = "sense-hat"
+
+SRC_URI = "https://pypi.python.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "71217f15ea963040f06e2f50722186ca"
+SRC_URI[sha256sum] = "c6c76707c0ea514e4b0f1f96f1b5b79755875891aae037df7434b6aad7b9dbca"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+DEPENDS += " \
+ jpeg \
+ zlib \
+ freetype \
+ "
+
+RDEPENDS_${PN} += " \
+ python-numpy \
+ python-rtimu \
+ python-imaging \
+ "