aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/bootfiles/rpi-config_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/bootfiles/rpi-config_git.bb')
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb
index 45b9f1d..aa11b25 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -66,6 +66,12 @@ do_deploy() {
echo "# Enable offline compositing" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
echo "dispmanx_offline=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
fi
+
+ # SPI bus support
+ if [ -n "${ENABLE_SPI_BUS}" ]; then
+ echo "# Enable SPI bus" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtparam=spi=on" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
}
addtask deploy before do_package after do_install