aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-multimedia/omxplayer/omxplayer/0001-Remove-Makefile.include-which-includes-hardcoded.patch84
-rw-r--r--recipes-multimedia/omxplayer/omxplayer/0002-Libraries-and-headers-from-ffmpeg-are-installed-in-u.patch49
-rw-r--r--recipes-multimedia/omxplayer/omxplayer/0003-Remove-strip-step-in-Makefile.patch (renamed from recipes-multimedia/omxplayer/omxplayer/don-t-strip-while-installing.patch)23
-rw-r--r--recipes-multimedia/omxplayer/omxplayer/libraries-are-installed-in-usr-lib.patch37
-rw-r--r--recipes-multimedia/omxplayer/omxplayer/remove-hardcoded-directory-omxplayer-dist.patch32
-rw-r--r--recipes-multimedia/omxplayer/omxplayer_git.bb24
6 files changed, 161 insertions, 88 deletions
diff --git a/recipes-multimedia/omxplayer/omxplayer/0001-Remove-Makefile.include-which-includes-hardcoded.patch b/recipes-multimedia/omxplayer/omxplayer/0001-Remove-Makefile.include-which-includes-hardcoded.patch
new file mode 100644
index 0000000..b68e351
--- /dev/null
+++ b/recipes-multimedia/omxplayer/omxplayer/0001-Remove-Makefile.include-which-includes-hardcoded.patch
@@ -0,0 +1,84 @@
+From a2a28fb7c4e8354cc0f90454e9bd151c16a6bf8b Mon Sep 17 00:00:00 2001
+From: Andrei Gherzan <andrei@gherzan.ro>
+Date: Tue, 20 Aug 2013 16:10:51 +0300
+Subject: [PATCH] Remove Makefile.include which includes hardcoded
+
+Remove Makefile.include which includes hardcoded paths and rely on
+variables provided by build system.
+
+Upstream-Status: Inappropriate [embedded specific]
+Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
+---
+ Makefile | 2 --
+ Makefile.ffmpeg | 2 --
+ Makefile.include | 38 --------------------------------------
+ 3 files changed, 42 deletions(-)
+ delete mode 100644 Makefile.include
+
+diff --git a/Makefile b/Makefile
+index 519048a..1faa779 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,5 +1,3 @@
+-include Makefile.include
+-
+ CFLAGS+=-std=c++0x -DSTANDALONE -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -D_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
+
+ LDFLAGS+=-L./ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz -Lffmpeg_compiled/usr/local/lib/
+diff --git a/Makefile.ffmpeg b/Makefile.ffmpeg
+index 6ec94af..4297b1f 100644
+--- a/Makefile.ffmpeg
++++ b/Makefile.ffmpeg
+@@ -1,5 +1,3 @@
+-include Makefile.include
+-
+ CFLAGS=-D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -D_LINUX -fPIC -DPIC -D_REENTRANT -D_HAVE_SBRK -D_LARGEFILE64_SOURCE -DHAVE_CMAKE_CONFIG -DHAVE_VMCS_CONFIG -D_REENTRANT -DUSE_VCHIQ_ARM -DVCHI_BULK_ALIGN=1 -DVCHI_BULK_GRANULARITY=1 -DEGL_SERVER_DISPMANX -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D__VIDEOCORE4__ -DGRAPHICS_X_VG=1 -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DOMX -DOMX_SKIP64BIT
+
+ WORK=$(PWD)
+diff --git a/Makefile.include b/Makefile.include
+deleted file mode 100644
+index 501fd4f..0000000
+--- a/Makefile.include
++++ /dev/null
+@@ -1,38 +0,0 @@
+-USE_BUILDROOT=1
+-FLOAT=hard
+-
+-ifeq ($(USE_BUILDROOT), 1)
+-BUILDROOT :=/opt/xbmc-bcm/buildroot
+-SDKSTAGE :=$(BUILDROOT)/output/staging
+-TARGETFS :=$(BUILDROOT)/output/target
+-TOOLCHAIN :=$(BUILDROOT)/output/host/usr/
+-HOST :=arm-unknown-linux-gnueabi
+-SYSROOT :=$(BUILDROOT)/output/host/usr/arm-unknown-linux-gnueabi/sysroot
+-else
+-BUILDROOT :=/opt/bcm-rootfs
+-SDKSTAGE :=/opt/bcm-rootfs
+-TARGETFS :=/opt/bcm-rootfs
+-TOOLCHAIN :=/usr/local/bcm-gcc
+-HOST :=bcm2708
+-SYSROOT :=$(TOOLCHAIN)/arm-bcm2708-linux-gnueabi/sys-root
+-endif
+-
+-JOBS=7
+-
+-CFLAGS := -isystem$(PREFIX)/include
+-CXXFLAGS := $(CFLAGS)
+-CPPFLAGS := $(CFLAGS)
+-LDFLAGS := -L$(BUILDROOT)/lib
+-LD := $(TOOLCHAIN)/bin/$(HOST)-ld --sysroot=$(SYSROOT)
+-CC := $(TOOLCHAIN)/bin/$(HOST)-gcc --sysroot=$(SYSROOT)
+-CXX := $(TOOLCHAIN)/bin/$(HOST)-g++ --sysroot=$(SYSROOT)
+-OBJDUMP := $(TOOLCHAIN)/bin/$(HOST)-objdump
+-RANLIB := $(TOOLCHAIN)/bin/$(HOST)-ranlib
+-STRIP := $(TOOLCHAIN)/bin/$(HOST)-strip
+-AR := $(TOOLCHAIN)/bin/$(HOST)-ar
+-CXXCP := $(CXX) -E
+-PATH := $(PREFIX)/bin:$(BUILDROOT)/output/host/usr/bin:$(PATH)
+-
+-CFLAGS += -pipe -mfloat-abi=$(FLOAT) -mcpu=arm1176jzf-s -fomit-frame-pointer -mabi=aapcs-linux -mtune=arm1176jzf-s -mfpu=vfp -Wno-psabi -mno-apcs-stack-check -O3 -mstructure-size-boundary=32 -mno-sched-prolog
+-LDFLAGS += -L$(SDKSTAGE)/lib -L$(SDKSTAGE)/usr/lib -L$(SDKSTAGE)/opt/vc/lib/
+-INCLUDES += -isystem$(SDKSTAGE)/usr/include -isystem$(SDKSTAGE)/opt/vc/include -isystem$(SYSROOT)/usr/include -isystem$(SDKSTAGE)/opt/vc/include/interface/vcos/pthreads -isystem$(SDKSTAGE)/usr/include/freetype2
+--
+1.7.9.5
+
diff --git a/recipes-multimedia/omxplayer/omxplayer/0002-Libraries-and-headers-from-ffmpeg-are-installed-in-u.patch b/recipes-multimedia/omxplayer/omxplayer/0002-Libraries-and-headers-from-ffmpeg-are-installed-in-u.patch
new file mode 100644
index 0000000..00a1f29
--- /dev/null
+++ b/recipes-multimedia/omxplayer/omxplayer/0002-Libraries-and-headers-from-ffmpeg-are-installed-in-u.patch
@@ -0,0 +1,49 @@
+From 13b525667a6ab7af2354ffd6208e490349669798 Mon Sep 17 00:00:00 2001
+From: Andrei Gherzan <andrei@gherzan.ro>
+Date: Tue, 20 Aug 2013 16:15:15 +0300
+Subject: [PATCH 2/3] Libraries and headers from ffmpeg are installed in /usr.
+
+Don't search for libraries and headers in /usr/local.
+
+Upstream-Status: Inappropriate [embedded specific]
+Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
+---
+ Makefile | 6 +++---
+ Makefile.ffmpeg | 2 +-
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 1faa779..7b639f1 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ CFLAGS+=-std=c++0x -DSTANDALONE -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -D_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
+
+-LDFLAGS+=-L./ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz -Lffmpeg_compiled/usr/local/lib/
+-INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/
++LDFLAGS+=-L./ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz -Lffmpeg_compiled/usr/lib/
++INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/include/
+
+ DIST ?= omxplayer-dist
+
+@@ -66,5 +66,5 @@ dist: omxplayer.bin
+ cp omxplayer omxplayer.bin $(DIST)/usr/bin
+ cp COPYING $(DIST)/usr/share/doc/
+ cp README.md $(DIST)/usr/share/doc/README
+- cp -a ffmpeg_compiled/usr/local/lib/*.so* $(DIST)/usr/lib/omxplayer/
++ cp -a ffmpeg_compiled/usr/lib/*.so* $(DIST)/usr/lib/omxplayer/
+ tar -czf omxplayer-dist.tar.gz $(DIST)
+diff --git a/Makefile.ffmpeg b/Makefile.ffmpeg
+index 6ec94af..13e6c09 100644
+--- a/Makefile.ffmpeg
++++ b/Makefile.ffmpeg
+@@ -64,5 +64,5 @@ checkout:
+
+ install:
+ cd ffmpeg; make -j9 DESTDIR="$(WORK)/ffmpeg_compiled" install
+- $(HOST)-strip ffmpeg_compiled/usr/local/lib/*.so
++ $(HOST)-strip ffmpeg_compiled/usr/lib/*.so
+
+--
+1.7.9.5
+
diff --git a/recipes-multimedia/omxplayer/omxplayer/don-t-strip-while-installing.patch b/recipes-multimedia/omxplayer/omxplayer/0003-Remove-strip-step-in-Makefile.patch
index 4f12cc0..df15763 100644
--- a/recipes-multimedia/omxplayer/omxplayer/don-t-strip-while-installing.patch
+++ b/recipes-multimedia/omxplayer/omxplayer/0003-Remove-strip-step-in-Makefile.patch
@@ -1,3 +1,8 @@
+From aa424d5bcbf40c69acb13de3cb6c67688f0c9046 Mon Sep 17 00:00:00 2001
+From: Andrei Gherzan <andrei@gherzan.ro>
+Date: Tue, 20 Aug 2013 16:17:06 +0300
+Subject: [PATCH 3/3] Remove strip step in Makefile
+
Build system will strip binaries so remove strip step in Makefile.
Avoid warnings/errors like:
WARNING: File '/usr/lib/omxplayer/libavutil.so.51.56.100' from
@@ -5,12 +10,15 @@ omxplayer was already stripped, this will prevent future debugging!
Upstream-Status: Inappropriate [embedded specific]
Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
+---
+ Makefile.ffmpeg | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
-Index: git/Makefile.ffmpeg
-===================================================================
---- git.orig/Makefile.ffmpeg 2012-08-26 15:38:45.099379852 +0300
-+++ git/Makefile.ffmpeg 2012-08-26 15:46:51.913055176 +0300
-@@ -52,7 +52,8 @@
+diff --git a/Makefile.ffmpeg b/Makefile.ffmpeg
+index 13e6c09..51c9514 100644
+--- a/Makefile.ffmpeg
++++ b/Makefile.ffmpeg
+@@ -53,7 +53,8 @@ configure:
--enable-hardcoded-tables \
--disable-runtime-cpudetect \
--disable-debug \
@@ -20,9 +28,12 @@ Index: git/Makefile.ffmpeg
clean:
@rm -rf ffmpeg
-@@ -63,5 +64,4 @@
+@@ -64,5 +65,4 @@ checkout:
install:
cd ffmpeg; make -j9 DESTDIR="$(WORK)/ffmpeg_compiled" install
- $(HOST)-strip ffmpeg_compiled/usr/lib/*.so
+--
+1.7.9.5
+
diff --git a/recipes-multimedia/omxplayer/omxplayer/libraries-are-installed-in-usr-lib.patch b/recipes-multimedia/omxplayer/omxplayer/libraries-are-installed-in-usr-lib.patch
deleted file mode 100644
index 1126bfb..0000000
--- a/recipes-multimedia/omxplayer/omxplayer/libraries-are-installed-in-usr-lib.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Libraries and headers from ffmpeg are installed in usr/lib.
-
-Upstream-Status: Pending
-Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
-
-Index: git/Makefile.ffmpeg
-===================================================================
---- git.orig/Makefile.ffmpeg 2012-08-26 02:46:40.380518313 +0300
-+++ git/Makefile.ffmpeg 2012-08-26 02:46:40.512511177 +0300
-@@ -63,5 +63,5 @@
-
- install:
- cd ffmpeg; make -j9 DESTDIR="$(WORK)/ffmpeg_compiled" install
-- $(HOST)-strip ffmpeg_compiled/usr/local/lib/*.so
-+ $(HOST)-strip ffmpeg_compiled/usr/lib/*.so
-
-Index: git/Makefile
-===================================================================
---- git.orig/Makefile 2012-08-26 02:52:11.578611542 +0300
-+++ git/Makefile 2012-08-26 02:52:53.952320465 +0300
-@@ -1,7 +1,7 @@
- CFLAGS+=-std=c++0x -DSTANDALONE -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -D_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
-
--LDFLAGS+=-L./ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz -Lffmpeg_compiled/usr/local/lib/
--INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/
-+LDFLAGS+=-L./ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz -Lffmpeg_compiled/usr/lib/
-+INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/include/
-
- SRC=linux/XMemUtils.cpp \
- utils/log.cpp \
-@@ -63,5 +63,5 @@
- cp omxplayer omxplayer.bin omxplayer-dist/usr/usr/bin
- cp COPYING omxplayer-dist/usr/share/doc/
- cp README.md omxplayer-dist/usr/share/doc/README
-- cp -a ffmpeg_compiled/usr/local/lib/*.so* omxplayer-dist/usr/lib/omxplayer/
-+ cp -a ffmpeg_compiled/usr/lib/*.so* omxplayer-dist/usr/lib/omxplayer/
- tar -czf omxplayer-dist.tar.gz omxplayer-dist
diff --git a/recipes-multimedia/omxplayer/omxplayer/remove-hardcoded-directory-omxplayer-dist.patch b/recipes-multimedia/omxplayer/omxplayer/remove-hardcoded-directory-omxplayer-dist.patch
deleted file mode 100644
index 99fbbf8..0000000
--- a/recipes-multimedia/omxplayer/omxplayer/remove-hardcoded-directory-omxplayer-dist.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Modify install rule to use /usr/bin path and not /usr/usr/bin for
-installing omxplayer binary and script.
-As well, add a variable to let the user specify where to install
-the files.
-
-Upstream-Status: Pending
-Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
-
-Index: git/Makefile
-===================================================================
---- git.orig/Makefile 2012-08-26 05:03:31.710678243 +0300
-+++ git/Makefile 2012-08-26 05:03:11.000000000 +0300
-@@ -59,11 +57,11 @@
- make -f Makefile.ffmpeg install
-
- dist: omxplayer.bin
-- mkdir -p omxplayer-dist/usr/lib/omxplayer
-- mkdir -p omxplayer-dist/usr/usr/bin
-- mkdir -p omxplayer-dist/usr/share/doc
-- cp omxplayer omxplayer.bin omxplayer-dist/usr/usr/bin
-- cp COPYING omxplayer-dist/usr/share/doc/
-- cp README.md omxplayer-dist/usr/share/doc/README
-- cp -a ffmpeg_compiled/usr/lib/*.so* omxplayer-dist/usr/lib/omxplayer/
-- tar -czf omxplayer-dist.tar.gz omxplayer-dist
-+ mkdir -p $(DEST)/usr/lib/omxplayer
-+ mkdir -p $(DEST)/usr/bin
-+ mkdir -p $(DEST)/usr/share/doc
-+ cp omxplayer omxplayer.bin $(DEST)/usr/bin
-+ cp COPYING $(DEST)/usr/share/doc/
-+ cp README.md $(DEST)/usr/share/doc/README
-+ cp -a ffmpeg_compiled/usr/lib/*.so* $(DEST)/usr/lib/omxplayer/
-+ tar -czf omxplayer-dist.tar.gz $(DEST)
diff --git a/recipes-multimedia/omxplayer/omxplayer_git.bb b/recipes-multimedia/omxplayer/omxplayer_git.bb
index b637ba6..a456026 100644
--- a/recipes-multimedia/omxplayer/omxplayer_git.bb
+++ b/recipes-multimedia/omxplayer/omxplayer_git.bb
@@ -7,29 +7,26 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
DEPENDS = "libpcre libav virtual/egl boost freetype"
-PR = "r0"
+PR = "r1"
-SRCREV = "231c08b42005e3de565013bc1cee18bd5a349c1f"
+SRCREV = "dae98a8bba9dc7410b0621134f6ebdb406adb1bd"
SRC_URI = "git://github.com/huceke/omxplayer.git;protocol=git;branch=master \
- file://remove-makefile-include.patch \
- file://libraries-are-installed-in-usr-lib.patch \
- file://remove-hardcoded-directory-omxplayer-dist.patch \
- file://don-t-strip-while-installing.patch \
- "
+ file://0001-Remove-Makefile.include-which-includes-hardcoded.patch \
+ file://0002-Libraries-and-headers-from-ffmpeg-are-installed-in-u.patch \
+ file://0003-Remove-strip-step-in-Makefile.patch"
S = "${WORKDIR}/git"
COMPATIBLE_MACHINE = "raspberrypi"
inherit autotools
-# Variable added in Makefile to INCLUDE
-export ADD_INCDIR = "-I${STAGING_INCDIR}/interface/vcos/pthreads -I${STAGING_INCDIR}/freetype2"
+# Needed in ffmpeg configure
+export TEMPDIR = "${S}/tmp"
-# Needed in configure from Makefile.ffmpeg
+# Needed in Makefile.ffmpeg
export HOST = "${HOST_SYS}"
export WORK = "${S}"
-export TEMPDIR = "${S}/tmp"
-export FLOAT = "softfp"
+export FLOAT = "${@bb.utils.contains("TUNE_FEATURES", "callconvention-hard", "hard", "softfp", d)}"
export LDFLAGS = "-L${S}/ffmpeg_compiled/usr/lib \
-L${STAGING_DIR_HOST}/lib \
@@ -39,10 +36,11 @@ export LDFLAGS = "-L${S}/ffmpeg_compiled/usr/lib \
export INCLUDES = "-isystem${STAGING_DIR_HOST}/usr/include \
-isystem${STAGING_DIR_HOST}/usr/include/interface/vcos/pthreads \
-isystem${STAGING_DIR_HOST}/usr/include/freetype2 \
+ -isystem${STAGING_DIR_HOST}/usr/include/interface/vmcs_host/linux \
"
# Install in ${D}
-export DEST = "${D}"
+export DIST = "${D}"
do_compile() {
# Needed for compiler test in ffmpeg's configure