aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb b/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb
new file mode 100644
index 0000000..4454d24
--- /dev/null
+++ b/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Platform detection for use by libraries like Adafruit-Blinka."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_Python_PlatformDetect"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fccd531dce4b989c05173925f0bbb76c"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_Python_PlatformDetect.git"
+SRCREV = "e0fe1b012898fa824944d6805ca74be0fa027968"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS_${PN} += "python3-core"