aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-raspberrypi/sl030raspberrypii2ckernel.patch32
-rw-r--r--recipes-kernel/linux/linux-raspberrypi_3.12.bb3
2 files changed, 1 insertions, 34 deletions
diff --git a/recipes-kernel/linux/linux-raspberrypi/sl030raspberrypii2ckernel.patch b/recipes-kernel/linux/linux-raspberrypi/sl030raspberrypii2ckernel.patch
deleted file mode 100644
index 8534ecb..0000000
--- a/recipes-kernel/linux/linux-raspberrypi/sl030raspberrypii2ckernel.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Fix i2c timing errors.
-
-When Transmitting: Make SDA valid quarter of a cycle after the falling edge of SCL.
-When Receiving: Sample SDA Quarter of a cycle after the rising edge of SCL.
-
-Upstream-Status: Pending
-
-RP 2013/04/21
-
-Index: git/drivers/i2c/busses/i2c-bcm2708.c
-===================================================================
---- git.orig/drivers/i2c/busses/i2c-bcm2708.c 2013-01-06 17:15:00.754954587 +0000
-+++ git/drivers/i2c/busses/i2c-bcm2708.c 2013-01-06 17:50:09.794905741 +0000
-@@ -150,6 +150,7 @@
- unsigned long bus_hz;
- u32 cdiv;
- u32 c = BSC_C_I2CEN | BSC_C_INTD | BSC_C_ST | BSC_C_CLEAR_1;
-+ u32 cdel;
-
- bus_hz = clk_get_rate(bi->clk);
- cdiv = bus_hz / baudrate;
-@@ -163,6 +164,10 @@
- bcm2708_wr(bi, BSC_A, bi->msg->addr);
- bcm2708_wr(bi, BSC_DLEN, bi->msg->len);
- bcm2708_wr(bi, BSC_C, c);
-+
-+ cdel = (cdiv / 4) & 0xffff;
-+ cdel = cdel << 16 | cdel;
-+ bcm2708_wr(bi, BSC_DEL, cdel);
- }
-
- static irqreturn_t bcm2708_i2c_interrupt(int irq, void *dev_id)
diff --git a/recipes-kernel/linux/linux-raspberrypi_3.12.bb b/recipes-kernel/linux/linux-raspberrypi_3.12.bb
index 2952778..71fba49 100644
--- a/recipes-kernel/linux/linux-raspberrypi_3.12.bb
+++ b/recipes-kernel/linux/linux-raspberrypi_3.12.bb
@@ -1,8 +1,7 @@
LINUX_VERSION ?= "3.12.36"
-SRCREV = "90fa5df724d147564149c7b79cb1ffc571a345ec"
+SRCREV = "ee9b8c7d46f2b1787b1e64604acafc70f70191cf"
SRC_URI = "git://github.com/raspberrypi/linux.git;protocol=git;branch=rpi-3.12.y \
- file://sl030raspberrypii2ckernel.patch \
"
require linux-raspberrypi.inc