aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/raspberrypi2.conf5
-rw-r--r--recipes-graphics/userland/userland_git.bb1
2 files changed, 1 insertions, 5 deletions
diff --git a/conf/machine/raspberrypi2.conf b/conf/machine/raspberrypi2.conf
index 778f5a6..30edae3 100644
--- a/conf/machine/raspberrypi2.conf
+++ b/conf/machine/raspberrypi2.conf
@@ -2,11 +2,6 @@
#@NAME: RaspberryPi 2 Development Board
#@DESCRIPTION: Machine configuration for the RaspberryPi 2
-# userland is not compiling on RPI 2
-# https://github.com/raspberrypi/userland/issues/214
-PREFERRED_PROVIDER_virtual/egl ?= "vc-graphics-hardfp"
-PREFERRED_PROVIDER_virtual/libgles2 ?= "vc-graphics-hardfp"
-
DEFAULTTUNE ?= "cortexa7thf-neon-vfpv4"
require conf/machine/include/tune-cortexa7.inc
diff --git a/recipes-graphics/userland/userland_git.bb b/recipes-graphics/userland/userland_git.bb
index 1e60ea8..729c42a 100644
--- a/recipes-graphics/userland/userland_git.bb
+++ b/recipes-graphics/userland/userland_git.bb
@@ -22,6 +22,7 @@ S = "${WORKDIR}/git"
inherit cmake
EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DCMAKE_EXE_LINKER_FLAGS='-Wl,--no-as-needed'"
+CFLAGS_append = " -fPIC"
# The compiled binaries don't provide sonames.
SOLIBS = "${SOLIBSDEV}"