aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-linaro-lt-freedreno_3.4.bb2
-rw-r--r--recipes-kernel/linux/linux-linaro-qcom.inc10
-rw-r--r--recipes-kernel/linux/linux-linaro-qcomlt_4.2.bb1
3 files changed, 9 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-linaro-lt-freedreno_3.4.bb b/recipes-kernel/linux/linux-linaro-lt-freedreno_3.4.bb
index 1e7b2bb..38bcb83 100644
--- a/recipes-kernel/linux/linux-linaro-lt-freedreno_3.4.bb
+++ b/recipes-kernel/linux/linux-linaro-lt-freedreno_3.4.bb
@@ -3,5 +3,7 @@
require recipes-kernel/linux/linux-linaro-qcom.inc
+SRC_URI += "file://defconfig"
+
SRCBRANCH = "freedreno/ifc6410-v2.0-drm"
SRCREV = "602a30a57d9d3807df758221c2224e64a29e6fc7"
diff --git a/recipes-kernel/linux/linux-linaro-qcom.inc b/recipes-kernel/linux/linux-linaro-qcom.inc
index e28c7c2..5eaa9b2 100644
--- a/recipes-kernel/linux/linux-linaro-qcom.inc
+++ b/recipes-kernel/linux/linux-linaro-qcom.inc
@@ -12,9 +12,7 @@ inherit kernel
LOCALVERSION ?= "+yocto"
SCMVERSION ?= "y"
-SRC_URI = "git://git.linaro.org/landing-teams/working/qualcomm/kernel.git;branch=${SRCBRANCH};protocol=https \
- file://defconfig \
-"
+SRC_URI = "git://git.linaro.org/landing-teams/working/qualcomm/kernel.git;branch=${SRCBRANCH};protocol=https"
S = "${WORKDIR}/git"
@@ -35,7 +33,11 @@ do_configure_prepend() {
kernel_conf_variable LOCALVERSION "\"${LOCALVERSION}\""
kernel_conf_variable LOCALVERSION_AUTO y
- sed -e "${CONF_SED_SCRIPT}" < '${WORKDIR}/defconfig' >> '${B}/.config'
+ if [ -f '${WORKDIR}/defconfig' ]; then
+ sed -e "${CONF_SED_SCRIPT}" < '${WORKDIR}/defconfig' >> '${B}/.config'
+ else
+ sed -e "${CONF_SED_SCRIPT}" < '${KERNEL_DEFCONFIG}' >> '${B}/.config'
+ fi
if [ "${SCMVERSION}" = "y" ]; then
# Add GIT revision to the local version
diff --git a/recipes-kernel/linux/linux-linaro-qcomlt_4.2.bb b/recipes-kernel/linux/linux-linaro-qcomlt_4.2.bb
index d2123ff..736daa5 100644
--- a/recipes-kernel/linux/linux-linaro-qcomlt_4.2.bb
+++ b/recipes-kernel/linux/linux-linaro-qcomlt_4.2.bb
@@ -9,6 +9,7 @@ require recipes-kernel/linux/linux-qcom-bootimg.inc
SRCBRANCH = "release/qcomlt-4.2"
SRCREV = "d3a8cef5d9a3eaa2b8e0f9f95e82354a40fac528"
+SRC_URI += "file://defconfig"
COMPATIBLE_MACHINE = "(ifc6410|dragonboard-410c)"