aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-linaro-qcomlt_4.2.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-linaro-qcomlt_4.2.bb b/recipes-kernel/linux/linux-linaro-qcomlt_4.2.bb
index a1debec..13f4445 100644
--- a/recipes-kernel/linux/linux-linaro-qcomlt_4.2.bb
+++ b/recipes-kernel/linux/linux-linaro-qcomlt_4.2.bb
@@ -30,6 +30,9 @@ do_compile_append_ifc6410() {
# append DTB, since bootloader doesn't support DTB
do_compile_append_ifc6410() {
+ if ! [ -e ${B}/arch/${ARCH}/boot/dts/${KERNEL_DEVICETREE} ] ; then
+ oe_runmake ${DTB}
+ fi
cp ${KERNEL_OUTPUT} ${KERNEL_OUTPUT}.backup
cat ${KERNEL_OUTPUT}.backup ${B}/arch/${ARCH}/boot/dts/${KERNEL_DEVICETREE} > ${KERNEL_OUTPUT}
rm -f ${KERNEL_OUTPUT}.backup