aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa/mesa_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/mesa/mesa_%.bbappend')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend32
1 files changed, 6 insertions, 26 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index fd40c39..3f4a6e2 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,30 +1,10 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
-SRC_URI_append = " \
- file://0001-freedreno-clear-last_fence-after-resource-tracking.patch \
-"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
# Enable freedreno driver
-GALLIUMDRIVERS_append_apq8064 = ",freedreno"
-GALLIUMDRIVERS_append_apq8016 = ",freedreno"
-GALLIUMDRIVERS_append_apq8096 = ",freedreno"
-GALLIUMDRIVERS_append_sdm845 = ",freedreno"
-
-PACKAGECONFIG_append_apq8064 = " \
- gallium \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
-"
-
-PACKAGECONFIG_append_apq8016 = " \
- gallium \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
+PACKAGECONFIG_FREEDRENO = "\
+ freedreno \
+ tools \
+ ${@bb.utils.contains('BBFILE_COLLECTIONS', 'openembedded-layer', 'freedreno-fdperf', '', d)} \
"
-PACKAGECONFIG_append_apq8096 = " \
- gallium \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
-"
-
-PACKAGECONFIG_append_sdm845 = " \
- gallium \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
-"
+PACKAGECONFIG:append:qcom = "${PACKAGECONFIG_FREEDRENO}"