aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch')
-rw-r--r--recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch22
1 files changed, 12 insertions, 10 deletions
diff --git a/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch b/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
index 3dd4124..8c0bab0 100644
--- a/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
+++ b/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
@@ -1,6 +1,6 @@
-From dd1d15c75f6ff8ee96cf1e7b74e582bff3183ef6 Mon Sep 17 00:00:00 2001
+From 16012eb00fa76343b35365e96ef24806c65948e1 Mon Sep 17 00:00:00 2001
From: Alistair Francis <alistair@alistair23.me>
-Date: Thu, 14 Nov 2019 13:08:31 -0800
+Date: Wed, 2 Sep 2020 15:28:50 -0500
Subject: [PATCH] meson.build: make TLS ELF optional
USE_ELF_TLS has replaced GLX_USE_TLS so this patch is the original "make
@@ -8,30 +8,29 @@ TLS GLX optional again" patch updated to the latest mesa.
Upstream-Status: Inappropriate [configuration]
Signed-off-by: Alistair Francis <alistair@alistair23.me>
-
---
meson.build | 2 +-
meson_options.txt | 6 ++++++
2 files changed, 7 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
-index 261b588..311436e 100644
+index e3e1dbfb116..791a42a083e 100644
--- a/meson.build
+++ b/meson.build
-@@ -392,7 +392,7 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless or with_plat
- endif
+@@ -428,7 +428,7 @@ endif
# Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
--if not ['windows', 'freebsd'].contains(host_machine.system()) and (not with_platform_android or get_option('platform-sdk-version') >= 29)
+ use_elf_tls = false
+-if not ['windows', 'freebsd', 'openbsd'].contains(host_machine.system()) and (not with_platform_android or get_option('platform-sdk-version') >= 29)
+if (not with_platform_android or get_option('platform-sdk-version') >= 29) and get_option('elf-tls')
pre_args += '-DUSE_ELF_TLS'
+ use_elf_tls = true
endif
-
diff --git a/meson_options.txt b/meson_options.txt
-index ab43150..d7b1555 100644
+index a0cf4abca92..d472772373e 100644
--- a/meson_options.txt
+++ b/meson_options.txt
-@@ -355,6 +355,12 @@ option(
+@@ -368,6 +368,12 @@ option(
value : true,
description : 'Enable direct rendering in GLX and EGL for DRI',
)
@@ -44,3 +43,6 @@ index ab43150..d7b1555 100644
option(
'prefer-iris',
type : 'boolean',
+--
+2.28.0
+