aboutsummaryrefslogtreecommitdiffstats
path: root/openembedded-layer/recipes-support/qmi-gps-proxy/files/fix_makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded-layer/recipes-support/qmi-gps-proxy/files/fix_makefile.patch')
-rw-r--r--openembedded-layer/recipes-support/qmi-gps-proxy/files/fix_makefile.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/openembedded-layer/recipes-support/qmi-gps-proxy/files/fix_makefile.patch b/openembedded-layer/recipes-support/qmi-gps-proxy/files/fix_makefile.patch
new file mode 100644
index 0000000..a0ac51c
--- /dev/null
+++ b/openembedded-layer/recipes-support/qmi-gps-proxy/files/fix_makefile.patch
@@ -0,0 +1,23 @@
+diff --git a/Makefile b/Makefile
+index 2b611a1..0040626 100644
+--- a/Makefile
++++ b/Makefile
+@@ -2,6 +2,7 @@ OUT := gps_proxy
+
+ CFLAGS := -Wall -g -I../qrtr/lib
+ LDFLAGS := -L../qrtr -lqrtr
++prefix := /usr/local
+
+ SRCS := qmi_gps.c qmi_tlv.c gps_proxy.c util.c
+ OBJS := $(SRCS:.c=.o)
+@@ -12,8 +13,8 @@ $(OUT): $(OBJS)
+ #%.c: %.qmi
+ # qmic < $<
+
+-test: $(OUT)
+- ./$(OUT)
++install: $(OUT)
++ install -D -m 755 $< $(DESTDIR)$(prefix)/bin/$<
+
+ clean:
+ rm -f $(OUT) $(OBJS)