aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/skales/skales_git.bb6
-rw-r--r--recipes-kernel/linux/linux-qcom-bootimg.inc4
2 files changed, 5 insertions, 5 deletions
diff --git a/recipes-devtools/skales/skales_git.bb b/recipes-devtools/skales/skales_git.bb
index dfbefb3..71928e8 100644
--- a/recipes-devtools/skales/skales_git.bb
+++ b/recipes-devtools/skales/skales_git.bb
@@ -16,9 +16,9 @@ SRC_URI = "git://codeaurora.org/quic/kernel/skales"
S = "${WORKDIR}/git"
do_install () {
- install -d ${D}${bindir}
- install -m 0755 ${S}/mkbootimg ${D}${bindir}
- install -m 0755 ${S}/dtbTool ${D}${bindir}
+ install -d ${D}${bindir}/skales
+ install -m 0755 ${S}/mkbootimg ${D}${bindir}/skales
+ install -m 0755 ${S}/dtbTool ${D}${bindir}/skales
}
BBCLASSEXTEND = "native"
diff --git a/recipes-kernel/linux/linux-qcom-bootimg.inc b/recipes-kernel/linux/linux-qcom-bootimg.inc
index 6c9b41f..ab1065b 100644
--- a/recipes-kernel/linux/linux-qcom-bootimg.inc
+++ b/recipes-kernel/linux/linux-qcom-bootimg.inc
@@ -13,7 +13,7 @@ do_deploy_append() {
mkbootimg_dtarg=""
if [ "${QCOM_BOOTIMG_BUNDLE_DT}" = "1" ]; then
export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:${STAGING_LIBDIR_NATIVE}"
- dtbTool -o ${DEPLOYDIR}/${DT_IMAGE_BASE_NAME}.img -s ${QCOM_BOOTIMG_PAGE_SIZE} ${B}/arch/${ARCH}/boot/dts/qcom/
+ ${STAGING_BINDIR_NATIVE}/skales/dtbTool -o ${DEPLOYDIR}/${DT_IMAGE_BASE_NAME}.img -s ${QCOM_BOOTIMG_PAGE_SIZE} ${B}/arch/${ARCH}/boot/dts/qcom/
mkbootimg_dtarg="--dt ${DEPLOYDIR}/${DT_IMAGE_BASE_NAME}.img"
ln -sf ${DT_IMAGE_BASE_NAME}.img ${DEPLOYDIR}/${DT_IMAGE_SYMLINK_NAME}.img
fi
@@ -26,7 +26,7 @@ do_deploy_append() {
# during boot
echo "This is not an initrd" > ${B}/initrd.img
- mkbootimg --kernel ${B}/arch/${ARCH}/boot/${KERNEL_IMAGETYPE} \
+ ${STAGING_BINDIR_NATIVE}/skales/mkbootimg --kernel ${B}/arch/${ARCH}/boot/${KERNEL_IMAGETYPE} \
--ramdisk ${B}/initrd.img \
--output ${DEPLOYDIR}/${BOOT_IMAGE_BASE_NAME}.img \
$mkbootimg_dtarg \