aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/mesa/files/0001-meson-misdetects-64bit-atomics-on-mips-clang.patch6
-rw-r--r--recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch12
-rw-r--r--recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch22
-rw-r--r--recipes-graphics/mesa/files/0003-Allow-enable-DRI-without-DRI-drivers.patch14
-rw-r--r--recipes-graphics/mesa/files/0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch99
-rw-r--r--recipes-graphics/mesa/files/0005-vc4-use-intmax_t-for-formatted-output-of-timespec-me.patch15
-rw-r--r--recipes-graphics/mesa/files/fix-meson-config-compat.patch37
-rw-r--r--recipes-graphics/mesa/mesa-git.inc18
-rw-r--r--recipes-graphics/mesa/mesa_git.bb18
9 files changed, 170 insertions, 71 deletions
diff --git a/recipes-graphics/mesa/files/0001-meson-misdetects-64bit-atomics-on-mips-clang.patch b/recipes-graphics/mesa/files/0001-meson-misdetects-64bit-atomics-on-mips-clang.patch
index 15485fe..7fbbe98 100644
--- a/recipes-graphics/mesa/files/0001-meson-misdetects-64bit-atomics-on-mips-clang.patch
+++ b/recipes-graphics/mesa/files/0001-meson-misdetects-64bit-atomics-on-mips-clang.patch
@@ -1,4 +1,4 @@
-From bb2f0bea553d51d659a9bc46f7ae186885405151 Mon Sep 17 00:00:00 2001
+From 515bded412d2624a6a9744838a7a0da7b402f612 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Mon, 13 Jan 2020 15:23:47 -0800
Subject: [PATCH] meson misdetects 64bit atomics on mips/clang
@@ -10,7 +10,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/util/u_atomic.c b/src/util/u_atomic.c
-index e4bffa8..58e1ddd 100644
+index e4bffa8534e..58e1dddca35 100644
--- a/src/util/u_atomic.c
+++ b/src/util/u_atomic.c
@@ -21,7 +21,7 @@
@@ -23,5 +23,5 @@ index e4bffa8..58e1ddd 100644
#include <stdint.h>
#include <pthread.h>
--
-2.24.1
+2.28.0
diff --git a/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch b/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
index 0852543..2a78921 100644
--- a/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
+++ b/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
@@ -1,4 +1,4 @@
-From 0d9ed002eff176b902da266d89829a9b0cb10946 Mon Sep 17 00:00:00 2001
+From 08c1591085f88190884809aeaf562d5a963399f7 Mon Sep 17 00:00:00 2001
From: Alistair Francis <alistair@alistair23.me>
Date: Thu, 14 Nov 2019 13:04:49 -0800
Subject: [PATCH] meson.build: check for all linux host_os combinations
@@ -14,16 +14,15 @@ Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Alistair Francis <alistair@alistair23.me>
-
---
meson.build | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/meson.build b/meson.build
-index 898d025..09e3759 100644
+index be007953c8b..e3e1dbfb116 100644
--- a/meson.build
+++ b/meson.build
-@@ -124,7 +124,7 @@ with_any_opengl = with_opengl or with_gles1 or with_gles2
+@@ -152,7 +152,7 @@ with_any_opengl = with_opengl or with_gles1 or with_gles2
# Only build shared_glapi if at least one OpenGL API is enabled
with_shared_glapi = with_shared_glapi and with_any_opengl
@@ -32,7 +31,7 @@ index 898d025..09e3759 100644
dri_drivers = get_option('dri-drivers')
if dri_drivers.contains('auto')
-@@ -884,7 +884,7 @@ if cc.compiles('__uint128_t foo(void) { return 0; }',
+@@ -928,7 +928,7 @@ if cc.compiles('__uint128_t foo(void) { return 0; }',
endif
# TODO: this is very incomplete
@@ -41,3 +40,6 @@ index 898d025..09e3759 100644
pre_args += '-D_GNU_SOURCE'
elif host_machine.system() == 'sunos'
pre_args += '-D__EXTENSIONS__'
+--
+2.28.0
+
diff --git a/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch b/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
index 3dd4124..8c0bab0 100644
--- a/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
+++ b/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
@@ -1,6 +1,6 @@
-From dd1d15c75f6ff8ee96cf1e7b74e582bff3183ef6 Mon Sep 17 00:00:00 2001
+From 16012eb00fa76343b35365e96ef24806c65948e1 Mon Sep 17 00:00:00 2001
From: Alistair Francis <alistair@alistair23.me>
-Date: Thu, 14 Nov 2019 13:08:31 -0800
+Date: Wed, 2 Sep 2020 15:28:50 -0500
Subject: [PATCH] meson.build: make TLS ELF optional
USE_ELF_TLS has replaced GLX_USE_TLS so this patch is the original "make
@@ -8,30 +8,29 @@ TLS GLX optional again" patch updated to the latest mesa.
Upstream-Status: Inappropriate [configuration]
Signed-off-by: Alistair Francis <alistair@alistair23.me>
-
---
meson.build | 2 +-
meson_options.txt | 6 ++++++
2 files changed, 7 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
-index 261b588..311436e 100644
+index e3e1dbfb116..791a42a083e 100644
--- a/meson.build
+++ b/meson.build
-@@ -392,7 +392,7 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless or with_plat
- endif
+@@ -428,7 +428,7 @@ endif
# Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
--if not ['windows', 'freebsd'].contains(host_machine.system()) and (not with_platform_android or get_option('platform-sdk-version') >= 29)
+ use_elf_tls = false
+-if not ['windows', 'freebsd', 'openbsd'].contains(host_machine.system()) and (not with_platform_android or get_option('platform-sdk-version') >= 29)
+if (not with_platform_android or get_option('platform-sdk-version') >= 29) and get_option('elf-tls')
pre_args += '-DUSE_ELF_TLS'
+ use_elf_tls = true
endif
-
diff --git a/meson_options.txt b/meson_options.txt
-index ab43150..d7b1555 100644
+index a0cf4abca92..d472772373e 100644
--- a/meson_options.txt
+++ b/meson_options.txt
-@@ -355,6 +355,12 @@ option(
+@@ -368,6 +368,12 @@ option(
value : true,
description : 'Enable direct rendering in GLX and EGL for DRI',
)
@@ -44,3 +43,6 @@ index ab43150..d7b1555 100644
option(
'prefer-iris',
type : 'boolean',
+--
+2.28.0
+
diff --git a/recipes-graphics/mesa/files/0003-Allow-enable-DRI-without-DRI-drivers.patch b/recipes-graphics/mesa/files/0003-Allow-enable-DRI-without-DRI-drivers.patch
index 727227a..d6511b8 100644
--- a/recipes-graphics/mesa/files/0003-Allow-enable-DRI-without-DRI-drivers.patch
+++ b/recipes-graphics/mesa/files/0003-Allow-enable-DRI-without-DRI-drivers.patch
@@ -1,4 +1,4 @@
-From 7eaa21a79ce6d6e92f6bf98c28b68e3fcb4d7874 Mon Sep 17 00:00:00 2001
+From 6e550e092e1329e8ba8da6eb0b86b7b48def2b13 Mon Sep 17 00:00:00 2001
From: Fabio Berton <fabio.berton@ossystems.com.br>
Date: Wed, 12 Jun 2019 14:18:31 -0300
Subject: [PATCH] Allow enable DRI without DRI drivers
@@ -8,17 +8,16 @@ Upstream-Status: Pending
Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-
---
meson.build | 2 +-
meson_options.txt | 6 ++++++
2 files changed, 7 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
-index a954118..62864c6 100644
+index 791a42a083e..2bc7d3a3556 100644
--- a/meson.build
+++ b/meson.build
-@@ -154,7 +154,7 @@ with_dri_r200 = dri_drivers.contains('r200')
+@@ -182,7 +182,7 @@ with_dri_r200 = dri_drivers.contains('r200')
with_dri_nouveau = dri_drivers.contains('nouveau')
with_dri_swrast = dri_drivers.contains('swrast')
@@ -28,10 +27,10 @@ index a954118..62864c6 100644
gallium_drivers = get_option('gallium-drivers')
if gallium_drivers.contains('auto')
diff --git a/meson_options.txt b/meson_options.txt
-index 637ff14..700c34c 100644
+index d472772373e..0d8fd65e07e 100644
--- a/meson_options.txt
+++ b/meson_options.txt
-@@ -35,6 +35,12 @@ option(
+@@ -42,6 +42,12 @@ option(
choices : ['auto', 'true', 'false', 'disabled', 'enabled'],
description : 'enable support for dri3'
)
@@ -44,3 +43,6 @@ index 637ff14..700c34c 100644
option(
'dri-drivers',
type : 'array',
+--
+2.28.0
+
diff --git a/recipes-graphics/mesa/files/0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch b/recipes-graphics/mesa/files/0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch
index 6bdbd4e..1cda3df 100644
--- a/recipes-graphics/mesa/files/0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch
+++ b/recipes-graphics/mesa/files/0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch
@@ -1,6 +1,6 @@
-From 41cd8836d785c79381764e7de59319f87959a5cf Mon Sep 17 00:00:00 2001
+From cfd31ff9b1bfa69c6a1b3486386a7eb28d9e925a Mon Sep 17 00:00:00 2001
From: Alistair Francis <alistair@alistair23.me>
-Date: Thu, 14 Nov 2019 09:06:02 -0800
+Date: Wed, 2 Sep 2020 15:31:59 -0500
Subject: [PATCH] Revert "mesa: Enable asm unconditionally, now that
gen_matypes is gone."
@@ -8,25 +8,65 @@ This reverts commit 20294dceebc23236e33b22578245f7e6f41b6997.
Upstream-Status: Inappropriate [configuration]
Signed-off-by: Alistair Francis <alistair@alistair23.me>
-
---
- meson.build | 94 ++++++++++++++++++++++++++++++-----------------
- meson_options.txt | 6 +++
- 2 files changed, 67 insertions(+), 33 deletions(-)
+ Android.common.mk | 3 +
+ Android.mk | 7 +++
+ meson.build | 96 +++++++++++++++++++----------
+ meson_options.txt | 6 ++
+ src/mesa/Android.libmesa_dricore.mk | 2 +
+ src/mesa/Android.libmesa_st_mesa.mk | 2 +
+ 6 files changed, 83 insertions(+), 33 deletions(-)
+diff --git a/Android.common.mk b/Android.common.mk
+index 9141ef951d6..cec6f7888c3 100644
+--- a/Android.common.mk
++++ b/Android.common.mk
+@@ -103,9 +103,12 @@ ifeq ($(shell test $(PLATFORM_SDK_VERSION) -ge 26 && echo true),true)
+ LOCAL_CFLAGS += -DHAVE_SYS_SHM_H
+ endif
+
++ifeq ($(strip $(MESA_ENABLE_ASM)),true)
+ ifeq ($(TARGET_ARCH),x86)
+ LOCAL_CFLAGS += \
+ -DUSE_X86_ASM
++
++endif
+ endif
+ ifeq ($(ARCH_ARM_HAVE_NEON),true)
+ LOCAL_CFLAGS_arm += -DUSE_ARM_ASM
+diff --git a/Android.mk b/Android.mk
+index aa2e7f7610e..adc0db69584 100644
+--- a/Android.mk
++++ b/Android.mk
+@@ -90,6 +90,13 @@ endif
+
+ $(foreach d, $(MESA_BUILD_CLASSIC) $(MESA_BUILD_GALLIUM), $(eval $(d) := true))
+
++# host and target must be the same arch to generate matypes.h
++ifeq ($(TARGET_ARCH),$(HOST_ARCH))
++MESA_ENABLE_ASM := true
++else
++MESA_ENABLE_ASM := false
++endif
++
+ ifneq ($(filter true, $(HAVE_GALLIUM_RADEONSI)),)
+ MESA_ENABLE_LLVM := true
+ endif
diff --git a/meson.build b/meson.build
-index 62864c6..b53be8d 100644
+index 2bc7d3a3556..c0159c155fb 100644
--- a/meson.build
+++ b/meson.build
-@@ -49,6 +49,7 @@ with_vulkan_icd_dir = get_option('vulkan-icd-dir')
-
+@@ -52,6 +52,9 @@ pre_args = [
with_vulkan_icd_dir = get_option('vulkan-icd-dir')
with_tests = get_option('build-tests')
+ with_aco_tests = get_option('build-aco-tests')
++with_valgrind = get_option('valgrind')
++with_libunwind = get_option('libunwind')
+with_asm = get_option('asm')
with_glx_read_only_text = get_option('glx-read-only-text')
with_glx_direct = get_option('glx-direct')
with_osmesa = get_option('osmesa')
-@@ -1093,41 +1094,68 @@ dep_ws2_32 = cc.find_library('ws2_32', required : with_platform_windows)
+@@ -1149,41 +1152,68 @@ dep_ws2_32 = cc.find_library('ws2_32', required : with_platform_windows)
# TODO: shared/static? Is this even worth doing?
@@ -129,10 +169,10 @@ index 62864c6..b53be8d 100644
endif
diff --git a/meson_options.txt b/meson_options.txt
-index 700c34c..62e8472 100644
+index 0d8fd65e07e..0fc28d69c93 100644
--- a/meson_options.txt
+++ b/meson_options.txt
-@@ -241,6 +241,12 @@ option(
+@@ -254,6 +254,12 @@ option(
value : false,
description : 'Enable GLVND support.'
)
@@ -145,3 +185,38 @@ index 700c34c..62e8472 100644
option(
'glx-read-only-text',
type : 'boolean',
+diff --git a/src/mesa/Android.libmesa_dricore.mk b/src/mesa/Android.libmesa_dricore.mk
+index 8eb6aabe836..792117767b4 100644
+--- a/src/mesa/Android.libmesa_dricore.mk
++++ b/src/mesa/Android.libmesa_dricore.mk
+@@ -39,9 +39,11 @@ LOCAL_MODULE_CLASS := STATIC_LIBRARIES
+ LOCAL_SRC_FILES := \
+ $(MESA_FILES)
+
++ifeq ($(strip $(MESA_ENABLE_ASM)),true)
+ ifeq ($(TARGET_ARCH),x86)
+ LOCAL_SRC_FILES += $(X86_FILES)
+ endif # x86
++endif # MESA_ENABLE_ASM
+
+ ifeq ($(ARCH_X86_HAVE_SSE4_1),true)
+ LOCAL_WHOLE_STATIC_LIBRARIES := \
+diff --git a/src/mesa/Android.libmesa_st_mesa.mk b/src/mesa/Android.libmesa_st_mesa.mk
+index 16153a3c5bd..ddfd03059c5 100644
+--- a/src/mesa/Android.libmesa_st_mesa.mk
++++ b/src/mesa/Android.libmesa_st_mesa.mk
+@@ -42,9 +42,11 @@ LOCAL_GENERATED_SOURCES := \
+ $(MESA_GEN_GLSL_H) \
+ $(MESA_GEN_NIR_H)
+
++ifeq ($(strip $(MESA_ENABLE_ASM)),true)
+ ifeq ($(TARGET_ARCH),x86)
+ LOCAL_SRC_FILES += $(X86_FILES)
+ endif # x86
++endif # MESA_ENABLE_ASM
+
+ ifeq ($(ARCH_X86_HAVE_SSE4_1),true)
+ LOCAL_WHOLE_STATIC_LIBRARIES := \
+--
+2.28.0
+
diff --git a/recipes-graphics/mesa/files/0005-vc4-use-intmax_t-for-formatted-output-of-timespec-me.patch b/recipes-graphics/mesa/files/0005-vc4-use-intmax_t-for-formatted-output-of-timespec-me.patch
index dacb1ea..db2dd34 100644
--- a/recipes-graphics/mesa/files/0005-vc4-use-intmax_t-for-formatted-output-of-timespec-me.patch
+++ b/recipes-graphics/mesa/files/0005-vc4-use-intmax_t-for-formatted-output-of-timespec-me.patch
@@ -1,7 +1,8 @@
-From 281a636353666bfdd373c62591e744087e750e89 Mon Sep 17 00:00:00 2001
+From ac12c3494d64f8b2250d28963f5ffe6fa30110cf Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Wed, 4 Dec 2019 14:15:28 -0800
-Subject: [PATCH] vc4: use intmax_t for formatted output of timespec members
+Subject: [PATCH] vc4: use intmax_t for formatted output of timespec
+ members
32bit architectures which have 64bit time_t does not fit the assumption
of time_t being same as system long int
@@ -13,17 +14,16 @@ error: format specifies type 'long' but the argument has type 'time_t' (aka 'lon
Upstream-Status: Submitted [https://gitlab.freedesktop.org/mesa/mesa/merge_requests/2966]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
---
src/gallium/drivers/v3d/v3d_bufmgr.c | 4 ++--
src/gallium/drivers/vc4/vc4_bufmgr.c | 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/src/gallium/drivers/v3d/v3d_bufmgr.c b/src/gallium/drivers/v3d/v3d_bufmgr.c
-index 31a0803..cc2e2af 100644
+index 48f5a54936c..e27395fa035 100644
--- a/src/gallium/drivers/v3d/v3d_bufmgr.c
+++ b/src/gallium/drivers/v3d/v3d_bufmgr.c
-@@ -80,8 +80,8 @@ v3d_bo_dump_stats(struct v3d_screen *screen)
+@@ -72,8 +72,8 @@ v3d_bo_dump_stats(struct v3d_screen *screen)
struct timespec time;
clock_gettime(CLOCK_MONOTONIC, &time);
@@ -35,7 +35,7 @@ index 31a0803..cc2e2af 100644
}
diff --git a/src/gallium/drivers/vc4/vc4_bufmgr.c b/src/gallium/drivers/vc4/vc4_bufmgr.c
-index a786e8e..975d49e 100644
+index a786e8ee939..975d49e2e77 100644
--- a/src/gallium/drivers/vc4/vc4_bufmgr.c
+++ b/src/gallium/drivers/vc4/vc4_bufmgr.c
@@ -99,8 +99,8 @@ vc4_bo_dump_stats(struct vc4_screen *screen)
@@ -49,3 +49,6 @@ index a786e8e..975d49e 100644
}
}
+--
+2.28.0
+
diff --git a/recipes-graphics/mesa/files/fix-meson-config-compat.patch b/recipes-graphics/mesa/files/fix-meson-config-compat.patch
index 3eedbec..59811b0 100644
--- a/recipes-graphics/mesa/files/fix-meson-config-compat.patch
+++ b/recipes-graphics/mesa/files/fix-meson-config-compat.patch
@@ -1,8 +1,24 @@
-Index: git/meson_options.txt
-===================================================================
---- git.orig/meson_options.txt
-+++ git/meson_options.txt
-@@ -45,7 +45,7 @@ option(
+From ae96da4146570ebe9b0a9e68ac209cda6f1fb7ff Mon Sep 17 00:00:00 2001
+From: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
+Date: Wed, 2 Sep 2020 15:37:55 -0500
+Subject: [PATCH] mesa: adapt meson script to restore compatibility with
+ release one
+
+During this development cycle meson script was changed to stop accepting
+empty values. This causes issues using some build options from OE-core's
+mesa.inc. Restore this compatibility by patching in support for empty
+values.
+
+Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
+---
+ meson_options.txt | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/meson_options.txt b/meson_options.txt
+index 0fc28d69c93..c29e73b62ca 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -52,7 +52,7 @@ option(
'dri-drivers',
type : 'array',
value : ['auto'],
@@ -11,7 +27,7 @@ Index: git/meson_options.txt
description : 'List of dri drivers to build. If this is set to auto all drivers applicable to the target OS/architecture will be built'
)
option(
-@@ -65,7 +65,7 @@ option(
+@@ -72,7 +72,7 @@ option(
type : 'array',
value : ['auto'],
choices : [
@@ -20,12 +36,15 @@ Index: git/meson_options.txt
'swrast', 'v3d', 'vc4', 'etnaviv', 'tegra', 'i915', 'svga', 'virgl',
'swr', 'panfrost', 'iris', 'lima', 'zink'
],
-@@ -165,7 +165,7 @@ option(
+@@ -172,7 +172,7 @@ option(
'vulkan-drivers',
type : 'array',
value : ['auto'],
-- choices : ['auto', 'amd', 'freedreno', 'intel'],
-+ choices : ['', 'auto', 'amd', 'freedreno', 'intel'],
+- choices : ['auto', 'amd', 'freedreno', 'intel', 'swrast'],
++ choices : ['', 'auto', 'amd', 'freedreno', 'intel', 'swrast'],
description : 'List of vulkan drivers to build. If this is set to auto all drivers applicable to the target OS/architecture will be built'
)
option(
+--
+2.28.0
+
diff --git a/recipes-graphics/mesa/mesa-git.inc b/recipes-graphics/mesa/mesa-git.inc
deleted file mode 100644
index bc41a3d..0000000
--- a/recipes-graphics/mesa/mesa-git.inc
+++ /dev/null
@@ -1,18 +0,0 @@
-SRC_URI = "git://gitlab.freedesktop.org/mesa/mesa.git;protocol=https \
- file://0001-meson.build-check-for-all-linux-host_os-combinations.patch \
- file://0002-meson.build-make-TLS-ELF-optional.patch \
- file://0003-Allow-enable-DRI-without-DRI-drivers.patch \
- file://0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch \
- file://0005-vc4-use-intmax_t-for-formatted-output-of-timespec-me.patch \
- file://0001-meson-misdetects-64bit-atomics-on-mips-clang.patch \
- file://fix-meson-config-compat.patch \
- "
-
-S = "${WORKDIR}/git"
-
-LIC_FILES_CHKSUM = "file://docs/license.rst;md5=9aa1bc48c9826ad9fdb16661f6930496"
-
-PV = "20.2-pre+git${SRCPV}"
-
-# Do not select this version by default
-DEFAULT_PREFERENCE = "-1"
diff --git a/recipes-graphics/mesa/mesa_git.bb b/recipes-graphics/mesa/mesa_git.bb
index 537e849..5bd1e09 100644
--- a/recipes-graphics/mesa/mesa_git.bb
+++ b/recipes-graphics/mesa/mesa_git.bb
@@ -1,8 +1,22 @@
require recipes-graphics/mesa/mesa.inc
-require mesa-git.inc
+SRC_URI = "git://gitlab.freedesktop.org/mesa/mesa.git;protocol=https \
+ file://0001-meson.build-check-for-all-linux-host_os-combinations.patch \
+ file://0002-meson.build-make-TLS-ELF-optional.patch \
+ file://0003-Allow-enable-DRI-without-DRI-drivers.patch \
+ file://0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch \
+ file://0005-vc4-use-intmax_t-for-formatted-output-of-timespec-me.patch \
+ file://0001-meson-misdetects-64bit-atomics-on-mips-clang.patch \
+ file://fix-meson-config-compat.patch \
+ "
+LIC_FILES_CHKSUM = "file://docs/license.rst;md5=9aa1bc48c9826ad9fdb16661f6930496"
-SRCREV = "d542bfc3066c86256748ccb681fad7f80e8668bd"
+SRCREV = "61b714a42ee676fe03b383c0caf050169e404c7d"
#SRCREV_sm8250 = "${AUTOREV}"
+S = "${WORKDIR}/git"
+PV = "20.3-dev+git${SRCPV}"
+
+# Do not select this version by default
+DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_sm8250 = "1"