aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/dragonboard-410c.conf7
-rw-r--r--recipes-bsp/qdsp-config/qdsp-config_1.1.bb26
-rw-r--r--recipes-bsp/wcnss-config/wcnss-config_1.11.2.bb (renamed from recipes-bsp/wcnss-config/wcnss-config_1.11.1.bb)12
-rw-r--r--recipes-kernel/linux/linux-linaro-qcomlt_4.4.bb4
-rw-r--r--recipes-navigation/gpsd/gpsd-machine-conf_%.bbappend2
-rw-r--r--recipes-support/qmi-gps-proxy/files/fix_makefile.patch23
-rw-r--r--recipes-support/qmi-gps-proxy/qmi-gps-proxy_0.0+0+df3b976-3.bb39
-rw-r--r--recipes-support/rmtfs/files/rmtfs.service2
8 files changed, 107 insertions, 8 deletions
diff --git a/conf/machine/dragonboard-410c.conf b/conf/machine/dragonboard-410c.conf
index 236c651..12bbbf2 100644
--- a/conf/machine/dragonboard-410c.conf
+++ b/conf/machine/dragonboard-410c.conf
@@ -18,7 +18,7 @@ XSERVER ?= "xserver-xorg \
xf86-input-mouse \
xf86-input-keyboard"
-MACHINE_FEATURES = "usbhost usbgadget alsa screen wifi bluetooth efi"
+MACHINE_FEATURES = "usbhost usbgadget alsa screen wifi bluetooth ext2"
PREFERRED_PROVIDER_virtual/egl ?= "mesa"
PREFERRED_PROVIDER_virtual/libgl ?= "mesa"
@@ -28,14 +28,15 @@ PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
PREFERRED_PROVIDER_virtual/kernel ?= "linux-linaro-qcomlt"
KERNEL_IMAGETYPE = "Image"
-KERNEL_DEVICETREE = "${S}/arch/arm64/boot/dts/dragonboard.dts"
+KERNEL_DEVICETREE = "qcom/apq8016-sbc.dtb"
SERIAL_CONSOLE = "115200 ttyMSM0"
MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += " \
kernel-modules \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-msm', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'wifi', 'wcnss-config', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wifi', 'wcnss-config wcnss-start', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5-noinst-tools', '', d)} \
${@'firmware-qcom-dragonboard410c' if d.getVar('ACCEPT_EULA_dragonboard-410c', True) == '1' else ''}"
CMDLINE = "console=ttyMSM0,115200n8 root=/dev/mmcblk0p10 rootwait"
diff --git a/recipes-bsp/qdsp-config/qdsp-config_1.1.bb b/recipes-bsp/qdsp-config/qdsp-config_1.1.bb
new file mode 100644
index 0000000..fb3011b
--- /dev/null
+++ b/recipes-bsp/qdsp-config/qdsp-config_1.1.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Configuration files for Hexagon DSP on QCOM SoC"
+HOMEPAGE = "https://git.linaro.org/landing-teams/working/qualcomm/pkg/qdsp-config.git"
+SECTION = "devel"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://debian/copyright;md5=0cac98b620cedbb3464bea2237db5bd6"
+
+SRCREV = "debian/${PV}"
+SRC_URI = "git://git.linaro.org/landing-teams/working/qualcomm/pkg/qdsp-config.git;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
+
+inherit systemd allarch
+
+do_install () {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${S}/debian/qdsp-start.service ${D}${systemd_unitdir}/system
+
+ install -d ${D}${sbindir}
+ install -m 0755 ${S}/qdsp-start ${D}${sbindir}
+}
+
+RDEPENDS_${PN} += "rmtfs"
+
+SYSTEMD_SERVICE_${PN} = "qdsp-start.service"
+SYSTEMD_AUTO_ENABLE_${PN} = "disable"
diff --git a/recipes-bsp/wcnss-config/wcnss-config_1.11.1.bb b/recipes-bsp/wcnss-config/wcnss-config_1.11.2.bb
index 4720f72..65daa75 100644
--- a/recipes-bsp/wcnss-config/wcnss-config_1.11.1.bb
+++ b/recipes-bsp/wcnss-config/wcnss-config_1.11.2.bb
@@ -12,15 +12,27 @@ S = "${WORKDIR}/git"
inherit systemd allarch
+PACKAGES =+ "wcnss-start"
+
do_install () {
install -d ${D}${sysconfdir}/udev/rules.d
install -m 0755 ${S}/debian/wcnss-wlan.udev ${D}${sysconfdir}/udev/rules.d/wcnss-wlan.rules
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${S}/debian/wcnss-wlan.service ${D}${systemd_unitdir}/system
+ install -m 0644 ${S}/debian/wcnss-start.service ${D}${systemd_unitdir}/system
install -d ${D}${sbindir}
install -m 0755 ${S}/wcnss-gen-macaddr ${D}${sbindir}
+ install -m 0755 ${S}/wcnss-start ${D}${sbindir}
}
+FILES_wcnss-start = "${sbindir}/wcnss-start ${systemd_unitdir}/system/wcnss-start.service"
+
+# need wcnss-gen-macaddr
+RDEPENDS_wcnss-start += "${PN}"
+
+SYSTEMD_PACKAGES = "${PN} wcnss-start"
SYSTEMD_SERVICE_${PN} = "wcnss-wlan.service"
+SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+SYSTEMD_SERVICE_wcnss-start = "wcnss-start.service"
diff --git a/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bb b/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bb
index 22a506f..689c444 100644
--- a/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bb
+++ b/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bb
@@ -9,15 +9,13 @@ require recipes-kernel/linux/linux-qcom-bootimg.inc
LOCALVERSION ?= "-linaro-lt-qcom"
SRCBRANCH ?= "release/qcomlt-4.4"
-SRCREV ?= "a84088931ea4f33d39ab066c0d3146e5dc501308"
+SRCREV ?= "f404da21e128bc015dfcbb88d3daf2bcf18ef872"
COMPATIBLE_MACHINE = "(ifc6410|dragonboard-410c)"
KERNEL_DEFCONFIG_dragonboard-410c ?= "${S}/arch/arm64/configs/defconfig"
KERNEL_DEFCONFIG_ifc6410 ?= "${S}/arch/arm/configs/qcom_defconfig"
KERNEL_CONFIG_FRAGMENTS += "${S}/kernel/configs/distro.config"
-KERNEL_IMAGETYPE_dragonboard-410c ?= "Image"
-KERNEL_DEVICETREE_dragonboard-410c = "qcom/apq8016-sbc.dtb"
# fixup.bin needs to be prepended to zImage to fixup the atag mem info because of broken bootloaders.
# Without this a panic will occur upon freeing bootmem.
diff --git a/recipes-navigation/gpsd/gpsd-machine-conf_%.bbappend b/recipes-navigation/gpsd/gpsd-machine-conf_%.bbappend
index a5a78ef..179c438 100644
--- a/recipes-navigation/gpsd/gpsd-machine-conf_%.bbappend
+++ b/recipes-navigation/gpsd/gpsd-machine-conf_%.bbappend
@@ -1,5 +1,5 @@
EXTRA_DEPS = ""
-EXTRA_DEPS_dragonboard-410c = "qrtr-apps rmtfs"
+EXTRA_DEPS_dragonboard-410c = "qrtr-apps gnss-gpsd qdsp-config"
RDEPENDS_${PN} += "${EXTRA_DEPS}"
diff --git a/recipes-support/qmi-gps-proxy/files/fix_makefile.patch b/recipes-support/qmi-gps-proxy/files/fix_makefile.patch
new file mode 100644
index 0000000..a0ac51c
--- /dev/null
+++ b/recipes-support/qmi-gps-proxy/files/fix_makefile.patch
@@ -0,0 +1,23 @@
+diff --git a/Makefile b/Makefile
+index 2b611a1..0040626 100644
+--- a/Makefile
++++ b/Makefile
+@@ -2,6 +2,7 @@ OUT := gps_proxy
+
+ CFLAGS := -Wall -g -I../qrtr/lib
+ LDFLAGS := -L../qrtr -lqrtr
++prefix := /usr/local
+
+ SRCS := qmi_gps.c qmi_tlv.c gps_proxy.c util.c
+ OBJS := $(SRCS:.c=.o)
+@@ -12,8 +13,8 @@ $(OUT): $(OBJS)
+ #%.c: %.qmi
+ # qmic < $<
+
+-test: $(OUT)
+- ./$(OUT)
++install: $(OUT)
++ install -D -m 755 $< $(DESTDIR)$(prefix)/bin/$<
+
+ clean:
+ rm -f $(OUT) $(OBJS)
diff --git a/recipes-support/qmi-gps-proxy/qmi-gps-proxy_0.0+0+df3b976-3.bb b/recipes-support/qmi-gps-proxy/qmi-gps-proxy_0.0+0+df3b976-3.bb
new file mode 100644
index 0000000..7e58c18
--- /dev/null
+++ b/recipes-support/qmi-gps-proxy/qmi-gps-proxy_0.0+0+df3b976-3.bb
@@ -0,0 +1,39 @@
+SUMMARY = "QMI GPS proxy daemon"
+HOMEPAGE = "https://git.linaro.org/landing-teams/working/qualcomm/pkg/qmi_loc2.git"
+SECTION = "devel"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://debian/copyright;md5=f84ce8e3f8d00a43026f8a80e62bca8e"
+
+inherit systemd
+
+SRCREV = "debian/${PV}"
+SRC_URI = "git://git.linaro.org/landing-teams/working/qualcomm/pkg/qmi_loc2.git;branch=master;protocol=https"
+SRC_URI += "file://fix_makefile.patch"
+DEPENDS = "qrtr"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "'LDFLAGS=${TARGET_LDFLAGS} -L${STAGING_LIBDIR} -lqrtr'"
+
+do_install () {
+ oe_runmake install DESTDIR=${D} prefix=${prefix}
+
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${S}/debian/qmi-gps-proxy.service ${D}${systemd_unitdir}/system
+ install -m 0644 ${S}/debian/gnss-gpsd.service ${D}${systemd_unitdir}/system
+
+ install -d ${D}${sysconfdir}/udev/rules.d
+ install -m 0644 ${S}/debian/qmi-gps-proxy.udev ${D}${sysconfdir}/udev/rules.d/qmi-gps-proxy.rules
+ install -m 0644 ${S}/debian/gnss-gpsd.udev ${D}${sysconfdir}/udev/rules.d/gnss-gpsd.rules
+}
+
+SYSTEMD_PACKAGES = "${PN} gnss-gpsd"
+SYSTEMD_SERVICE_${PN} = "qmi-gps-proxy.service"
+SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+
+PACKAGES =+ "gnss-gpsd"
+FILES_gnss-gpsd = "${sysconfdir}/udev/rules.d/gnss-gpsd.rules ${systemd_unitdir}/system/gnss-gpsd.service"
+RDEPENDS_gnss-gpsd += "gpsd qmi-gps-proxy"
+SYSTEMD_SERVICE_gnss-gpsd= "gnss-gpsd.service"
+SYSTEMD_AUTO_ENABLE_gnss-gpsd = "disable"
diff --git a/recipes-support/rmtfs/files/rmtfs.service b/recipes-support/rmtfs/files/rmtfs.service
index 4d2e601..e3965db 100644
--- a/recipes-support/rmtfs/files/rmtfs.service
+++ b/recipes-support/rmtfs/files/rmtfs.service
@@ -1,6 +1,6 @@
[Unit]
Description=RMTFS setup
-After=systemd-remount-fs.service
+After=systemd-remount-fs.service qrtr.service
Requires=qrtr.service
[Service]