aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend26
1 files changed, 6 insertions, 20 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 00e12fd..bdacbb0 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,27 +1,13 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
# Enable freedreno driver
-GALLIUMDRIVERS_append_apq8064 = ",freedreno"
-GALLIUMDRIVERS_append_apq8016 = ",freedreno"
-GALLIUMDRIVERS_append_apq8096 = ",freedreno"
-GALLIUMDRIVERS_append_sdm845 = ",freedreno"
-
-PACKAGECONFIG_append_apq8064 = " \
- gallium \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
-"
-
-PACKAGECONFIG_append_apq8016 = " \
- gallium \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
-"
-
-PACKAGECONFIG_append_apq8096 = " \
+PACKAGECONFIG_FREEDRENO = "\
gallium \
+ freedreno \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
"
-PACKAGECONFIG_append_sdm845 = " \
- gallium \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
-"
+PACKAGECONFIG_append_apq8016 = "${PACKAGECONFIG_FREEDRENO}"
+PACKAGECONFIG_append_apq8064 = "${PACKAGECONFIG_FREEDRENO}"
+PACKAGECONFIG_append_apq8096 = "${PACKAGECONFIG_FREEDRENO}"
+PACKAGECONFIG_append_sdm845 = "${PACKAGECONFIG_FREEDRENO}"