aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/dragonboard-410c.conf39
-rw-r--r--conf/machine/ifc6410.conf33
-rw-r--r--conf/machine/include/qcom-apq8016.inc30
-rw-r--r--conf/machine/include/qcom-apq8064.inc28
-rw-r--r--conf/machine/sd-600eval.conf20
-rw-r--r--recipes-bsp/firmware/firmware-qcom-dragonboard410c_1.3.0.bb (renamed from recipes-bsp/firmware/firmware-qcom-dragonboard410c_1.2.0.bb)12
-rw-r--r--recipes-bsp/firmware/firmware-qcom-sd-600eval_1.0.bb28
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend19
-rw-r--r--recipes-kernel/linux/linux-linaro-qcomlt_4.4.bb9
-rw-r--r--recipes-kernel/linux/linux-qcom-bootimg.inc4
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend4
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-v4l2.bb7
12 files changed, 148 insertions, 85 deletions
diff --git a/conf/machine/dragonboard-410c.conf b/conf/machine/dragonboard-410c.conf
index 12bbbf2..04e258d 100644
--- a/conf/machine/dragonboard-410c.conf
+++ b/conf/machine/dragonboard-410c.conf
@@ -2,46 +2,21 @@
#@NAME: dragonboard-410c
#@DESCRIPTION: Machine configuration for the DragonBoard 410c (96boards), with Qualcomm Snapdragon 410 APQ8016.
-require conf/machine/include/arm/arch-armv8.inc
-
-
-XSERVER_OPENGL ?= "xf86-video-freedreno \
- xserver-xorg-module-exa \
- xserver-xorg-extension-glx \
- xserver-xorg-extension-dri \
- "
-
-XSERVER ?= "xserver-xorg \
- xserver-xorg-module-libint10 \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${XSERVER_OPENGL}', 'xf86-video-fbdev', d)} \
- xf86-input-evdev \
- xf86-input-mouse \
- xf86-input-keyboard"
+require conf/machine/include/qcom-apq8016.inc
MACHINE_FEATURES = "usbhost usbgadget alsa screen wifi bluetooth ext2"
-PREFERRED_PROVIDER_virtual/egl ?= "mesa"
-PREFERRED_PROVIDER_virtual/libgl ?= "mesa"
-PREFERRED_PROVIDER_virtual/libgles1 ?= "mesa"
-PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa"
-PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
-PREFERRED_PROVIDER_virtual/kernel ?= "linux-linaro-qcomlt"
-
KERNEL_IMAGETYPE = "Image"
KERNEL_DEVICETREE = "qcom/apq8016-sbc.dtb"
SERIAL_CONSOLE = "115200 ttyMSM0"
MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += " \
- kernel-modules \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-msm', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'wifi', 'wcnss-config wcnss-start', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5-noinst-tools', '', d)} \
- ${@'firmware-qcom-dragonboard410c' if d.getVar('ACCEPT_EULA_dragonboard-410c', True) == '1' else ''}"
+ kernel-modules \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-msm', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wifi', 'wcnss-config wcnss-start', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5-noinst-tools', '', d)} \
+ ${@'firmware-qcom-dragonboard410c' if d.getVar('ACCEPT_EULA_dragonboard-410c', True) == '1' else ''} \
+"
CMDLINE = "console=ttyMSM0,115200n8 root=/dev/mmcblk0p10 rootwait"
-
-# Fastboot expects an ext4 image, which needs to be 4096 aligned
-IMAGE_FSTYPES_append = " ext4.gz"
-IMAGE_ROOTFS_ALIGNMENT = "4096"
-
diff --git a/conf/machine/ifc6410.conf b/conf/machine/ifc6410.conf
index 236b6da..cbed9b8 100644
--- a/conf/machine/ifc6410.conf
+++ b/conf/machine/ifc6410.conf
@@ -2,42 +2,19 @@
#@NAME: ifc6410
#@DESCRIPTION: Machine configuration for the Inforce IFC6410, with Qualcomm Snapdragon 600 APQ8064.
-require conf/machine/include/tune-cortexa8.inc
-
-XSERVER_OPENGL ?= "xf86-video-freedreno \
- xserver-xorg-module-exa \
- xserver-xorg-extension-glx \
- xserver-xorg-extension-dri \
- "
-
-XSERVER = " \
- xserver-xorg \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${XSERVER_OPENGL}', 'xf86-video-fbdev', d)} \
- xf86-input-mouse \
- xf86-input-keyboard \
- xf86-input-evdev \
-"
+require conf/machine/include/qcom-apq8064.inc
# features
MACHINE_FEATURES = "alsa kernel26 screen usb keyboard wifi ext2 ext3"
-MACHINE_EXTRA_RRECOMMENDS = " kernel-modules \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-msm', '', d)}"
-
-PREFERRED_PROVIDER_virtual/egl ?= "mesa"
-PREFERRED_PROVIDER_virtual/libgl ?= "mesa"
-PREFERRED_PROVIDER_virtual/libgles1 ?= "mesa"
-PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa"
-PREFERRED_PROVIDER_virtual/xserver = "xserver-xorg"
-PREFERRED_PROVIDER_virtual/kernel = "linux-linaro-qcomlt"
+MACHINE_EXTRA_RRECOMMENDS = " \
+ kernel-modules \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-msm', '', d)} \
+"
KERNEL_IMAGETYPE = "zImage"
KERNEL_DEVICETREE = "qcom-apq8064-ifc6410.dtb"
SERIAL_CONSOLE = "115200 ttyMSM0"
-# Fastboot expects an ext4 image, which needs to be 4096 aligned
-IMAGE_FSTYPES_append = " ext4.gz"
-IMAGE_ROOTFS_ALIGNMENT = "4096"
-
INHERIT += "qcom-firmware-mount"
diff --git a/conf/machine/include/qcom-apq8016.inc b/conf/machine/include/qcom-apq8016.inc
new file mode 100644
index 0000000..25458be
--- /dev/null
+++ b/conf/machine/include/qcom-apq8016.inc
@@ -0,0 +1,30 @@
+SOC_FAMILY = "apq8016"
+require conf/machine/include/soc-family.inc
+require conf/machine/include/arm/arch-armv8.inc
+
+XSERVER_OPENGL ?= " \
+ xf86-video-freedreno \
+ xserver-xorg-module-exa \
+ xserver-xorg-extension-glx \
+ xserver-xorg-extension-dri \
+"
+
+XSERVER ?= " \
+ xserver-xorg \
+ xserver-xorg-module-libint10 \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${XSERVER_OPENGL}', 'xf86-video-fbdev', d)} \
+ xf86-input-evdev \
+ xf86-input-mouse \
+ xf86-input-keyboard \
+"
+
+PREFERRED_PROVIDER_virtual/egl ?= "mesa"
+PREFERRED_PROVIDER_virtual/libgl ?= "mesa"
+PREFERRED_PROVIDER_virtual/libgles1 ?= "mesa"
+PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa"
+PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-linaro-qcomlt"
+
+# Fastboot expects an ext4 image, which needs to be 4096 aligned
+IMAGE_FSTYPES_append = " ext4.gz"
+IMAGE_ROOTFS_ALIGNMENT = "4096"
diff --git a/conf/machine/include/qcom-apq8064.inc b/conf/machine/include/qcom-apq8064.inc
new file mode 100644
index 0000000..2e7a60d
--- /dev/null
+++ b/conf/machine/include/qcom-apq8064.inc
@@ -0,0 +1,28 @@
+SOC_FAMILY = "apq8064"
+require conf/machine/include/soc-family.inc
+require conf/machine/include/tune-cortexa8.inc
+
+XSERVER_OPENGL ?= "xf86-video-freedreno \
+ xserver-xorg-module-exa \
+ xserver-xorg-extension-glx \
+ xserver-xorg-extension-dri \
+ "
+
+XSERVER = " \
+ xserver-xorg \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${XSERVER_OPENGL}', 'xf86-video-fbdev', d)} \
+ xf86-input-mouse \
+ xf86-input-keyboard \
+ xf86-input-evdev \
+"
+
+PREFERRED_PROVIDER_virtual/egl ?= "mesa"
+PREFERRED_PROVIDER_virtual/libgl ?= "mesa"
+PREFERRED_PROVIDER_virtual/libgles1 ?= "mesa"
+PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa"
+PREFERRED_PROVIDER_virtual/xserver = "xserver-xorg"
+PREFERRED_PROVIDER_virtual/kernel = "linux-linaro-qcomlt"
+
+# Fastboot expects an ext4 image, which needs to be 4096 aligned
+IMAGE_FSTYPES_append = " ext4.gz"
+IMAGE_ROOTFS_ALIGNMENT = "4096"
diff --git a/conf/machine/sd-600eval.conf b/conf/machine/sd-600eval.conf
new file mode 100644
index 0000000..18834b3
--- /dev/null
+++ b/conf/machine/sd-600eval.conf
@@ -0,0 +1,20 @@
+#@TYPE: Machine
+#@NAME: SD 600eval
+#@DESCRIPTION: Machine configuration for the Arrow SD 600eval, with Qualcomm Snapdragon 600 APQ8064.
+
+require conf/machine/include/qcom-apq8064.inc
+
+MACHINE_FEATURES = "usbhost usbgadget alsa screen wifi bluetooth ext2"
+
+MACHINE_EXTRA_RRECOMMENDS = " \
+ kernel-modules \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-msm', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wifi', 'wcnss-config wcnss-start', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5-noinst-tools', '', d)} \
+ firmware-qcom-sd-600eval \
+"
+
+KERNEL_IMAGETYPE = "zImage"
+KERNEL_DEVICETREE = "qcom-apq8064-arrow-sd-600eval.dtb"
+
+SERIAL_CONSOLE = "115200 ttyMSM0"
diff --git a/recipes-bsp/firmware/firmware-qcom-dragonboard410c_1.2.0.bb b/recipes-bsp/firmware/firmware-qcom-dragonboard410c_1.3.0.bb
index e275885..0d6daf6 100644
--- a/recipes-bsp/firmware/firmware-qcom-dragonboard410c_1.2.0.bb
+++ b/recipes-bsp/firmware/firmware-qcom-dragonboard410c_1.3.0.bb
@@ -4,15 +4,15 @@ LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://LICENSE;md5=003cae816e20ae44589f8f7cc022cb54"
SRC_URI = "http://developer.qualcomm.com/download/db410c/firmware-410c-${PV}.bin;qcom-eula=true"
-SRC_URI[md5sum] = "de6038f1c07b93886b8d0845a1d8eb4b"
-SRC_URI[sha256sum] = "c017b4c1bc4e52294539ef84ea18ed9a06e863b553c96eb5aaad915fc8b41bd6"
+SRC_URI[md5sum] = "3bcec6fa4068f4622c65a9b2e0b67f1f"
+SRC_URI[sha256sum] = "0f74c25f5c17c528a75138ad08722c835feb4cd7edac8fcafb9746481b8bdc44"
DEPENDS += "mtools-native"
COMPATIBLE_MACHINE = "(dragonboard-410c)"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-S = "${WORKDIR}/linux-ubuntu-board-support-package-v1.2"
+S = "${WORKDIR}/linux-board-support-package-v1.3"
python qcom_bin_do_unpack() {
src_uri = (d.getVar('SRC_URI', True) or "").split()
@@ -75,10 +75,10 @@ do_compile() {
do_install() {
install -d ${D}/lib/firmware/
- rm -f ./proprietary-ubuntu/firmware.tar
- cp -r ./proprietary-ubuntu/* ${D}/lib/firmware/
+ rm -f ./proprietary-linux/firmware.tar
+ cp -r ./proprietary-linux/* ${D}/lib/firmware/
- MTOOLS_SKIP_CHECK=1 mcopy -i ./bootloaders-ubuntu/NON-HLOS.bin \
+ MTOOLS_SKIP_CHECK=1 mcopy -i ./bootloaders-linux/NON-HLOS.bin \
::image/modem.* ::image/mba.mbn ${D}/lib/firmware/
install -d ${D}${sysconfdir}/
diff --git a/recipes-bsp/firmware/firmware-qcom-sd-600eval_1.0.bb b/recipes-bsp/firmware/firmware-qcom-sd-600eval_1.0.bb
new file mode 100644
index 0000000..c4199c6
--- /dev/null
+++ b/recipes-bsp/firmware/firmware-qcom-sd-600eval_1.0.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "QCOM Firmware for DragonBoard 410c"
+
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://license.txt;md5=c09af6bc68c68f92e6a711634ee5cb14"
+
+SRC_URI = "https://eragon.einfochips.com/media/wysiwyg/datasheet/SD_600eval-linux_proprietary_firmware-v${PV}.zip"
+SRC_URI[md5sum] = "0903e9f656d3cea005ecc8e26f1243b2"
+SRC_URI[sha256sum] = "fdffcb2cedc0d0215ee3dec95ce3683a780d9280960d27200379fbe1b21af979"
+
+COMPATIBLE_MACHINE = "(sd-600eval)"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+S = "${WORKDIR}/SD_600eval-linux_proprietary_firmware-v${PV}"
+
+do_compile() {
+ :
+}
+
+do_install() {
+ install -d ${D}/lib/firmware/
+ cp -a * ${D}/lib/firmware/
+
+ install -d ${D}${sysconfdir}/
+ install -m 0644 license.txt ${D}${sysconfdir}/
+}
+
+FILES_${PN} += "/lib/firmware/*"
+INSANE_SKIP_${PN} += "arch"
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index c22ada0..8daec35 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,10 +1,13 @@
# Enable freedreno driver
-GALLIUMDRIVERS_append_ifc6410 = ",freedreno"
-GALLIUMDRIVERS_append_dragonboard-410c = ",freedreno"
+GALLIUMDRIVERS_append_apq8064 = ",freedreno"
+GALLIUMDRIVERS_append_apq8016 = ",freedreno"
-PACKAGECONFIG_append_ifc6410 = " gallium \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
- "
-PACKAGECONFIG_append_dragonboard-410c = " gallium \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
- "
+PACKAGECONFIG_append_apq8064 = " \
+ gallium \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
+"
+
+PACKAGECONFIG_append_apq8016 = " \
+ gallium \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
+"
diff --git a/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bb b/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bb
index 689c444..1b1c451 100644
--- a/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bb
+++ b/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bb
@@ -11,10 +11,10 @@ LOCALVERSION ?= "-linaro-lt-qcom"
SRCBRANCH ?= "release/qcomlt-4.4"
SRCREV ?= "f404da21e128bc015dfcbb88d3daf2bcf18ef872"
-COMPATIBLE_MACHINE = "(ifc6410|dragonboard-410c)"
+COMPATIBLE_MACHINE = "(ifc6410|sd-600eval|dragonboard-410c)"
-KERNEL_DEFCONFIG_dragonboard-410c ?= "${S}/arch/arm64/configs/defconfig"
-KERNEL_DEFCONFIG_ifc6410 ?= "${S}/arch/arm/configs/qcom_defconfig"
+KERNEL_DEFCONFIG_apq8016 ?= "${S}/arch/arm64/configs/defconfig"
+KERNEL_DEFCONFIG_apq8064 ?= "${S}/arch/arm/configs/qcom_defconfig"
KERNEL_CONFIG_FRAGMENTS += "${S}/kernel/configs/distro.config"
# fixup.bin needs to be prepended to zImage to fixup the atag mem info because of broken bootloaders.
@@ -28,7 +28,7 @@ do_compile_append_ifc6410() {
}
# append DTB, since bootloader doesn't support DTB
-do_compile_append_ifc6410() {
+do_compile_append_apq8064() {
if ! [ -e ${B}/arch/${ARCH}/boot/dts/${KERNEL_DEVICETREE} ] ; then
oe_runmake ${KERNEL_DEVICETREE}
fi
@@ -42,3 +42,4 @@ ERROR_QA_remove = "arch"
QCOM_BOOTIMG_ROOTFS_dragonboard-410c = "mmcblk0p10"
QCOM_BOOTIMG_ROOTFS_ifc6410 = "mmcblk0p12"
+QCOM_BOOTIMG_ROOTFS_sd-600eval = "mmcblk0p12"
diff --git a/recipes-kernel/linux/linux-qcom-bootimg.inc b/recipes-kernel/linux/linux-qcom-bootimg.inc
index 78c6bd7..96e1496 100644
--- a/recipes-kernel/linux/linux-qcom-bootimg.inc
+++ b/recipes-kernel/linux/linux-qcom-bootimg.inc
@@ -13,7 +13,7 @@ DT_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
BOOT_IMAGE_BASE_NAME = "boot-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}"
BOOT_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
-do_deploy_append_dragonboard-410c() {
+do_deploy_append_apq8016() {
dtbTool -o ${DEPLOYDIR}/${DT_IMAGE_BASE_NAME}.img -s 2048 ${B}/arch/${ARCH}/boot/dts/qcom/
@@ -40,7 +40,7 @@ do_deploy_append_dragonboard-410c() {
cd -
}
-do_deploy_append_ifc6410 () {
+do_deploy_append_apq8064 () {
tmp="${SERIAL_CONSOLES}"
baudrate=`echo $tmp | sed 's/\;.*//'`
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
index fa6ba2b..13d759a 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
@@ -1,5 +1,5 @@
GST_BAD_OPENGL_FEATURES= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'gles2', 'opengl', d)}"
# We want OpenGL with freedreno for our machines
-PACKAGECONFIG_GL_ifc6410 = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${GST_BAD_OPENGL_FEATURES}', '', d)}"
-PACKAGECONFIG_GL_dragonboard-410c = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${GST_BAD_OPENGL_FEATURES}', '', d)}"
+PACKAGECONFIG_GL_apq8064 = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${GST_BAD_OPENGL_FEATURES}', '', d)}"
+PACKAGECONFIG_GL_apq8016 = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${GST_BAD_OPENGL_FEATURES}', '', d)}"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-v4l2.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-v4l2.bb
index b5b165a..f19693a 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-v4l2.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-v4l2.bb
@@ -10,9 +10,10 @@ LICENSE = "GPLv2+ & LGPLv2.1+"
SRCREV_FORMAT = "plugin-common"
-SRC_URI = " git://git.linaro.org/landing-teams/working/qualcomm/pkg/gst-plugins-v4l2.git;protocol=https;branch=debian;name=plugin \
- git://anongit.freedesktop.org/gstreamer/common;name=common;branch=master;destsuffix=git/common \
- file://remove-git-from-autogen.patch \
+SRC_URI = " \
+ git://git.linaro.org/landing-teams/working/qualcomm/pkg/gst-plugins-v4l2.git;protocol=https;branch=debian;name=plugin \
+ git://anongit.freedesktop.org/gstreamer/common;name=common;branch=master;destsuffix=git/common \
+ file://remove-git-from-autogen.patch \
"
SRCREV_plugin = "0d051f538fe00c8a79fcf12a05a6dac3a9af7dd7"