aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf2
-rw-r--r--conf/machine/include/qcom-apq8016.inc4
-rw-r--r--conf/machine/include/qcom-apq8096.inc4
-rw-r--r--conf/machine/include/qcom-sdm845.inc5
-rw-r--r--dynamic-layers/networking-layer/recipes-test/images/initramfs-test-image.bbappend5
-rw-r--r--dynamic-layers/openembedded-layer/recipes-test/images/initramfs-test-image.bbappend3
-rw-r--r--recipes-kernel/linux/linux-linaro-qcomlt_5.4.bb2
-rw-r--r--recipes-support/adsprpc/adsprpc_git.bb14
-rw-r--r--recipes-support/fastrpc/fastrpc_git.bb15
-rw-r--r--recipes-support/qrtr/qrtr_git.bb2
-rw-r--r--recipes-test/diag/diag_git.bb2
-rw-r--r--recipes-test/images/initramfs-test-image.bb11
12 files changed, 47 insertions, 22 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 29f088c..c564ce3 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -13,4 +13,6 @@ LAYERSERIES_COMPAT_qcom = "zeus"
BBFILES_DYNAMIC += " \
openembedded-layer:${LAYERDIR}/dynamic-layers/openembedded-layer/*/*/*.bb \
openembedded-layer:${LAYERDIR}/dynamic-layers/openembedded-layer/*/*/*.bbappend \
+ networking-layer:${LAYERDIR}/dynamic-layers/networking-layer/*/*/*.bb \
+ networking-layer:${LAYERDIR}/dynamic-layers/networking-layer/*/*/*.bbappend \
"
diff --git a/conf/machine/include/qcom-apq8016.inc b/conf/machine/include/qcom-apq8016.inc
index 08bd660..2688b20 100644
--- a/conf/machine/include/qcom-apq8016.inc
+++ b/conf/machine/include/qcom-apq8016.inc
@@ -27,6 +27,10 @@ MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += " \
rmtfs \
"
+MACHINE_EXTRA_RRECOMMENDS += " \
+ fastrpc \
+"
+
# Fastboot expects an ext4 image, which needs to be 4096 aligned
IMAGE_FSTYPES ?= "ext4.gz"
IMAGE_ROOTFS_ALIGNMENT = "4096"
diff --git a/conf/machine/include/qcom-apq8096.inc b/conf/machine/include/qcom-apq8096.inc
index 5c65f12..3a6a08b 100644
--- a/conf/machine/include/qcom-apq8096.inc
+++ b/conf/machine/include/qcom-apq8096.inc
@@ -28,6 +28,10 @@ MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += " \
rmtfs \
"
+MACHINE_EXTRA_RRECOMMENDS += " \
+ fastrpc \
+"
+
# Fastboot expects an ext4 image, which needs to be 4096 aligned
IMAGE_FSTYPES ?= "ext4.gz"
IMAGE_ROOTFS_ALIGNMENT = "4096"
diff --git a/conf/machine/include/qcom-sdm845.inc b/conf/machine/include/qcom-sdm845.inc
index 7f6a1c2..e3839b1 100644
--- a/conf/machine/include/qcom-sdm845.inc
+++ b/conf/machine/include/qcom-sdm845.inc
@@ -24,13 +24,16 @@ PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
PREFERRED_PROVIDER_virtual/kernel ?= "linux-linaro-qcomlt"
MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += " \
- adsprpc \
pd-mapper \
qrtr \
rmtfs \
tqftpserv \
"
+MACHINE_EXTRA_RRECOMMENDS += " \
+ fastrpc \
+"
+
IMAGE_FSTYPES ?= "ext4.gz"
IMAGE_ROOTFS_ALIGNMENT = "4096"
diff --git a/dynamic-layers/networking-layer/recipes-test/images/initramfs-test-image.bbappend b/dynamic-layers/networking-layer/recipes-test/images/initramfs-test-image.bbappend
new file mode 100644
index 0000000..bd946f8
--- /dev/null
+++ b/dynamic-layers/networking-layer/recipes-test/images/initramfs-test-image.bbappend
@@ -0,0 +1,5 @@
+PACKAGE_INSTALL += " \
+ iperf2 \
+ iperf3 \
+ tcpdump \
+"
diff --git a/dynamic-layers/openembedded-layer/recipes-test/images/initramfs-test-image.bbappend b/dynamic-layers/openembedded-layer/recipes-test/images/initramfs-test-image.bbappend
new file mode 100644
index 0000000..16f4e3c
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-test/images/initramfs-test-image.bbappend
@@ -0,0 +1,3 @@
+PACKAGE_INSTALL += " \
+ devmem2 \
+"
diff --git a/recipes-kernel/linux/linux-linaro-qcomlt_5.4.bb b/recipes-kernel/linux/linux-linaro-qcomlt_5.4.bb
index 3ae2f0f..31897ce 100644
--- a/recipes-kernel/linux/linux-linaro-qcomlt_5.4.bb
+++ b/recipes-kernel/linux/linux-linaro-qcomlt_5.4.bb
@@ -11,7 +11,7 @@ require recipes-kernel/linux/linux-qcom-bootimg.inc
LOCALVERSION ?= "-linaro-lt-qcom"
SRCBRANCH ?= "release/qcomlt-5.4"
-SRCREV ?= "37a87299c86289371173ba70c186b9201ba0f4fc"
+SRCREV ?= "8c79b3d123550fde184d9ef6b3d5e2e530abe0bd"
COMPATIBLE_MACHINE = "(apq8016|apq8096|sdm845)"
diff --git a/recipes-support/adsprpc/adsprpc_git.bb b/recipes-support/adsprpc/adsprpc_git.bb
deleted file mode 100644
index 430c1ee..0000000
--- a/recipes-support/adsprpc/adsprpc_git.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-HOMEPAGE = "https://git.linaro.org/landing-teams/working/qualcomm/libadsprpc.git"
-SECTION = "devel"
-
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e868d7526728e9b1c0c4f34730d27754"
-
-SRCREV = "741c1415df731503b3aea8b754223a871081d2f3"
-SRC_URI = "git://git.linaro.org/landing-teams/working/qualcomm/libadsprpc.git;branch=master;protocol=https"
-
-PV = "0.0+${SRCPV}"
-
-S = "${WORKDIR}/git"
-
-inherit autotools
diff --git a/recipes-support/fastrpc/fastrpc_git.bb b/recipes-support/fastrpc/fastrpc_git.bb
new file mode 100644
index 0000000..3aa67a7
--- /dev/null
+++ b/recipes-support/fastrpc/fastrpc_git.bb
@@ -0,0 +1,15 @@
+HOMEPAGE = "https://git.linaro.org/landing-teams/working/qualcomm/fastrpc.git"
+SUMMARY = "Qualcomm FastRPC applications and library"
+SECTION = "devel"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://src/fastrpc_apps_user.c;beginline=1;endline=29;md5=f94f3a7beba14ae2f59f817e9634f891"
+
+SRCREV = "388d868b3146fa7ccbeb6aa8c71485ebbbf5e1b9"
+SRC_URI = "git://git.linaro.org/landing-teams/working/qualcomm/fastrpc.git;branch=automake;protocol=https"
+
+PV = "0.0+${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
diff --git a/recipes-support/qrtr/qrtr_git.bb b/recipes-support/qrtr/qrtr_git.bb
index 03566db..51c342b 100644
--- a/recipes-support/qrtr/qrtr_git.bb
+++ b/recipes-support/qrtr/qrtr_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=15329706fbfcb5fc5edcc1bc7c139da5"
inherit systemd
-SRCREV = "cd6bedd5d00f211e6c1e3803ff2f9f53c246435e"
+SRCREV = "7bd5cf302437755b0d741c9dc1805395a9654597"
SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https"
PV = "0.0+${SRCPV}"
diff --git a/recipes-test/diag/diag_git.bb b/recipes-test/diag/diag_git.bb
index 3fa4529..a0e9023 100644
--- a/recipes-test/diag/diag_git.bb
+++ b/recipes-test/diag/diag_git.bb
@@ -7,7 +7,7 @@ SRC_URI = "git://github.com/andersson/diag.git;protocol=https \
"
PV = "0.0+git${SRCPV}"
-SRCREV = "5ef6b6b0c50047be3dd456d91d9a6dd730ba99e2"
+SRCREV = "cc5dc0dec3f584d4a500fa36b983e6e77a98e478"
S = "${WORKDIR}/git"
diff --git a/recipes-test/images/initramfs-test-image.bb b/recipes-test/images/initramfs-test-image.bb
index 3fe75f9..16eafef 100644
--- a/recipes-test/images/initramfs-test-image.bb
+++ b/recipes-test/images/initramfs-test-image.bb
@@ -2,20 +2,23 @@ DESCRIPTION = "Small ramdisk image for running tests (bootrr, etc)"
PACKAGE_INSTALL = " \
${ROOTFS_BOOTSTRAP_INSTALL} \
+ bluez5 \
busybox \
base-passwd \
- devmem2 \
+ dhcp-client \
diag \
ethtool \
gptfdisk \
- iperf2 \
- iperf3 \
lava-test-shell \
packagegroup-core-boot \
+ pciutils \
+ pd-mapper \
qrtr \
rmtfs \
- tcpdump \
+ tqftpserv \
udev \
+ usbutils \
+ wpa-supplicant \
"
# Do not pollute the initrd image with rootfs features