aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/dragonboard-845c.conf21
-rw-r--r--conf/machine/include/qcom-sdm845.inc32
-rw-r--r--recipes-kernel/linux/linux-linaro-qcom.inc1
-rw-r--r--recipes-kernel/linux/linux-linaro-qcomlt_4.14.bb1
-rw-r--r--recipes-kernel/linux/linux-linaro-qcomlt_5.1.bb19
5 files changed, 73 insertions, 1 deletions
diff --git a/conf/machine/dragonboard-845c.conf b/conf/machine/dragonboard-845c.conf
new file mode 100644
index 0000000..8b82657
--- /dev/null
+++ b/conf/machine/dragonboard-845c.conf
@@ -0,0 +1,21 @@
+#@TYPE: Machine
+#@NAME: dragonboard-845c
+#@DESCRIPTION: Machine configuration for the DragonBoard 845c (96boards), with Qualcomm Snapdragon 845 SDM845.
+
+require conf/machine/include/qcom-sdm845.inc
+
+MACHINE_FEATURES = "usbhost usbgadget alsa screen wifi bluetooth ext2"
+
+KERNEL_IMAGETYPE ?= "Image.gz"
+KERNEL_DEVICETREE ?= "qcom/sdm845-db845c.dtb"
+
+SERIAL_CONSOLE ?= "115200 ttyMSM0"
+
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += " \
+ kernel-modules \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-msm', '', d)} \
+"
+
+# XXX: The sda10 is userdata we need to create an Linux gpt to have more space
+# and use rootfs
+QCOM_BOOTIMG_ROOTFS ?= "sda10"
diff --git a/conf/machine/include/qcom-sdm845.inc b/conf/machine/include/qcom-sdm845.inc
new file mode 100644
index 0000000..2526d2f
--- /dev/null
+++ b/conf/machine/include/qcom-sdm845.inc
@@ -0,0 +1,32 @@
+SOC_FAMILY = "sdm845"
+require conf/machine/include/soc-family.inc
+require conf/machine/include/arm/arch-armv8.inc
+
+XSERVER_OPENGL ?= " \
+ xf86-video-modesetting \
+ xserver-xorg-extension-glx \
+"
+
+XSERVER ?= " \
+ xserver-xorg \
+ xserver-xorg-module-libint10 \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${XSERVER_OPENGL}', 'xf86-video-fbdev', d)} \
+ xf86-input-evdev \
+ xf86-input-mouse \
+ xf86-input-keyboard \
+"
+
+PREFERRED_PROVIDER_virtual/egl ?= "mesa"
+PREFERRED_PROVIDER_virtual/libgl ?= "mesa"
+PREFERRED_PROVIDER_virtual/libgles1 ?= "mesa"
+PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa"
+PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-linaro-qcomlt"
+
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += " \
+"
+
+IMAGE_FSTYPES ?= "ext4.gz"
+
+QCOM_BOOTIMG_KERNEL_BASE ?= "0x80000000"
+QCOM_BOOTIMG_PAGE_SIZE ?= "4096"
diff --git a/recipes-kernel/linux/linux-linaro-qcom.inc b/recipes-kernel/linux/linux-linaro-qcom.inc
index cabf17d..21f0ae6 100644
--- a/recipes-kernel/linux/linux-linaro-qcom.inc
+++ b/recipes-kernel/linux/linux-linaro-qcom.inc
@@ -4,7 +4,6 @@
DESCRIPTION = "Linux kernel for MSM platforms"
LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
inherit kernel
diff --git a/recipes-kernel/linux/linux-linaro-qcomlt_4.14.bb b/recipes-kernel/linux/linux-linaro-qcomlt_4.14.bb
index 22942d2..40b202f 100644
--- a/recipes-kernel/linux/linux-linaro-qcomlt_4.14.bb
+++ b/recipes-kernel/linux/linux-linaro-qcomlt_4.14.bb
@@ -2,6 +2,7 @@
# Released under the MIT license (see COPYING.MIT for the terms)
DESCRIPTION = "Linaro Qualcomm Landing team 4.14 Kernel"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
inherit pythonnative
diff --git a/recipes-kernel/linux/linux-linaro-qcomlt_5.1.bb b/recipes-kernel/linux/linux-linaro-qcomlt_5.1.bb
new file mode 100644
index 0000000..5f915b6
--- /dev/null
+++ b/recipes-kernel/linux/linux-linaro-qcomlt_5.1.bb
@@ -0,0 +1,19 @@
+# Copyright (C) 2014-2019 Linaro
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Linaro Qualcomm Landing team 5.1 Kernel"
+LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
+
+inherit pythonnative
+
+require recipes-kernel/linux/linux-linaro-qcom.inc
+require recipes-kernel/linux/linux-qcom-bootimg.inc
+
+LOCALVERSION ?= "-linaro-lt-qcom"
+SRCBRANCH ?= "release/db845c/qcomlt-5.1"
+SRCREV ?= "5f45ef7de008123ffcc5d2433545e97861e19bcf"
+
+COMPATIBLE_MACHINE = "(sdm845)"
+
+# Wifi firmware has a recognizable arch :(
+ERROR_QA_remove = "arch"