aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/include/qcom-apq8016.inc4
-rw-r--r--conf/machine/include/qcom-apq8064.inc4
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend4
3 files changed, 6 insertions, 6 deletions
diff --git a/conf/machine/include/qcom-apq8016.inc b/conf/machine/include/qcom-apq8016.inc
index 1b78294..ffb1517 100644
--- a/conf/machine/include/qcom-apq8016.inc
+++ b/conf/machine/include/qcom-apq8016.inc
@@ -2,10 +2,8 @@ SOC_FAMILY = "apq8016"
require conf/machine/include/soc-family.inc
XSERVER_OPENGL ?= " \
- xf86-video-freedreno \
- xserver-xorg-module-exa \
+ xf86-video-modesetting \
xserver-xorg-extension-glx \
- xserver-xorg-extension-dri \
"
XSERVER ?= " \
diff --git a/conf/machine/include/qcom-apq8064.inc b/conf/machine/include/qcom-apq8064.inc
index def4903..edb06d6 100644
--- a/conf/machine/include/qcom-apq8064.inc
+++ b/conf/machine/include/qcom-apq8064.inc
@@ -2,10 +2,8 @@ SOC_FAMILY = "apq8064"
require conf/machine/include/soc-family.inc
require conf/machine/include/tune-cortexa8.inc
-XSERVER_OPENGL ?= "xf86-video-freedreno \
- xserver-xorg-module-exa \
+XSERVER_OPENGL ?= "xf86-video-modesetting \
xserver-xorg-extension-glx \
- xserver-xorg-extension-dri \
"
XSERVER = " \
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
new file mode 100644
index 0000000..286d6ba
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
@@ -0,0 +1,4 @@
+# We want to use modesetting + glamor with mesa freedreno driver
+# http://bloggingthemonkey.blogspot.fr/2016/11/a-quick-note-for-usersdistros.html
+PACKAGECONFIG_append_apq8064 = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', ' dri3 xshmfence glamor', '', d)}"
+PACKAGECONFIG_append_apq8016 = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', ' dri3 xshmfence glamor', '', d)}"